Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: [Help] Two intel express chipsets show up in device manager.

19 Aug 2010   #1
Ree7

Windows 7 Ultimate
 
 
[Help] Two intel express chipsets show up in device manager.

My laptop is a Vaio VGN-SZ38GP/C.
It was loaded with XP when I bought it, but has been clean installed with Windows 7 without any problems for the past year. I used a graphic driver with a modified inf to install the video card driver (the laptop came with nVidia Geforce Go 7400). All was fine.

Now here's the problem.
Two days ago, when I turned on the laptop, the display went small (it doesn't cover the entire screen). After it entered into Windows, a message pops up: 'new device has been detected', it was then installed etc. The new device turns out to be an Intel Express Chipset. After that, it required me to reboot the system. After the system was rebooted, all seems well, the display once again covered the entire screen.

However, I found out that the laptop is currently not utilizing the video card (it doesn't even shows up under device manager). There's not even a 'standard vga adapter' entry in it. None under display adapters. None under other devices. Couldn't find it.

And turns out the STAMINA-SPEED switch on my laptop isn't working (Vaio SZ has a STAMINA mode that preserves the battery by switching off the video card). I put the switch on SPEED, but the led indicator stays on STAMINA. Windows doesn't even seem to recognize any changes I made in switching between the modes back and forth.

Also, another weird thing right now is that the device manager shows that I have two Intel Express Chipsets when I turned on the 'show hidden devices' option. Both with identical hardware IDs.
PCI\VEN_8086&DEV_27A2&SUBSYS_81E6104D&REV_03
  • I've tried to do a system restore to no avail.
  • Updated the bios to no avail.
  • Look for ways to switch off the onboard video card via bios, but seems like there's no apparent setting for it. Its a Phoenix Technologies'.
  • Uninstalled both Intel Express Chipsets and then reboot. The laptop simply turns back to the small screen not covering the entire display.
  • Downloaded and installed another 189.79 nVidia driver with modded inf. It says no supported hardware has been detected, even after uninstalling both Intel Expres Chipset drivers.

I didn't make any changes in programs/softwares whatsoever before the problem occurred. Right now I am beginning to think that either a Windows Automatic Update has installed something or the video card has simply died.

Helps and suggestions are greatly appreciated.




Attached Thumbnails
[Help] Two intel express chipsets show up in device manager.-two-intel-express-chipsets.jpg  
My System SpecsSystem Spec
.
19 Aug 2010   #2
BCXtreme

Windows 7 Home Premium x64
 
 

Welcome to the Seven Forums!

Firstly, just so we can make sure it wasn't Windows Update, do you have Windows Update set to automatically install Recommended/Optional updates, or only Important updates?
My System SpecsSystem Spec
19 Aug 2010   #3
Lemur

Systems 1 and 2: Windows 7 Enterprise x64, Win 8 Developer
 
 

We could install the latest drivers for the Intel 945 chipset: http://downloadcenter.intel.com/Sear...Chipset+Family
My System SpecsSystem Spec
.

19 Aug 2010   #4
Ree7

Windows 7 Ultimate
 
 

Quote   Quote: Originally Posted by BCXtreme View Post
Welcome to the Seven Forums!

Firstly, just so we can make sure it wasn't Windows Update, do you have Windows Update set to automatically install Recommended/Optional updates, or only Important updates?
I chose the option for windows updates not to download and install updates automatically. But almost everytime I installed every available important updates while leaving the optional updates untouched (currently I think the optional updates list is filled with language packs).

Quote   Quote: Originally Posted by Lemur View Post
We could install the latest drivers for the Intel 945 chipset: http://downloadcenter.intel.com/Sear...Chipset+Family
Thanks for the link! I'll try it out once I get home later tonight and let you know how it goes.
My System SpecsSystem Spec
19 Aug 2010   #5
Petey7

Windows 7 Professional SP1 64-bit
 
 

It sounds like you have two GPUs, integrated intel graphics and the NVIDIA graphics card, and something has happened to the NVIDIA GPU.

I found this and this which supports that theory.

Note the part about the hybrid graphics system.
My System SpecsSystem Spec
19 Aug 2010   #6
Ree7

Windows 7 Ultimate
 
 

Quote   Quote: Originally Posted by Petey7 View Post
It sounds like you have two GPUs, integrated intel graphics and the NVIDIA graphics card, and something has happened to the NVIDIA GPU.

I found this and this which supports that theory.

Note the part about the hybrid graphics system.
Yes you're correct. It has an integrated intel graphics plus an NVIDIA graphics card. But since that day, the NVIDIA cannot be detected. Instead, it showed up in device manager as two intel graphics with the same hardware IDs.

And as you can also see from the website, there's a switch with led that determines the GPU its using. I've always been using the SPEED mode, but somehow that day the STAMINA led lights up even though the switch was still on SPEED.
My System SpecsSystem Spec
19 Aug 2010   #7
Petey7

Windows 7 Professional SP1 64-bit
 
 

It sounds the NVIDIA GPU is burnt out. If this is the case, it will have to be replaced, or you will have to live with Intel graphics.

Is the laptop still under warranty?
My System SpecsSystem Spec
20 Aug 2010   #8
Ree7

Windows 7 Ultimate
 
 

Quote   Quote: Originally Posted by Lemur View Post
We could install the latest drivers for the Intel 945 chipset: http://downloadcenter.intel.com/Sear...Chipset+Family
The latest driver from the link you gave is the same version as the one that windows installed during device detection. Still, I gave it a shot by reinstalling it and the NVIDIA GPU still doesn't show up anywhere.

Quote   Quote: Originally Posted by Petey7 View Post
It sounds the NVIDIA GPU is burnt out. If this is the case, it will have to be replaced, or you will have to live with Intel graphics.

Is the laptop still under warranty?
That's the worst case I am afraid of. Its no longer under warranty either (+- 4 year-old laptop).

Any chance to upgrade such GPU to some newer ones?
My System SpecsSystem Spec
20 Aug 2010   #9
Petey7

Windows 7 Professional SP1 64-bit
 
 

It's not common for you to be able to do it in a laptop, but there are some exceptions. Looking online, I can't find one. I can't even find a motherboard for it. Laptops are only expected to last +/- five years. Have you noticed anything else not working on the laptop?
My System SpecsSystem Spec
20 Aug 2010   #10
Ree7

Windows 7 Ultimate
 
 

Quote   Quote: Originally Posted by Petey7 View Post
It's not common for you to be able to do it in a laptop, but there are some exceptions. Looking online, I can't find one. I can't even find a motherboard for it. Laptops are only expected to last +/- five years. Have you noticed anything else not working on the laptop?
Is there anyway for me to check what type of motherboard its using?
So far everything else is working fine, except for 4 bluetooth peripherals showing up under other devices in device manager missing their appropriate drivers. Couldn't find any drivers for those, but otherwise the bluetooth functionality still works fine (able to sync with my phone, send files etc).
My System SpecsSystem Spec
Reply

 [Help] Two intel express chipsets show up in device manager.




Thread Tools




Similar help and support threads
Thread Forum
External drives show in Device Manager & Disk Manager but not Computer
Two of my USB external Hard drives, a Fantom 600 GB and a Western Digital My Book 500GB cannot be seen in My Computer. I can see them in Device Manager and that says that they are working properly and the drivers are up to Date. In Disk Manager the 2 external drives had a black bar unlike the...
Hardware & Devices
Unknown Device in Device Manager/Show Hidden Devices
I have a Toshiba laptop, model L505-ES5018. I had Windows 7 Home Premium 64 bit installed on here, but decided to reformat my hard drive using Windows 7 Ultimate 64 bit. After the reformat was finished, I ran Windows Update and it found several items to download and install for me. I noticed...
Drivers
Cd/dvd rom not show in device manager or in computer
Hello all..... Ty for any help with promble even before i get started ty ty...... I have a hp pavillon dv-9000 running win 7 pro.......this laptop when give to me was in bad shape.... At one point i had the cd/dvd rom drive working yet in the middle of loading windows files it stoped...
Hardware & Devices
Onboard LAN wont show in Device Manager
Hello, I have a Jetway PA78VM5-H-LF motherboard. Newegg.com - JetWay JPA78VM5-H-LF AM2+/AM2 AMD 780V HDMI Micro ATX AMD Motherboard It's discontinued. Downloaded the lan drivers for the onboard lan at Jetway.
Hardware & Devices
Device Manager And Having Ports Listings Show Up ?
Hi, Opened up Device Manager to look at settings for the various Com "Ports" in use and just can't see any listed. Here's a snap of what I have. Where do they show, or how can I make them show up ? Thanks, Bob
Hardware & Devices
Realtek doesn't show in Device Manager
Hi guys, I'm trying to get Realtek installed and i do manage to install it without getting a failure message or whatsoever. But the problem is that it does not work. I installed and removed many codecs and versions of realtek, it just doesn't show in the device manager. The only thing...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:04.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App