Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: ATI Mobility HD3470 Showing up as HD3450?

22 Jun 2009   #1
samstar1412

32bit-Vista Home Premium SP2, 32bit-Windows 7 Ultimate RC, also got Mac OS X 10.5.7 (in VMware)
 
 
ATI Mobility HD3470 Showing up as HD3450?

Well i have just recently dual booted Windows 7 RC (32bit) with my oem Vista Home Premium(32bit) install and i have finally got ATI Catalyst to install with help from Mobility Modder. The only downfall is my graphics card (hd3470) is showing up in ATI Catalyst and Device Manager as an hd3450. Now as some people would no the hd3470 is in fact an overclocked hd3450. So i am running lousier clock settings now and was wondering if anyone could help me out with this small but very annoying problem?
Also im very sorry if this has already been answered..


My System SpecsSystem Spec
.
22 Jun 2009   #2
DaRonRon

Main OS: Windows 7 64 bit, Secondary: Vista 32 bit
 
 

hi mate,

yes this problem is pretty widespread with people that use mobility modder. It even happened to me (i have the same card as you). Just to let u know, dont worry about it, u wont get any performance downgrade as a result. The reason for it displaying the wrong card has something to do with both cards having the same id or something and mobility modder doesnt distinguish between them.

Having said that there is a way to make it display the correct card. Have a look here:

» HD 3470 is 3450?

But just an idea. U do know that ati is releasing official drivers for ur exact model on mobility? Just download the drivers from here and install without modding Works perfect, and no need to modify!

Graphics Drivers & Software

Just choose ur os and ur set
My System SpecsSystem Spec
22 Jun 2009   #3
samstar1412

32bit-Vista Home Premium SP2, 32bit-Windows 7 Ultimate RC, also got Mac OS X 10.5.7 (in VMware)
 
 

Thanks for the quick reply but i already tried installing the official drivers and ati catalyst 9.6 and they just wouldn't install at all so i used mobility modder to modify the catalyst 9.6 drivers and install and then it installed first shot. Also thanks for the link to the other forum i'll check it out.
My System SpecsSystem Spec
.

22 Jun 2009   #4
DaRonRon

Main OS: Windows 7 64 bit, Secondary: Vista 32 bit
 
 

Quote   Quote: Originally Posted by samstar1412 View Post
Thanks for the quick reply but i already tried installing the official drivers and ati catalyst 9.6 and they just wouldn't install at all so i used mobility modder to modify the catalyst 9.6 drivers and install and then it installed first shot. Also thanks for the link to the other forum i'll check it out.
hmmm.. thats strange. Are u sure u didnt go onto the mobility radeon link rather than regular radeon after choosing windows 7 32 bit?

Oh and just to make sure, are u using windows 7 32 bit on a laptop right?
My System SpecsSystem Spec
22 Jun 2009   #5
samstar1412

32bit-Vista Home Premium SP2, 32bit-Windows 7 Ultimate RC, also got Mac OS X 10.5.7 (in VMware)
 
 

My install file is called: 9-6_vista32_win7_32_dd_ccc_wdm_enu. If that helps at all i dont know if its the mobility or regular radeon install. Should i download the regular radeon install and use that instead?
And yes this is on a laptop its an Asus M51Vr: 3gb ram, 2.4ghz intel centrino 2 (P8600), 320gb HDD, ATI Radeon Hd3470 256mb (obviously, thats why asked the question) and it came with Vista Home Premium SP1 32bit but i have upgraded that to SP2 Which is what i am dual booting with win7
My System SpecsSystem Spec
22 Jun 2009   #6
darkassain

Windows 7 Ult x64(x2), HomePrem x32(x4), Server 08 (+VM), 08 R2 (VM) , SuSe 11.2 (VM), XP 32 (VM)
 
 

if you can find the Ati inf's you can change the entries as shown in the forum link...
this is the important bit from the forum link
as i am away (meaning on vacation...:P) i cant tell the exact location...
Code:
"ATI MOBILITY RADEON HD 3450" = ati2mtag_M72, PCI\VEN_1002&DEV_95C9
"ATI Mobility Radeon HD 3470" = ati2mtag_M72, PCI\VEN_1002&DEV_95C4&SUBSYS_01381025
"ATI Mobility Radeon HD 3470 " = ati2mtag_M72, PCI\VEN_1002&DEV_95C4&SUBSYS_013B1025
"ATI Mobility Radeon HD 3470 " = ati2mtag_M72, PCI\VEN_1002&DEV_95C4&SUBSYS_011F1025
"ATI Mobility Radeon HD 3470 " = ati2mtag_M72, PCI\VEN_1002&DEV_95C4&SUBSYS_01491025
"ATI Mobility Radeon HD 3470 " = ati2mtag_M72, PCI\VEN_1002&DEV_95C4&SUBSYS_013F1025
"ATI Mobility Radeon HD 3470 " = ati2mtag_M72, PCI\VEN_1002&DEV_95C4&SUBSYS_011E1025
"ATI Mobility Radeon HD 3470 " = ati2mtag_M72, PCI\VEN_1002&DEV_95C4&SUBSYS_013C1025
"ATI Mobility Radeon HD 3470 " = ati2mtag_M72, PCI\VEN_1002&DEV_95C4&SUBSYS_013E1025
"ATI Mobility Radeon HD 3470 " = ati2mtag_M72, PCI\VEN_1002&DEV_95C4&SUBSYS_01211025
as you can see they all use the same "driver" which is ati2mtag_M72...
all this does is display that it is a 3470 and not 3450...
it does not in anyway slow down or hinder performance (unless a game goes by gfx names, but you can still tweak those setting to match your liking..)
My System SpecsSystem Spec
22 Jun 2009   #7
samstar1412

32bit-Vista Home Premium SP2, 32bit-Windows 7 Ultimate RC, also got Mac OS X 10.5.7 (in VMware)
 
 

Quote   Quote: Originally Posted by darkassain View Post
if you can find the Ati inf's you can change the entries as shown in the forum link...
this is the important bit from the forum link
as i am away (meaning on vacation...:P) i cant tell the exact location...
Code:
"ATI MOBILITY RADEON HD 3450" = ati2mtag_M72, PCI\VEN_1002&DEV_95C9
"ATI Mobility Radeon HD 3470" = ati2mtag_M72, PCI\VEN_1002&DEV_95C4&SUBSYS_01381025
"ATI Mobility Radeon HD 3470 " = ati2mtag_M72, PCI\VEN_1002&DEV_95C4&SUBSYS_013B1025
"ATI Mobility Radeon HD 3470 " = ati2mtag_M72, PCI\VEN_1002&DEV_95C4&SUBSYS_011F1025
"ATI Mobility Radeon HD 3470 " = ati2mtag_M72, PCI\VEN_1002&DEV_95C4&SUBSYS_01491025
"ATI Mobility Radeon HD 3470 " = ati2mtag_M72, PCI\VEN_1002&DEV_95C4&SUBSYS_013F1025
"ATI Mobility Radeon HD 3470 " = ati2mtag_M72, PCI\VEN_1002&DEV_95C4&SUBSYS_011E1025
"ATI Mobility Radeon HD 3470 " = ati2mtag_M72, PCI\VEN_1002&DEV_95C4&SUBSYS_013C1025
"ATI Mobility Radeon HD 3470 " = ati2mtag_M72, PCI\VEN_1002&DEV_95C4&SUBSYS_013E1025
"ATI Mobility Radeon HD 3470 " = ati2mtag_M72, PCI\VEN_1002&DEV_95C4&SUBSYS_01211025
as you can see they all use the same "driver" which is ati2mtag_M72...
all this does is display that it is a 3470 and not 3450...
it does not in anyway slow down or hinder performance (unless a game goes by gfx names, but you can still tweak those setting to match your liking..)
Yeah i think i might just leave it because i dont wana screw up my drivers again and i dont know where the drivers i need to edit are located
My System SpecsSystem Spec
22 Jun 2009   #8
DaRonRon

Main OS: Windows 7 64 bit, Secondary: Vista 32 bit
 
 

Quote   Quote: Originally Posted by samstar1412 View Post
My install file is called: 9-6_vista32_win7_32_dd_ccc_wdm_enu. If that helps at all i dont know if its the mobility or regular radeon install. Should i download the regular radeon install and use that instead?
And yes this is on a laptop its an Asus M51Vr: 3gb ram, 2.4ghz intel centrino 2 (P8600), 320gb HDD, ATI Radeon Hd3470 256mb (obviously, thats why asked the question) and it came with Vista Home Premium SP1 32bit but i have upgraded that to SP2 Which is what i am dual booting with win7
im pretty sure its mobility u should choose. Ok looking at the name of the file, it looks like u have the wrong file. It should look like "9-6_beta_win7_32_dd_CC".

Just click download from here:

ATI Catalystâ„¢ Mobility Display Driver

Let me know how it goes
My System SpecsSystem Spec
23 Jun 2009   #9
samstar1412

32bit-Vista Home Premium SP2, 32bit-Windows 7 Ultimate RC, also got Mac OS X 10.5.7 (in VMware)
 
 

I just tried that install you linked to and now my card just shows up as "ATI Mobility Radeon HD 3400 Series" and in GPU-Z it says the core clock is 250mhz and the memory is at 200mhz. The clock speed should be 450mhz and the memory 400+mhz(cant remember the exact frequency). Would it be possible to use rivatuner or amd gpu tool to re clock it back to the original?
My System SpecsSystem Spec
23 Jun 2009   #10
DaRonRon

Main OS: Windows 7 64 bit, Secondary: Vista 32 bit
 
 

Quote   Quote: Originally Posted by samstar1412 View Post
I just tried that install you linked to and now my card just shows up as "ATI Mobility Radeon HD 3400 Series" and in GPU-Z it says the core clock is 250mhz and the memory is at 200mhz. The clock speed should be 450mhz and the memory 400+mhz(cant remember the exact frequency). Would it be possible to use rivatuner or amd gpu tool to re clock it back to the original?
yes it should appear as HD 3400 series. However those clocks seem low, my GPU core clock is 337 mhz and memory clock is 396 mhz. Im not sure if u can use those tools because i've personally never but i cant see anything wrong with it. Go ahead
My System SpecsSystem Spec
Reply

 ATI Mobility HD3470 Showing up as HD3450?




Thread Tools




Similar help and support threads
Thread Forum
Will hd3450 agp work with nf3 and w7?
Hi, I have recently ordered a powercolor hd3450 512mb agp. I have a am2nf3-vsta motherboard, wich has a nForce3 250 chipset. I currently have a ati radeon 9250 128mb agp, with no official drivers for windows 7, but I downloaded a modded version here a few moths ago. It didnt have...
Graphic Cards
ATI HD3470 Mobility HDMI Audio output not working!!!
Hey guys I have a ASUS M51vr Notebook Running windows 7, I have the latest ATI Drivers for my ATI HD3470 mobility Plus latest Realtek HD drivers. My problem is when i plug in my hdmi output via my hdmi cable it doesn't make the new device detected sound it would make on vista then allow me to...
Sound & Audio
ATI Mobility HD3470 problem after standby
After standby sometimes on my Toshiba laptop can't load windows 7. After a few seconds I see blue scren with error and system restart. I use driver from toshiba site In action center error is: Description A problem with your video hardware caused Windows to stop working correctly. ...
Graphic Cards
Windows 7 Radeon HD3470 issue.
Hi, I'm on the verge of putting my foot through my girlfriends laptop, it's an Acer Aspire 5920G running Windows 7 X64. It seems that windows has installed it's stored version of the driver (version 8.56.1.15) the problem being this is causing issues in Maya and she needs the latest version....
Graphic Cards
ati hd3450 driver problem
I have tried to install all ati catalst control software so that I can use my tv out. I am useing win7 7100 this feature worked when I used win7 beta but I keep get the error install package failure can any ont come up with a fix for this. I have tried all methods of trying to install these...
Graphic Cards
ATI Radeon HD3470
Hey guys, I have another issue on my hands today. Inside my Asus M51Se laptop is an ATI Radeon HD 3470, 512MB VRAM, and 1024MB shared RAM. After installing Windows 7 build 7100 it says my card is an ATI Radeon 3450, and that I have 256MB VRAM, and another 1279MB shared RAM :confused: Can...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 19:33.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App