Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Installed new PSU and GFX and still doesnt work

07 Feb 2011   #11
i3rock

Windows 7 Ultimate 64Bit
 
 

Ok im not completely sure if the card is good or not but i bought it off a friend who had it working a month ago so i think it should be..

And sorry im not at home atm some cant exaclty remember the specs, but its something like
8750 x3 core AMD
650W Awyun 48A PSU
Asus Mobo
4GB Ram
1TB Harddrive
3850 WORKING card\
and the 4890 freezing on "Starting Windows" card

Well yea thats the basics
Cheers


My System SpecsSystem Spec
.
07 Feb 2011   #12
sygnus21

Windows 10 Pro
 
 

Well I suggest you find out if that card is working properly or you going to wind up chasing your tail 'round in circles.

Obviously the 3870 is working, so that says there's nothing wrong with the system. Also for what its worth I had a 4890 working rather well on a Antec 550watt power supply for a little over a year. So you 650 is plenty of power.

Again, check that the card is working.

Good luck.
My System SpecsSystem Spec
07 Feb 2011   #13
smarteyeball

 
 

With the 3870 in place - UNINSTALL the current ATI drivers and then use DriverSweeper in Safe Mode to clean the remnants.

Then replace the 3870 with the 4890 and install the drivers.

Where the hang is occurring is around the time time the generic video driver hands over to the ATI drivers. That's why the 4890 also works in safe mode, because it's using the generic VGA drivers.
My System SpecsSystem Spec
.

07 Feb 2011   #14
sygnus21

Windows 10 Pro
 
 

Quote   Quote: Originally Posted by smarteyeball View Post
Where the hang is occurring is around the time time the generic video driver hands over to the ATI drivers. That's why the 4890 also works in safe mode, because it's using the generic VGA drivers.
Very true.

However both cards use the same drivers, so again, check that the card is working.
My System SpecsSystem Spec
08 Feb 2011   #15
smarteyeball

 
 

Quote   Quote: Originally Posted by sygnus21 View Post

However both cards use the same drivers
The drivers may be the same, but when you add the existing CCC settings and all the different registry entries/switches into the mix for two different series of cards, you have a recipe for 'bugger' - it's not working


If after cleaning the drivers it still doesn't work - then you have to consider the card may indeed be faulty.
My System SpecsSystem Spec
10 Feb 2011   #16
i3rock

Windows 7 Ultimate 64Bit
 
 

Quote   Quote: Originally Posted by smarteyeball View Post
With the 3870 in place - UNINSTALL the current ATI drivers and then use DriverSweeper in Safe Mode to clean the remnants.

Then replace the 3870 with the 4890 and install the drivers.

Where the hang is occurring is around the time time the generic video driver hands over to the ATI drivers. That's why the 4890 also works in safe mode, because it's using the generic VGA drivers.
Sorry guys been busy for the past 2 days
Anyways found out what the problem was, I got my friend to bring over his download of the ATI driver and installed that using the 3870 after driversweeping
So then when i put the 4890 back in, it didnt freeze at Starting windows but instead showed a black screen afterwards

Which i later found out to be fixed as easy as doing this - Taking the power cable out of the monitor, leaving the DVI connected to both the monitor and card. Then when the computer is fully booted up(tell from the sounds) plug it back in. So as simple as that the monitor got a signal and started working, crazy huh
My System SpecsSystem Spec
11 Feb 2011   #17
fseal

Windows 7 x64 Ultimate
 
 

Do you need to do that every time now?

What probably happened was that wit the power off, the card/driver could not talk to the monitor to find out what modes it supported and it just went with "generic" settings. But when powered, something about the monitors communication with the card/driver causes the driver to put it into a mode that the monitor cannot actually handle.

This has been a problem for a while about monitors giving incorrect data about their capabilities but it wasn't till Vista that the information was taken and used on every boot. (On vista and 7 you can change monitors after install constantly and it rearranges the desktop to fit on the fly, whereas on XP and earlier it did not).
My System SpecsSystem Spec
Reply

 Installed new PSU and GFX and still doesnt work




Thread Tools




Similar help and support threads
Thread Forum
Win 7 Ult x64 Start doesnt work Icons dont work
Attempted a restore in Safe Mode. System came back up with all icons as normal. Issue start button doesn't work, icons open file but there is not text or data...there is what appears to be wire frames where the information should be. All files still on drive but cannot access. Safe mode does...
General Discussion
My mic doesnt work
Hello all, As the title says, my mic doesnt work! Yesterday is worked perfectly then i reset my computer and it stopped working. WHen i press my push to talk key in Teamspeak people hear there self and even hear the music i am playing through my headset, but they cant hear me. I did almost...
Sound & Audio
Mic doesnt work
Ok so ive been reading a lot and found that there is a large issue with mics not working properly in windows 7. here is my dilemma Imma make this quick: Came home to talk to buddy on skype. when i plugged in my mic and tried to call him, skype said there was a problem with my mic. under...
Sound & Audio
keyboard doesnt work!
well today i went on my computer, i typed in my pass and logged in.everything seemed fine so i decided to play combat arms. i got on and started playing but after 15-20 min it stopped working. the weird thing is that right after i died the keyboard stopped working. i tried 2 hours later then my...
Hardware & Devices
cd drive doesnt work
Hello, I installed windows 7 two weeks ago and everything worked well expect for the sound (5.1 doesnt work, still working on it). But yesterday when i wanted to watch a dvd my cd drive didnt work. i put it in but ni response but it in again and again no response. looked in "Computer" but it...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:05.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App