Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Wonky Screen Corruption Problem

28 Jun 2009   #11
johnsag49

Windows 7 RC 1
 
 

I was, and now am, using Nvidia latest drivers 186.86.


My System SpecsSystem Spec
.
28 Jun 2009   #12
icoola77

Windows 7 Home Basic 64bit
 
 

Well I went to nvidia's site and looked for latest drivers for Windows 7 that support your card and the site gave me this result :

GeForce/ION Driver Release 186 32bit

GeForce/ION Driver Release 186 64bit

These drivers are dated june 18. 2009
and it says it supports your card

Wonky Screen Corruption Problem-capture.png

Wonky Screen Corruption Problem-capture2.png

Wonky Screen Corruption Problem-capture3.png

Wonky Screen Corruption Problem-capture4.png




Maybe try with this driver?


My System SpecsSystem Spec
28 Jun 2009   #13
johnsag49

Windows 7 RC 1
 
 

186.86... and I've confirmed through the tubes that other people have had this problem as well. Looks like its a new videocard for me!
My System SpecsSystem Spec
.

04 Jul 2009   #14
johnsag49

Windows 7 RC 1
 
 

Well I picked up a Sapphire HD 3650 AGP card... when I finally found a driver that worked, it cleaned up the problem. So I guess the artifacts were an issue with the Nvidia drivers. Since the AGP bus is a dead interface, I assume no one will try to fix the problem. So this new card will hold me over until I'm ready to upgrade the whole system.
My System SpecsSystem Spec
05 Jul 2009   #15
gongoscho

Windows 7 x64
 
 

Hello,
i have exactly the same problem after first install!

Tests:
  • win7RC1x64 and win7Build7229x64
  • using latest nVIDIA x64 driver for win7
  • Switch to "Windows Classic" Theme i se the corruption
  • When i deactivate the "themes" service, i see nothing only the wonky screen corruption
  • STRG + ALT + DEL i see to the wonky screen corruption
  • In safemode, i have no problems

System, se My System Specs
My System SpecsSystem Spec
05 Jul 2009   #16
johnsag49

Windows 7 RC 1
 
 

Interesting, we both have the same motherboard, ASRock 4CoreDual Sata-2. I wonder if there's something weird going on with it? This ATI Sapphire card I've got now doesn't show any weird artifacts... so my feeling is it's some kind of problem with the lower end nvidia cards.
My System SpecsSystem Spec
05 Jul 2009   #17
gongoscho

Windows 7 x64
 
 

When i flash the card to the 6800 Ultra (possible), win7 and nVIDIA detect it normal and have the same problems

Yeah the same motherboard but have you too the 2.10 Bios?
My System SpecsSystem Spec
05 Jul 2009   #18
septprince

Window 7 build 7600, Xp pro(VM)
 
 

When this thing happens does you computer hangs or works very slowly??
My System SpecsSystem Spec
05 Jul 2009   #19
gongoscho

Windows 7 x64
 
 

My PC works very good. With winXPproSP3 works great!
My System SpecsSystem Spec
05 Jul 2009   #20
septprince

Window 7 build 7600, Xp pro(VM)
 
 

Did you said that this problem also occur while booting(while computer shows its motherboards information when you just switch on your computer)?
My System SpecsSystem Spec
Reply

 Wonky Screen Corruption Problem




Thread Tools




Similar help and support threads
Thread Forum
On-screen output corruption
Can anyone advise me, please, why some print I see on screen is corrupted as per the attached example? Hard copy does not seem to suffer. If pictures suffer similarly, I do not know, but I suspect it would be harder to detect. Monitor is Dell ST2210, should that be relevant.
General Discussion
Windows Explorer Folders Gone Wonky
My girlfriend was trying to delete multiple folders and somehow the folder icon got changed to 3 blue rectangles. Not only that but now you can't see the properties, delete, or even move the folders. Any time you try to move them it just creates a shortcut. I've never seen this before. Anyone...
General Discussion
New SSD,wonky boot up
Greetings, I just installed my new SSD(Vertex4) and cloned with using Clonezilla. I performed disk to disk image and also moved the MBR over as well to the SSD. After following the instructions listed by HTG(How To Migrate Windows 7 to a Solid State Drive - How-To Geek)I'm finding that I'm having...
Installation & Setup
Graphics screen corruption - random noise, flickers,etc
Hi All I have a problem with my year old desktop pc and random screen corruption when I startup the pc. Sometimes it does it once a month, but in the last week its happened it every day. This is a video of what happens but its not always the same, but its always at startup. Usually...
BSOD Help and Support
Wonky Library view
I've always disliked the Libraries feature as I much prefer to work with absolute paths rather than this "it's over there, somewhere" approach to finding files (one reason I can't stand the whole cloud thing..) anyway... When I click on Libraries -> Documents, it shows me in one giant long list...
General Discussion
Welcome screen corruption
Hi, For a long time, I've had just one administrator account on my Win7 x64 PC. I've recently added a second administrator account but I see corruption on the welcome screen. Here's what I see when Windows boots up. It says "Windows Security | Please enter a username and password." ...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:26.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App