Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: ATI catalyst problem

27 Jun 2009   #1
slovak21

Windows 7 RC
 
 
ATI catalyst problem

Trying to setup ATI catalyst 9.6, everytime the setup is installing the drivers the screen flickers and then comes back to the background picture and that is the only thing that shows, I know I can logout and in due to the music chime. Tried restarting comp, same thing, just the background picture. Have to go into safe mode and do restore everytime. Anybody have a suggestion? This is on Windows 7 RC x64.

my build, laptop acer 8935G
intel P8700
ATI Mobility Radeon HD 4670
4GB DDR3 memory


My System SpecsSystem Spec
.
27 Jun 2009   #2
Captain Zero

Windows 7 Home Premium x64
 
 

Install 'as admin'?
My System SpecsSystem Spec
27 Jun 2009   #3
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

You using the Mobility version,

ATI Catalystâ„¢ Mobility Display Driver

or are you using the regular Cat 9.6?
My System SpecsSystem Spec
.

27 Jun 2009   #4
slovak21

Windows 7 RC
 
 

yes, tried running as 'admin'

and

yes, I used your posted version of 9.6.

both have same result, still having no luck.
My System SpecsSystem Spec
07 Jul 2009   #5
Kristoffach

Windows 7 (RC:7201 64-bit)
 
 
Some feedback from someone who might have seen this

Quote   Quote: Originally Posted by slovak21 View Post
Trying to setup ATI catalyst 9.6, every time the setup is installing the drivers the screen flickers and then comes back to the background picture and that is the only thing that shows
Belive this has actually happened to me before. I also have the same computer and have experienced something similar when i also tried to go from the pre-installed vista to Win7(rc). Altrough my problem is probably a bit different and maybe more complicated i might cast some light on this issue of yours.

----------

This will only be helpfull right after you have done an install of the ATI drivers. What i belive is happening is the computer choosing the wrong display (i know this sounds weird, but even thought you dont have an external monitor connected the system might still belive there is)

* Right-click on the desktop
* Screen Resolution

* In the new window find the Detect/Identify buttons and press them accordingly (Detect first)

* If theres more then two displays, choose (1. mobile PC display) and choose that as your main display.
(reason why the dropdown list says 1. Mobile PC display is because in my situation the drivers doesnt install correctly so your dropdown meny might be a bit diffirent. Either way #1 on the list should be your main display)


I hope this might help you
Anyway, if someone's interested after reading this post and want to know more about my issue I'm now making a post about it: Driver issue in windows 7 (ATI Radeon Mobility 4670)
All help would be much appriciated
My System SpecsSystem Spec
07 Jul 2009   #6
Kristoffach

Windows 7 (RC:7201 64-bit)
 
 

ATI catalyst problem-atiscreenbugafterinstall.jpg

This is what i was talking about Hope its of any help

Belive you might suffer from the same problems as me.
If that's the case, take a look at the link i posted if your
interested


My System SpecsSystem Spec
07 Jul 2009   #7
slovak21

Windows 7 RC
 
 

cool, thanks has been a bit useful for other things still having the issue of installing CCC and the newest driver, installed an older driver. My games are running sooo slow right now, unplayable, probably related to my driver issue.
My System SpecsSystem Spec
07 Jul 2009   #8
K3VL4R

Windows 7 Ultimate X64
 
 

Quote   Quote: Originally Posted by slovak21 View Post
Trying to setup ATI catalyst 9.6, everytime the setup is installing the drivers the screen flickers and then comes back to the background picture and that is the only thing that shows, I know I can logout and in due to the music chime. Tried restarting comp, same thing, just the background picture. Have to go into safe mode and do restore everytime. Anybody have a suggestion? This is on Windows 7 RC x64.

my build, laptop acer 8935G
intel P8700
ATI Mobility Radeon HD 4670
4GB DDR3 memory
I also have had some problems with ATI drivers in the past with Windows 7. The problem with doing a clean install of drivers is that it requires a reboot but once the computer reboots, the WDDM driver install takes over before I could install any drivers. There were some tutorials out that was supposed to disable this automatic driver installation, but none of them were working for me with a clean installation.

But here is the workaround that I have found to be effective:

Tip   Tip
1. Download and install Driversweeper (and make sure you have the video driver that is to be installed downloaded)
2. Go to Device manager Right click my computer /properties/ device manager / and Disable any under display adapters.
3. Reboot into safe mode (usually F8)
4. Run Driversweeper and select your video drivers ATI (or Nvidia if someone else with Nvidia is reading this)
5. Manually delete any ATI folders that may be located at C:\ ATI and Program files (both X64 and X86)\ATI
6. Reboot again into Windows and install the new drivers then reboot once the installation completes.


By disabling the drivers in device manager instead of uninstalling them, it allows you to reboot without the WDDM installation taking over. You also should use Driversweeper and do a clean driver install any time you install Video drivers instead of just updating them, especially when switching between ATI to Nvidia as any leftover driver remnants from one brand will interfere with the other.

Edit this post has been edited to make it more clear to understand.
My System SpecsSystem Spec
14 Jul 2009   #9
slovak21

Windows 7 RC
 
 

cool, thanks got my driver finally installed, but the real problem is presenting itself is that the primary display adaptor is intel 45 chipset and when disabled, my screen goes black. When I restarted after the initial driver setup CCC popped up a msg saying that it doesnt recognize the driver and make sure its the right driver for CCC, either way my comp won't use my ATI 4670. Anybody have something that can help out? it's messed up.
My System SpecsSystem Spec
Reply

 ATI catalyst problem




Thread Tools




Similar help and support threads
Thread Forum
catalyst control center 12-2 PROBLEM
hey all. i have just installed the catalyst control center 12-2 after downloading from amd site. i have a mobility radeon hd4250 and radeon hd 5650 on my laptop. the problem is after installation went successfully(as said by installer) i ran ccc and it said that: "no amd graphics driver is...
Graphic Cards
ATI Catalyst problem on HD 4870
I ve installed some game today nd it may installed few other components with it (most likely directx) however, after that i got into the CCC (had 11.9 installed on Win7 x64) and somehow the Overdrive function wasn t working - everytime i loaded CCC nd clicked on Overdrive i had to "Agree" again,...
Graphic Cards
ATI Catalyst 9.3 - Windows x64 Problem
I have run into the problem with the setup. It runs, but doesn't install new drivers. The catalyst seems to have been installed but i can't open it. 1. Tried disabling the driver enforcement before booting 2. mobility modder is the driver packaged in this catalyst the same as the one on...
Drivers
Catalyst 9.4, RC Problem
I have upgraded from Vista 64 (running 9.4) to Win7 RC. The drivers seem to be working fine however the Control Center will not run. I've uninstalled and re-installed 9.4 to no avail. There are no errors onscreen or in the event logs it just wont run. Tried launching from the desktop...
Graphic Cards
Windows 7 64-bit OpenGL Catalyst problem
I'm running the Windows 7 64-bit beta (build 7000) and I need help with the OpenGL problem in the preview ATI driver. Has anyone found a way to fix this? Can I install Catalyst 9.1 and fix this?:confused: It doesn't officialy support Windows 7. Also I'm new here, where is the reputation slider or...
Drivers
Catalyst GPU problem
My graphic card ATI mobility Radeon HD 3650 I dont know if my problem is caused by drivers or something else but i tryied drivers for vista that i got with my laptop and with some drivers from the ati site but with any drivers i have the same problem... when i lunch CCC and i try to change graphic...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 13:49.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App