Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Multiple monitors detected & utilised when only have 1

09 Jul 2009   #1
AdamGRR

Windows 7 Build 7100
 
 
Multiple monitors detected & utilised when only have 1

Hi all,

I have a new machine that I have installed Win7 64bit (build 7100) and am having issues with the system detecting and selecting as my primary display monitors that dont exist.

I am running 2 Gigabyte GTX275s in SLI and have a Samsung 2443BW LCD via a single DVI cable. Nothing is plugged into the other connectors.

I wouldn't usually care if there were other disconnected displays being detected but my problem is it seems to randomly detect a range of monitors at each startup and pick one to be the primary display leaving my monitor blank. The screen will flash 3 or 4 times making the windows sound when you connect new hardware.

I have tried another monitor and get the same result.

It is quite frustrating when you have to reboot the system often 3 times before you can get a desktop (an extended one still) so you can get to the display properties and make corrections that dont seem to last after a reboot.

I have tried both the 186.18 and 190.15 Nvidia drivers.

Sometimes even into either the change the screen resolution or nvidia control panel will sometimes cause it to refresh all the monitors it detects and i can be left with a blank screen.

I hope I have given enough detail for someone to be able to assist.

Thanks

Adam


My System SpecsSystem Spec
.
09 Jul 2009   #2
smarteyeball

 
 

Hi Adam and welcome to the forums.

I had a similar problem of a mysterious 3rd display appearing (I have two) yesterday when I was setting up my crossfired 4890's.

I eventually sorted it all by uninstalling the drivers, running driver sweeper in safe mode, removing one card and re-installing the drivers with just a single card. Then I re-added the second card.
My System SpecsSystem Spec
01 Aug 2009   #3
ozimp

Windows 7 Ultimate RC
 
 
Multiple "Phantom" moonitors

I too am having this problem. Yesterday I updated the Nvidia drivers and now I am getting two Samsung Synchmasters showing up and one Generic PNP Monitor. I only have the one synchmaster connected via the digital cable.
My System SpecsSystem Spec
.

01 Aug 2009   #4
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by ozimp View Post
I too am having this problem. Yesterday I updated the Nvidia drivers and now I am getting two Samsung Synchmasters showing up and one Generic PNP Monitor. I only have the one synchmaster connected via the digital cable.
ozimp

you could try uninstalling the driver by right clicking my computer, manage, device manager, display and roll it back

Ken
My System SpecsSystem Spec
01 Aug 2009   #5
AdamGRR

Windows 7 Build 7100
 
 

I have had some minor sucess by disabling Transient Multimon Manager (TMM) via the registery.

I still have problems with it occasionally but not as much as I used to
My System SpecsSystem Spec
29 Oct 2009   #6
bobafett8782

Windows 7 Home Premium 64
 
 

Just wondering if anyone has come across a fix for this yet?
I have a Gigabyte GTX 260 OC card with a Samsung monitor. When it boots i get a KSOD. I've gotten a work around going by removing my login password, so when it boots it goes directly to the desktop. Most of the time it boots right, but every once in a while (1 in 5) it will show it as an extended desktop and I have to bring up the monitor settings and hit detect for it to realize there is only 1 monitor connected.

I have updated the firmware on the videocard thru Gigabytes website with no luck.

Thoughts?
My System SpecsSystem Spec
18 Nov 2009   #7
mrplow

windows 7 professional (64 bit)
 
 

also having this problem.... sometimes have to boot 3 or 4 times before it will pick the real monitor to be the display.. and when i hit detect monitors, it blacks out
pretty frustrating..
My System SpecsSystem Spec
19 Nov 2009   #8
bobafett8782

Windows 7 Home Premium 64
 
 

What hardware do you have (monitor, video card) what Version of W7? Driver versions?
My System SpecsSystem Spec
19 Nov 2009   #9
mrplow

windows 7 professional (64 bit)
 
 

asus vk222u lcd, gigabyte gtx260oc, ga-m55sli-s4 mobo, couple gigs ram, amd X2 6000+

using 191.07 nvidia drivers at present, have used many different ones including the default display driver that win 7 installs with no luck. im using win 7 pro 64 bit.

did you manage to stop this from happening bobbafet? seen this issue identifyed on a couple of forums now but no solutions apart from the standard roll back drivers etc.
My System SpecsSystem Spec
20 Nov 2009   #10
bobafett8782

Windows 7 Home Premium 64
 
 

I also am using a Gigabyte gtx260oc, have a gigabyte GA-Ep35-UD3L. And am running Win7 Home 64.
Maybe its an issue with the Gigabyte Vid card. I usually buy BFG but decided to try Gigabyte this time.

I have discovered kind of a work around. If you remove you password from your account so that when your computer boots it goes right to your desktop, 85% of the time it boots with no problem. I still have the occasional problem with a black screen or when it boots it displays like it is the 2nd desktop and I have to go in and hit detect, then it realizes there is only 1 monitor......
My System SpecsSystem Spec
Reply

 Multiple monitors detected & utilised when only have 1




Thread Tools




Similar help and support threads
Thread Forum
Multiple Monitors for Multiple Users
Hey guys, im brand new here and I wonder if anyone could help me. Im trying to find a way to automate my multiple monitor setup a bit. I have 2 user profiles, one which I use for work, were I need two monitors setup and one which I use for gaming - I only need one screen here. Is there a way I can...
Customization
Working with multiple monitors does not allow multiple desktops
I have attached a second monitor to my laptop which runs Windows 7, however, I need to set different resolutions for different monitors, because the display does not fit to fill the screen on both monitors. It is also noted that the display is replicated, and I would like to have the effect of...
Graphic Cards
Processor being excessively utilised
I just installed windows 7 on a 'new' in the sense I just got it but its a refurbished PC from a working environment, anyway I activated Hyper Threading and I got 2 bars on the performance tab of task manager (2 graphs as before I activated Hyper Threading it was just 1 graph), but there's 2...
Performance & Maintenance
Multiple Monitors
Greetings all! I have the following issue I need assistance in resolving. I currently have my Syncmaster 2033 as my primary viewing screen. I'm able to use a Sharp Aquos independantly to view Hi def, provided I have the syncmaster disconnected! That is I cannot have both connected, the...
Graphic Cards
Multiple monitors
Hi all First post ever to a computer forum I have a new computer and I am planning to output to on or more of three monitors including a 42 inch TV I have an ATI 5770 GPU The output will be identical on the different displays
Graphic Cards
My monitors seem to be detected in incorrect order!?!?
Maybe someone can help me. I have a GTX295, and my main monitor is plugged into the right plug while my TV into the left. For Nvidia the right plug (when facing front of the computer) was always considered Monitor #1, for what ever reason... The strange thing is that these new Nvidia drivers...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:44.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App