Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Latest AMD Catalyst Video Driver for Windows 7

20 Jan 2011   #1251
Solarstarshines

Windows 10 Home Premium 64bit sp1
 
 

just installed my wei stayed the same 7.8 graphics and 3d thanks guys


My System SpecsSystem Spec
.
20 Jan 2011   #1252
Zen00

Windows 7 Ultimate x64
 
 

I don't think it goes much higher than that anyways.
My System SpecsSystem Spec
20 Jan 2011   #1253
Solarstarshines

Windows 10 Home Premium 64bit sp1
 
 

Quote   Quote: Originally Posted by Zen00 View Post
I don't think it goes much higher than that anyways.

well when i just installed the 10.11 without the hotfix you members suggested i was running a 6.8 like wtf happened there ?

Well im happy now but still got a few bsod's while gamming something about the amd cpu cache i looked into it but really can't tell why it is happening i also reset the graphics card and it still bsod .

This particular situation i was looking at the error log alot of people suggested bad ram but that isnt the case I dont have another pci -e slot also suggested bios needs to be updated did that as well.

Can someone maybe give a eduacated guess i pretty much did all the trouble shooting areas memtest and all but the bsod is not always just occasionaly also the report was saying something that the card wasn't looping fast enough or got stuck is there something wrong with the cpu or is it my card in general too much load on it?

One more thing it also mentioned my virus might be corrupting it technicly windows doesn't reconize it so what could it be i use WEBROOT SPYSWEEPER WITH ANTI VIRUS

All answers will be welcomed thanks in advanced
My System SpecsSystem Spec
.

20 Jan 2011   #1254
jr26

Win7 Ultimate x64
 
 

Have you tried the 10.10e hotfix drivers or the new 11.1a beta drivers? I haven't had any crashes with either of those. I never tried 10.11 because I saw too many people having issues.
My System SpecsSystem Spec
20 Jan 2011   #1255
Solarstarshines

Windows 10 Home Premium 64bit sp1
 
 

well i used the 11.1 a hot fix on the 10.11 is that were i f'up'ed?

It says im using 10.12


Attached Thumbnails
Latest AMD Catalyst Video Driver for Windows 7-driver.png  
My System SpecsSystem Spec
20 Jan 2011   #1256
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

The reason it shows 10.12 is that is the last official/WHQL set you had installed. The beta/hotfix sets don't have the Catalyst version listed in them anywhere so it will show whatever was the last one, or on a clean Windows install show nothing for the Catalyst version if a beta driver is installed.

Here is what mine looks like after cleaning out the leftover bits from the last driver,

Latest AMD Catalyst Video Driver for Windows 7-cccnoversionshowing.png


My System SpecsSystem Spec
20 Jan 2011   #1257
Solarstarshines

Windows 10 Home Premium 64bit sp1
 
 

i see thank you stormy for the info

Now if i can just figure why i get those random BSOD's

actually soon im going to change the board and ram anyone think that could lick my issue ?
My System SpecsSystem Spec
20 Jan 2011   #1258
Dave76

Microsoft Community Contributor Award Recipient

Windows 7 Ult x64 - SP1/ Windows 8 Pro x64
 
 

Quote   Quote: Originally Posted by Solarstarshines View Post
Quote   Quote: Originally Posted by Zen00 View Post
I don't think it goes much higher than that anyways.

well when i just installed the 10.11 without the hotfix you members suggested i was running a 6.8 like wtf happened there ?

Well im happy now but still got a few bsod's while gamming something about the amd cpu cache i looked into it but really can't tell why it is happening i also reset the graphics card and it still bsod .

This particular situation i was looking at the error log alot of people suggested bad ram but that isnt the case I dont have another pci -e slot also suggested bios needs to be updated did that as well.

Can someone maybe give a eduacated guess i pretty much did all the trouble shooting areas memtest and all but the bsod is not always just occasionaly also the report was saying something that the card wasn't looping fast enough or got stuck is there something wrong with the cpu or is it my card in general too much load on it?

One more thing it also mentioned my virus might be corrupting it technicly windows doesn't reconize it so what could it be i use WEBROOT SPYSWEEPER WITH ANTI VIRUS

All answers will be welcomed thanks in advanced
How many RAM cards do you have?

Sometimes, when you have lots of RAM and/or RAM cards, you need a CPU-NB voltage bump. This is for the CPU integrated memory controller.

D/L CPUZ and post a snip of the CPU, Mainboard, Memory, and SPD tabs.

Have you been checking your temperatures?


Go to your BIOS and tell us what the CPU, RAM and North Bridge/memory controller (CPU-NB) voltages are.

They are usually around 1.0 - 1.1v, bump it to 1.2v.
My System SpecsSystem Spec
20 Jan 2011   #1259
Solarstarshines

Windows 10 Home Premium 64bit sp1
 
 

here's a snip i see my ram has two different voltages should i swap out the 2 sticks with the higher voltage ?

i have the same exact ram except two of them are the gaming series and the other isnt but duplicate specs and same vendor g-series viper ram patriot 8 gigs

also this is my ram http://www.frys.com/product/5958394?...H:MAIN_RSLT_PG

http://www.frys.com/product/5447899?...H:MAIN_RSLT_PG

i think the ram doesnt match even though they bare the same latency i think i might have solved my own problem what do you think


Attached Thumbnails
Latest AMD Catalyst Video Driver for Windows 7-voltages.png   Latest AMD Catalyst Video Driver for Windows 7-mobo.png  
My System SpecsSystem Spec
20 Jan 2011   #1260
Dave76

Microsoft Community Contributor Award Recipient

Windows 7 Ult x64 - SP1/ Windows 8 Pro x64
 
 

Most important is the CPUZ Memory tab, this tells us what the actual settings are, the SPD tab is the recommended settings and voltages, they are not actual voltages and settings.

This will tell me what needs to be done, include this in your next post.
Quote:
Go to your BIOS and tell us what the CPU, RAM and North Bridge/memory controller (CPU-NB) voltages are.
Mixing RAM can cause problems, but they do work sometimes.
Since yours are close to the same, I would check the settings/voltages before buying any new RAM.

The EPP#1 is different, so make sure you are running JEDEC #3 settings. You won't notice a difference going from EPP#1 to JEDEC #3.
My System SpecsSystem Spec
Closed Thread

 Latest AMD Catalyst Video Driver for Windows 7




Thread Tools




Similar help and support threads
Thread Forum
Latest AMD Catalyst Video Driver for Windows 7
Latest AMD Radeon Crimson Video Driver Released How to Install AMD Graphics Drivers Without Installing Catalyst Install Manager
Graphic Cards
I need help with installing the latest AMD Catalyst Video Driver
When I install it my resolution goes to like 640x720 or something like that and I can't change it unless I rollback the driver and I need the driver to play minecraft.
Graphic Cards
BSOD after installing Latest AMD Catalyst Video Driver for Windows 7
I have a His Radeon 4850 and it seems like every time I go to install the latest updates, I get a BSOD after restarting. Am I not installing correctly or something? is there a link to the proper procedure I usually just download and install over the old. Thanks for all assistance. :)
Graphic Cards
Crush with the latest Catalyst driver.
Hello Sapphire ‏‏HD 5870 Vapor-X OC 1GB GDDR5 DX11 - my card When I install the latest 10.10 catalyst driver and running FunMark stability check my screen goes black and pc crashes. On 10.9 this never happens but then I got scaling problem with my screen samsung xl2370. Please help!
Graphic Cards
Latest ATI Catalyst Driver for Radeon X1550 on Se7en?
Hi, i'm using a Radeon X1550 on Windows 7 build 7137. What are the latest drivers avaiable for this card? Now i'm using the Catalyst 8.1 for Vista, and I can't install the Catalyst 9.3 for Vista.
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:00.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App