Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Latest AMD Catalyst Video Driver for Windows 7

21 Jul 2012   #1811
HoneycombAG

Microsoft Windows 7 Home Premium 64-bit Service Pack 1
 
 

The Catalyst 12.6 WHQL "update" keeps installing 12.4, no matter what I do on here! I kept uninstalling parts, reinstalling, uninstalled the whole thing, ran Driver Sweeper, but it still keeps installing itself as "12.4"! And right now I'm getting graphics corruption on Team Fortress 2 with "recommended" settings on my XFX Radeon HD-4350


My System SpecsSystem Spec
.
21 Jul 2012   #1812
dsperber

Windows 7 Pro x64 (1), Win7 Pro X64 (2)
 
 

Quote   Quote: Originally Posted by HoneycombAG View Post
The Catalyst 12.6 WHQL "update" keeps installing 12.4, no matter what I do on here! I kept uninstalling parts, reinstalling, uninstalled the whole thing, ran Driver Sweeper, but it still keeps installing itself as "12.4"! And right now I'm getting graphics corruption on Team Fortress 2 with "recommended" settings on my XFX Radeon HD-4350
The HD4xxx cards have been legacied by ATI. You can't install 12.6 for them. I think 12.4 is the final, although I couldn't even install that for my HD4850 and had to stick with my previous 12.3 (which works perfectly, so I'm not complaining).

The "legacy beta" drivers that get selected when you designate you have an HD4xxx cards are not 12.6.
My System SpecsSystem Spec
21 Jul 2012   #1813
Phone Man

Windows 8.1 Pro w/Media Center 64bit, Windows 7 HP 64bit
 
 

Quote   Quote: Originally Posted by dsperber View Post
Quote   Quote: Originally Posted by HoneycombAG View Post
The Catalyst 12.6 WHQL "update" keeps installing 12.4, no matter what I do on here! I kept uninstalling parts, reinstalling, uninstalled the whole thing, ran Driver Sweeper, but it still keeps installing itself as "12.4"! And right now I'm getting graphics corruption on Team Fortress 2 with "recommended" settings on my XFX Radeon HD-4350
The HD4xxx cards have been legacied by ATI. You can't install 12.6 for them. I think 12.4 is the final, although I couldn't even install that for my HD4850 and had to stick with my previous 12.3 (which works perfectly, so I'm not complaining).

The "legacy beta" drivers that get selected when you designate you have an HD4xxx cards are not 12.6.
They now have 12.6 Beta driver for older cards. HD4xxx, HD3xxx, HD2xxx.

AMD Catalyst

Jim
My System SpecsSystem Spec
.

21 Jul 2012   #1814
dsperber

Windows 7 Pro x64 (1), Win7 Pro X64 (2)
 
 

Quote   Quote: Originally Posted by Phone Man View Post
They now have 12.6 Beta driver for older cards. HD4xxx, HD3xxx, HD2xxx.

AMD Catalyst

Jim
That's what it says. But I couldn't install it on my HD4850 machine. Tried everything I could, but always got "driver failed" on the log. So if there is something in the INF that's supposed to make it usable with the older cards, it certainly didn't work for me.

I then tried to install an explicit 12.4, but it too would not install. I think that was just a pre-release of the current 12.6 which had already been carved out only for HD5xxx and newer cards.

I finally had to go back to a restore of my existing system image backupo where I currently have 12.3 installed. That's the only one which actually works for me and my HD4850 machine, so that's what I'll probably stick with forever. Not a problem... as it works flawlessly for me (I'm not a gamer).
My System SpecsSystem Spec
22 Jul 2012   #1815
BugMeister

Windows10 Pro - 64Bit vs.10547
 
 

Quote   Quote: Originally Posted by BugMeister View Post
- for anyone having problems with the 12.6 Legacy driver - try this one..
AMD Catalyst 12.6 BETA (8.97.100.3 July 3) AMD Legacy Driver - Guru3D.com Forums

- and good luck, folks..!!
- this one might work..

- check your hardware ID in the CCC (- it's down at the bottom left of the GUI)
- it should tell you what model number your card is "hardware-wise"
- then check the list of compatible hardware on the Guru 3D link..
My System SpecsSystem Spec
22 Jul 2012   #1816
HoneycombAG

Microsoft Windows 7 Home Premium 64-bit Service Pack 1
 
 

Before I forget, how do I turn off that dreaded HyperMemory feature? Some Google searches I did say to disable a non-existent setting in the registry, while others tell me to use ATI Tray Tools, which also doesn't do anything, because in my Display Properties, it still shows that my card still eats up to 767 MB of the main system RAM.

I also tried checking the BIOS; the only shared memory option there is the one for the onboard graphics which is Disabled for both.
My System SpecsSystem Spec
22 Jul 2012   #1817
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by HoneycombAG View Post
in my Display Properties, it still shows that my card still eats up to 767 MB of the main system RAM.
Shared or dedicated? If dedicated it is taking from system ram. If shared it is only taken/used as needed,

Video Memory Virtualization - A Brief Guide

and is not HyperMemory.
My System SpecsSystem Spec
25 Jul 2012   #1818
neo101

WIN7 Ultimate 64bit
 
 

Quote   Quote: Originally Posted by M1GU31 View Post
Lately i've been having bad luck with drivers,rolling back but now i see that 12.6 is offical O_o? Don't know if I should go with 12.6 or 12.4 instead of 12.7. Also if I try to rollback like I mention eailer,my info wont update and still say 12.6 even though I put 12.4.,same thing if I change to 12.7
If yer back-tracking on drivers make sure you use "driver cleaner" to get the debris off and make sure AMD folder disappears off your C:/ drive (which holds 'other' copies of previous installed drivers!)

Uninstall all 12.6 stuff with uninstaller
install default vga driver and adjust screen size
driver cleaner > clean off AMD
restart
install 12.4 again
My System SpecsSystem Spec
27 Jul 2012   #1819
zapp22

Windows XP Pro SP3, Windows 7 Pro 32-bit, Windows 7 Ultimate 64bit, Windows XP Home SP3
 
 

I'm having this issue with modern/late hardware on thinkpad x120e, amd e-350, radeon 6310. all previous catalyst installs went like clockwork - no drama. now stuck on stoopid. when I run uninstall, the msi windows installer throws an error and shuts down. I used ccleaner to uninstall the "installer" from programs list - that was the only ati thing in the programs list. when I uninstalled the device, windows initially put the generic vga driver in. I reran the 12.6 install, and it simply skips the video section altogether.... what the heck is that all about?

when I tried to point Device Manager to update driver from the correct folder dropped by the 12.6 unpack, it failed to load that driver .... "the correct driver is installed"

what 'driver cleaner' is reliable? feedback on such is not exciting [not a thrillseeker]

How do I get AMD stuff PROPERLY uninstalled. seems that is broken.

I have re-downloaded 12.6 package but not going there until I get some better advice. pls provide!

Quote   Quote: Originally Posted by neo101 View Post
Quote   Quote: Originally Posted by M1GU31 View Post
Lately i've been having bad luck with drivers,rolling back but now i see that 12.6 is offical O_o? Don't know if I should go with 12.6 or 12.4 instead of 12.7. Also if I try to rollback like I mention eailer,my info wont update and still say 12.6 even though I put 12.4.,same thing if I change to 12.7
If yer back-tracking on drivers make sure you use "driver cleaner" to get the debris off and make sure AMD folder disappears off your C:/ drive (which holds 'other' copies of previous installed drivers!)

Uninstall all 12.6 stuff with uninstaller
install default vga driver and adjust screen size
driver cleaner > clean off AMD
restart
install 12.4 again
if I say Puh-leeezzzz.. see above.
man am I ever in the ditch.

I went back and made TRIPLE sure I downloaded 12.6 MOBILITY catalyst.
uninstalled device with "delete driver". tried to use Device manager to install directly from the win764bit driver folder. no go.
went to the folder, tried to "install" the included *.msi file and it returns a "not compatible with this version of windows" !! Huh?
My System SpecsSystem Spec
27 Jul 2012   #1820
zapp22

Windows XP Pro SP3, Windows 7 Pro 32-bit, Windows 7 Ultimate 64bit, Windows XP Home SP3
 
 
Solved, via 12.7

I never got anywhere with 12.6 "mobility" or 12.6 generic. I'm including some screenshots this time so maybe someone smarter than me can see what the issue was. Neither 12.6 install package could discover the graphics hardware in the 'discover' phase. that seems crystal clear.

downloaded the 12.7 Beta package [not "mobility"], first ran the uninstall and got it in custom mode to list everything so I could see: no graphics, just audio, sdk, installer, that stuff. That part made sense as I Had reduced win7 down until it could discover no hdwe-specific drivers. [note that the 12.6 discover mode NEVER discovered the 6310 even when it was running correctly with a 10/2011 dated ATI driver]. Uninstall through MSIexec error but that is not new... will post on that elsewhere. Log reported no errors

then ran the 12.7 INstall, chose Custom so I could see what it finds: discovery went well, everything there, installed it all, got the graphics right along with everything else.

will run WEI next.

hope this helps someone/sometime


Attached Thumbnails
Latest AMD Catalyst Video Driver for Windows 7-ati-problem.jpg   Latest AMD Catalyst Video Driver for Windows 7-ati-problem-yay12.7.jpg  
Attached Images
Latest AMD Catalyst Video Driver for Windows 7-ati-problem-msi-fail1.jpg Latest AMD Catalyst Video Driver for Windows 7-ati-problem-finally12.7.jpg 
My System SpecsSystem Spec
Closed Thread

 Latest AMD Catalyst Video Driver for Windows 7




Thread Tools




Similar help and support threads
Thread Forum
Latest AMD Radeon Video Driver for Windows 7
Latest AMD Radeon Video Driver Released How to Install AMD Graphics Drivers Without Installing Catalyst Install Manager
Graphic Cards
I need help with installing the latest AMD Catalyst Video Driver
When I install it my resolution goes to like 640x720 or something like that and I can't change it unless I rollback the driver and I need the driver to play minecraft.
Graphic Cards
BSOD after installing Latest AMD Catalyst Video Driver for Windows 7
I have a His Radeon 4850 and it seems like every time I go to install the latest updates, I get a BSOD after restarting. Am I not installing correctly or something? is there a link to the proper procedure I usually just download and install over the old. Thanks for all assistance. :)
Graphic Cards
Crush with the latest Catalyst driver.
Hello Sapphire ‏‏HD 5870 Vapor-X OC 1GB GDDR5 DX11 - my card When I install the latest 10.10 catalyst driver and running FunMark stability check my screen goes black and pc crashes. On 10.9 this never happens but then I got scaling problem with my screen samsung xl2370. Please help!
Graphic Cards
Latest ATI Catalyst Driver for Radeon X1550 on Se7en?
Hi, i'm using a Radeon X1550 on Windows 7 build 7137. What are the latest drivers avaiable for this card? Now i'm using the Catalyst 8.1 for Vista, and I can't install the Catalyst 9.3 for Vista.
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:50.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App