Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Latest AMD Catalyst Video Driver for Windows 7

30 Jul 2009   #461
Night Hawk

W7 Ultimate x64/W10 Pro x64 dual boot main build-remote pc W10 Pro x64 Insider Preview/W7 Pro x64
 
 

Quote   Quote: Originally Posted by ShaolinMilk View Post
Yeah, I'll play around with it.

Another thing I noticed... Whenever I play any games(including flash games), it does some weird lag. For example, if I play Mario and walk him across the screen, theres like this little lag every time the frame switches from one to another. I think this has to do with the driver.

EDIT: Even when I scroll up and down on the scroll bar, its not "smooth". The frames seems to skip sometimes.
I see some lags when reaching a room right before characters start speaking in an old 98-XP game on the 64bit RC! Often it's simply how a game is written and for which version. Some are able to run without problems on different versions while others are specific to XP.

I'll be seeing that one works out on the XP mode since that offers far less for video as a rule there. It's not always video drivers that will cause lags but often sound as well. For older games prior to Vista you may simply need to install DX 9c.




Attached Thumbnails
Latest AMD Catalyst Video Driver for Windows 7-rtcw-xp-mode.jpg  
My System SpecsSystem Spec
.
30 Jul 2009   #462
ShaolinMilk

Windows 7 Home Premium 64-bit
 
 

Could this also be the problem?

My specs are:
Intel Pentium 4 3.0ghz
2gb DDR400(1xPC3200 512mb, 1xPC3200 1gb, 1xPC2700 512mb) ram
Asus P4S800 motherboard
Titan 470W PSU

and I just bought this video card. The system requirement for it requires at least a 450W PSU with 30 amp on 12 volt. My PSU max is 22 amp on 12 volt. Can this be the reason why this is happening? I did what you suggested and it did not work. The problem still persist. Could my ram have something to do with it? Maybe the PC2700 is getting too old?

I'm thinking about reinstalling windows xp or get ubuntu and maybe the problem will stop. Its frustrating when my old Geforce 6200 feels better than this video card. lol
My System SpecsSystem Spec
30 Jul 2009   #463
danitaro

windows 7
 
 

Quote   Quote: Originally Posted by danitaro View Post
hi everybody
I have a little problem, I'm running windows 7 rtm 7600 (64bit) on my hp pavilion with an ati hd4500.
The driver is installed but I can't seem to get the catalyst center to work. I've installed the 9.7 driver and everything seems to go well with the installation, it even says, installation completed, but the catalyst center isn't enywhere to be found. When I go to the folder ..programfiles/ati technologies the folder is just empty. my laptop says the ati install manager is installed but the catalyst control center not. I had the same problem when I was running the windows 7 rc.
I've tried to install the ccc from the extraction folder on c:/ati but still same problem.
Can anybody tell me what's wrong?
Thx
Dani
Still no solution, anybody help, please? I'm desperate! :-)
My System SpecsSystem Spec
.

30 Jul 2009   #464
ShaolinMilk

Windows 7 Home Premium 64-bit
 
 

UPDATE:

Okay. I don't think its my power supply or ram that's causing these little stutters when I play games. Whether its a game on flash that's hosted on say Play Games - Free Online Games at AddictingGames! or a game I play often(Warcraft 3), it stutters randomly and its a distraction. I just bought a new 600W power supply and replaced my old PC2700DDR ram with a PC3200 1gb DDR. The stutter still occurs!

Is it my processor? Is it getting too old or something? My OLD geforce 6200 did not do this and right now, it feels like that one ran better on Windows 7 than this new one I got. Can someone help me? Is it a driver issue? Is it my P4 3.0 GHZ processor?

EDIT:

Also, the "Desktop Windows Manager" keeps on popping up saying it has closed and stopped working and changes my theme back to the high contrast Windows 7 theme. :/

As mentioned earlier, when I scroll even on the scroll bar of mozilla firefox, it does not look "smooth" like my geforce 6200. It stutters quite a bit and looks like I'm running on a pentium one.
My System SpecsSystem Spec
30 Jul 2009   #465
Night Hawk

W7 Ultimate x64/W10 Pro x64 dual boot main build-remote pc W10 Pro x64 Insider Preview/W7 Pro x64
 
 

You could have a bad card or a need to take it out and blow out the slot before reseating down fully. If the card is raised up any in the slot itself that will cause an endless list of display problems. That would be thing you could try unless you elect to go with a much newer model.

As far as only originally having 512mb of PC2700 memory or the cpu have a look at this article. Windows Seven 7 Runs Flawlessly on 512MB RAM | Windows 7 News & Development | Windows Tools, Help & Guides
My System SpecsSystem Spec
31 Jul 2009   #466
ShaolinMilk

Windows 7 Home Premium 64-bit
 
 

I have reseated my video card and the problem still occurs. Do you think it's my video card? What exactly is the problem here? Should I get an exchange for another one or what?
My System SpecsSystem Spec
31 Jul 2009   #467
Night Hawk

W7 Ultimate x64/W10 Pro x64 dual boot main build-remote pc W10 Pro x64 Insider Preview/W7 Pro x64
 
 

If the drivers are on good and you are not running into problems with sound or the games or other things including problems in Windows itself it could be a fault with the card.

When not seeing immediate results with the Catalyst 9.7 and noticing a problem with another program that works normally on a second installation I redid the host drive with a clean install all over again to see the 9.7 go right on without a whisper!

For the most part what people often forget is that they are still running whatever build of a non finished version of Windows until the actual RTM is on coming in August. If you happen to be running even the RCs let alone some leak problems come up!
My System SpecsSystem Spec
31 Jul 2009   #468
mail2parun

windows 7
 
 

hey dani

like gedas has said i tried using the Mobility Modder to modify my ATI drivers.but b4 installing it uninstall ur graphics driver from device manager and also ati catalyst from control panel...
then delete the folder C:\ATI.

then Download the newest desktop drivers from www.ati.com. ver 9.7

If you already hav them,then Run the downloaded driver, let it extract into c:/ATI/SUPPORT - but cancel the installation once the driver is extracted.
this is very important ok that u cancel the installation as soon as the drivers are extracted.


then run the Run Mobility Modder - and browse to the driver in C:ATI/SUPPORT/ - an example of Catalyst 7.4 would be C:\ATI\SUPPORT\7-4_vista32_dd_ccc_enu_44985 - hit modify. Wait until driver is modified.

after that go to C:\ATI\SUPPORT\7-4_vista32_dd_ccc_enu_44985 and run the SETUP.EXE.
in between the installation u ll get the msg tht the file is not from recognised source but continue installing it...

aft installation restart the system and enjoi...it ll be working...
try it and let me kno..

the software you can get it from
Mobility Modder - DriverHeaven.net

by the way thanks Gedas for the help....
My System SpecsSystem Spec
31 Jul 2009   #469
danitaro

windows 7
 
 

Quote   Quote: Originally Posted by mail2parun View Post
hey dani

like gedas has said i tried using the Mobility Modder to modify my ATI drivers.but b4 installing it uninstall ur graphics driver from device manager and also ati catalyst from control panel...
then delete the folder C:\ATI.

then Download the newest desktop drivers from www.ati.com. ver 9.7

If you already hav them,then Run the downloaded driver, let it extract into c:/ATI/SUPPORT - but cancel the installation once the driver is extracted.
this is very important ok that u cancel the installation as soon as the drivers are extracted.


then run the Run Mobility Modder - and browse to the driver in C:ATI/SUPPORT/ - an example of Catalyst 7.4 would be C:\ATI\SUPPORT\7-4_vista32_dd_ccc_enu_44985 - hit modify. Wait until driver is modified.

after that go to C:\ATI\SUPPORT\7-4_vista32_dd_ccc_enu_44985 and run the SETUP.EXE.
in between the installation u ll get the msg tht the file is not from recognised source but continue installing it...

aft installation restart the system and enjoi...it ll be working...
try it and let me kno..

the software you can get it from
Mobility Modder - DriverHeaven.net

by the way thanks Gedas for the help....

nope still no result,
the strange thing is, the installation takes about 10secs (wich I asume, is way too little) and it never gives me a message that the file isn't recognized, and it doesn't seem to install any driver, nor the ccc, but when I restart the computer, windows conf says it's installing the driver.. but installation of ccc still hasen't happened, still an empty folder..
And to be honest I'm sick of it! I'm giving up!
Thank you for your help!
Greetz Dani
My System SpecsSystem Spec
31 Jul 2009   #470
ShaolinMilk

Windows 7 Home Premium 64-bit
 
 

Quote   Quote: Originally Posted by Night Hawk View Post
If the drivers are on good and you are not running into problems with sound or the games or other things including problems in Windows itself it could be a fault with the card.

When not seeing immediate results with the Catalyst 9.7 and noticing a problem with another program that works normally on a second installation I redid the host drive with a clean install all over again to see the 9.7 go right on without a whisper!

For the most part what people often forget is that they are still running whatever build of a non finished version of Windows until the actual RTM is on coming in August. If you happen to be running even the RCs let alone some leak problems come up!
Thank you for the reply.

What I'm going to do is install Ubuntu as a dual boot and if it runs perfectly on that, then it's not my card and it's Windows 7 itself. Thank you once again.
My System SpecsSystem Spec
Closed Thread

 Latest AMD Catalyst Video Driver for Windows 7




Thread Tools




Similar help and support threads
Thread Forum
Latest AMD Catalyst Video Driver for Windows 7
Latest AMD Radeon Crimson Video Driver Released How to Install AMD Graphics Drivers Without Installing Catalyst Install Manager
Graphic Cards
I need help with installing the latest AMD Catalyst Video Driver
When I install it my resolution goes to like 640x720 or something like that and I can't change it unless I rollback the driver and I need the driver to play minecraft.
Graphic Cards
BSOD after installing Latest AMD Catalyst Video Driver for Windows 7
I have a His Radeon 4850 and it seems like every time I go to install the latest updates, I get a BSOD after restarting. Am I not installing correctly or something? is there a link to the proper procedure I usually just download and install over the old. Thanks for all assistance. :)
Graphic Cards
Crush with the latest Catalyst driver.
Hello Sapphire ‏‏HD 5870 Vapor-X OC 1GB GDDR5 DX11 - my card When I install the latest 10.10 catalyst driver and running FunMark stability check my screen goes black and pc crashes. On 10.9 this never happens but then I got scaling problem with my screen samsung xl2370. Please help!
Graphic Cards
Latest ATI Catalyst Driver for Radeon X1550 on Se7en?
Hi, i'm using a Radeon X1550 on Windows 7 build 7137. What are the latest drivers avaiable for this card? Now i'm using the Catalyst 8.1 for Vista, and I can't install the Catalyst 9.3 for Vista.
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:39.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App