Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Latest AMD Catalyst Video Driver for Windows 7

13 May 2010   #851
smarteyeball

 
 

Quote   Quote: Originally Posted by Airbot View Post
Ati pushes out an update every month.
ATI pushes out an official update every month.

They now also officially and "unofficially" 'leak' about 3+ different betas versions... not confusing at all


There is also supposedly two different driver teams - each branch works on alternative builds.

ie one does 10.1, 10.3, 10.5 etc and the other 10.2, 10.4, 10.6 etc.

Goes a long way in explaining why one release is good, but breaks something and the next releases fixes whats broken but breaks something else instead



Quote   Quote: Originally Posted by Night Hawk View Post
The Cat. 10.4 is the latest one to come out last month. I won't expect any newer 10.5 or other version to be out until at least a few months have passed.
The cat 10.4a, 10.4b preview drivers and the mysterious 'early leak' Cat 10.5 are newer 3D drivers than the Cat 10.4 official.


My System SpecsSystem Spec
.
13 May 2010   #852
Night Hawk

W7 Ultimate x64/W10 Pro x64 dual boot main build-remote pc W10 Pro x64 Insider Preview/W7 Pro x64
 
 

That could be!

So far the 10.4 however is working like a champ and I usually wait a lengthy period before looking at any newer versions not being in any rush at least as far as everything since the 7.9 headache was seen for the card on the last build!

The 7.9 was the latest as well as on the software disk then where the 7.10 and 7.11 were anxiously waited for to see those work! Even the patch for the 7.9 then release was a waste of time there.
My System SpecsSystem Spec
16 May 2010   #853
sygnus21

Windows 10 Pro
 
 
Strange issue...

FYI

Tech info first… Single ATI 4890 (1gig), Catalyst 10.4 drivers running for two weeks before issue.

Here’s a strange issue that popped up on me today. So I’m getting ready to play Boarderlands - the game loads up and I hear my video card’s fan start rapidly cycling up and down. It’s really loud. So I exit the game, and the fan goes into a loud spin. WTH!

So I restart the computer and the card’s fan cycles down until I log into Windows, after a few seconds the card cycles up to 50 percent, as shown in GPU-Z and Catalyst Control Center, and stays. What????

Latest AMD Catalyst Video Driver for Windows 7-gpu-z-current-status.jpgLatest AMD Catalyst Video Driver for Windows 7-ati-overdrive-tab.jpg

OK, obviously something’s wrong. And I know it’s a software issue because the card only does this when I log into Windows.

OK, uninstall the drivers and Catalyst Control Center and upon completion of uninstall the fan throttles back to normal (around 20%). So I reboot with no drivers or CCC installed, log into Windows and the card’s fan is still running normal. OK…. Now I know it’s a driver/software issue.

Reinstall driver and software, reboot, login, CCC loads…. And the fan starts running at 50%. Oh man! WTF!!!

OK, let me try something…. Open up CCC, go into Overdrive section, click the Unlock button key, tick "Enable Manual Fan Control" and manually set fan speed. This will let me know if CCC can control the fan.

So I set the fan speed to 20%, click apply, and the fan throttles back to the 20% setting I chose. Well, now I definitely know it’s a CCC issue because I’m able to manually choose any speed I want and CCC is setting them accordingly. Hmmmm……

OK, let's try this…. I untick Enable Manual Fan Control, click Defaults tab and the fan sets to around 23% and appears to be working in "auto mode" again, and the rapid cycling is gone.

So I check to see if the fan is running in auto mode by running Half-Life 2 EP 2 in windowed mode, this also allows me to check CCC and GPU-Z at the same time, and did notice the fan cycle up as the card warmed up; so now I know the fan is working correctly.

Don’t know what that was about but if anyone else had/has this weird issue, try what I did and see if it works.

Just FYI

BTW Has anyone else had this issue with these drivers?


My System SpecsSystem Spec
.

16 May 2010   #854
Night Hawk

W7 Ultimate x64/W10 Pro x64 dual boot main build-remote pc W10 Pro x64 Insider Preview/W7 Pro x64
 
 

That's not so odd with the OverDrive in use there. Once Windows loads up the catalyst as well as the AI settings are loaded as well. To avoid that you can either trim that back or remove the CCC while still seeing the latest driver set installed.
My System SpecsSystem Spec
16 May 2010   #855
sygnus21

Windows 10 Pro
 
 

Quote   Quote: Originally Posted by Night Hawk View Post
That's not so odd with the OverDrive in use there.
Errr....Overdrive was NEVER turned on. I NEVER use it!!! That's why it's a strange issue.

BTW I don't overclock my GPU. It's just something I never do.
My System SpecsSystem Spec
17 May 2010   #856
Night Hawk

W7 Ultimate x64/W10 Pro x64 dual boot main build-remote pc W10 Pro x64 Insider Preview/W7 Pro x64
 
 

It does tend to look that way when you compare how it is seen on the image here of the Cat. 10.4 running with a Radeon 5750 1gb card in use here. As you can see the slider bar on the top is all the way to the right suggesting perhaps a large ocing capacity while run stock here as well.


Attached Images
Latest AMD Catalyst Video Driver for Windows 7-ati-overdirve.jpg 
My System SpecsSystem Spec
17 May 2010   #857
sygnus21

Windows 10 Pro
 
 

I'm not sure what you mean but as I said before my card wasn't overclocked, nor did I, or do I, use overdrive. Period. And as noted in my post, I only unlocked overdrive after my issue.

Since I don't OC my video card, or manually control my fan, there's no need for me to us Overdrive. Thus the "strange issue"

And just for FYI, I always check my settings anytime I install CCC, just to make sure nothings out of whack. It wasn't, and overdrive wasn't unlocked.

Sorry.
My System SpecsSystem Spec
17 May 2010   #858
Night Hawk

W7 Ultimate x64/W10 Pro x64 dual boot main build-remote pc W10 Pro x64 Insider Preview/W7 Pro x64
 
 

Maybe simply unlocking it was all it took? I haven't unlocked anything here and it stays ay 39%!
My System SpecsSystem Spec
17 May 2010   #859
smarteyeball

 
 

Quote   Quote: Originally Posted by sygnus21 View Post

BTW Has anyone else had this issue with these drivers?
Tbh, mate, no. Then again I'm using 10.4a and always have a manually set fan speed.

But I have noticed that the cards BIOS powerplay states tends to 'battle' with the drivers quite often. (ie card ignores the driver settings, driver reasserts the settings etc)

The closest I've had to this issue is that on a cold boot, the fanspeed cranks to about 50-60% for a split second as CCC initialises then settles down to normal



Quote   Quote: Originally Posted by Night Hawk View Post
As you can see the slider bar on the top is all the way to the right suggesting perhaps a large ocing capacity while run stock here as well.
How far the slider goes is largely irrelevant as there will be a OC wall on stock voltages if OC'ed with CCC.
My System SpecsSystem Spec
17 May 2010   #860
stomper

Windows 7 Ultimate 64 bit
 
 

Hey there,

Do any of you know why AutoCAD, Revit and even Sketchup won;t run on any newer version of CCC?

I'm still running version 9.11, when I install the newer versions AutoCAD gives me an error, Failed to load library........! Sketchup doesn't even open at all.

I find this really weird.

Any thoughts?

Tnx
My System SpecsSystem Spec
Closed Thread

 Latest AMD Catalyst Video Driver for Windows 7




Thread Tools




Similar help and support threads
Thread Forum
Latest AMD Catalyst Video Driver for Windows 7
Latest AMD Radeon Crimson Video Driver Released How to Install AMD Graphics Drivers Without Installing Catalyst Install Manager
Graphic Cards
I need help with installing the latest AMD Catalyst Video Driver
When I install it my resolution goes to like 640x720 or something like that and I can't change it unless I rollback the driver and I need the driver to play minecraft.
Graphic Cards
BSOD after installing Latest AMD Catalyst Video Driver for Windows 7
I have a His Radeon 4850 and it seems like every time I go to install the latest updates, I get a BSOD after restarting. Am I not installing correctly or something? is there a link to the proper procedure I usually just download and install over the old. Thanks for all assistance. :)
Graphic Cards
Crush with the latest Catalyst driver.
Hello Sapphire ‏‏HD 5870 Vapor-X OC 1GB GDDR5 DX11 - my card When I install the latest 10.10 catalyst driver and running FunMark stability check my screen goes black and pc crashes. On 10.9 this never happens but then I got scaling problem with my screen samsung xl2370. Please help!
Graphic Cards
Latest ATI Catalyst Driver for Radeon X1550 on Se7en?
Hi, i'm using a Radeon X1550 on Windows 7 build 7137. What are the latest drivers avaiable for this card? Now i'm using the Catalyst 8.1 for Vista, and I can't install the Catalyst 9.3 for Vista.
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:40.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App