Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Latest AMD Catalyst Video Driver for Windows 7

17 May 2010   #861
sygnus21

Windows 10 Pro
 
 

Quote   Quote: Originally Posted by smarteyeball View Post
on a cold boot, the fanspeed cranks to about 50-60% for a split second as CCC initialises then settles down to normal
Yeah, I view that as normal. It's been that way for me since my 3870 days. Re-boot fan cranks up then settles down.

Quote   Quote: Originally Posted by smarteyeball View Post
But I have noticed that the cards BIOS powerplay states tends to 'battle' with the drivers quite often. (ie card ignores the driver settings, driver reasserts the settings etc)
Hmmm....Perhaps that's what happened to me yesterday. It was strange to have the fan mysteriously crank to 50% and stay, especially since I never enabled or messed with Overdrive (prior to the issue).

It's that's what happened, it was the first time i've seen it. At any rate things are back to normal now, I hope


My System SpecsSystem Spec
.
17 May 2010   #862
Night Hawk

W7 Ultimate x64/W10 Pro x64 dual boot main build-remote pc W10 Pro x64 Insider Preview/W7 Pro x64
 
 

What you could be seeing which didn't quite come up correct since we both are card with 1gb of onboard memory is the fact that some cards have to work harder then others with any initial load. Something is telling the fan to work a bit harder there as you were saying when starting up and remaining cranked.

Mine stays right up into the high 30s percentage wise due to a need due to the layout of the board seeing the second Crossfire slot mixed inbetween the pci slots which are now used with the nic card up close to the card itself. Unfortunately that doesn't leave much room for air flow as you can see here.


Attached Images
Latest AMD Catalyst Video Driver for Windows 7-gpu_z.jpg 
My System SpecsSystem Spec
17 May 2010   #863
Seven Eleven

Windows 7 Professional x64 SP1
 
 

two fans on my HAWK are constantly rotating at ~35%. even under load.



and everything is cool.
My System SpecsSystem Spec
.

18 May 2010   #864
Night Hawk

W7 Ultimate x64/W10 Pro x64 dual boot main build-remote pc W10 Pro x64 Insider Preview/W7 Pro x64
 
 

With one expansion card removed the fan speed dropped 2% from 39% to 37% but steady showing it is being maintained by the controller on the card itself. You expect to see this when any card is left instock not having been unlocked at any time.
My System SpecsSystem Spec
19 May 2010   #865
Proex

windows 7
 
 
Issue with 10.4 Cat

Hi, I'm having some problem with the new driver installation. Maybe it's just me since it looks like it's working very fine with everyone else.

I 1st tried to install it the normal way, and it wouldn't update my driver ( stuck at 8.632.0).

Then I tried the way with Driver Sweeper, restart in safe mode run Driver Sweeper, reboot in normal mode and install.
But it also failed, even worse now I'm stuck in 800*600 view and I don't see the ATi icon in the system tray like it used to ( but this is because the 1st time I uninstalled old cat, instead of only uninstalling only the manager I uninstalled everything )

I have windows 7 familial edition and ATi Radeon HD 4200 Integrated.
My System SpecsSystem Spec
19 May 2010   #866
sygnus21

Windows 10 Pro
 
 

Hi Proex,

Sorry but I'm not fully following what you're saying. I gather you tried to update your drivers and got an error, then did an uninstall, and are now stuck at 800 x 600? You also don't see the ATI icon as well.

Sounds like you need to try the install again. Make sure you choose to install the Catalyst Control Panel as well.

Let me know.
My System SpecsSystem Spec
19 May 2010   #867
Proex

windows 7
 
 

Thank you for trying to help me.

1st, what I did was install the cat 10.4 full package but it wouldn't update my driver, so i decided to roll back and do it again, it also didn't worked. So I decided to uninstall Cat but instead of uninstalling only the manager I uninstalled all the ATi Technologies on my computer.
So this is why I think I don't have the icon in the system tray anymore.

I did a restore on my computer to get rid of the 800*600 view, but I'm still stuck at driver version 8.632. I'm starting to think that, as win7 says, it IS up to date.
My System SpecsSystem Spec
19 May 2010   #868
sygnus21

Windows 10 Pro
 
 

Quote   Quote: Originally Posted by Proex View Post
but instead of uninstalling only the manager I uninstalled all the ATi Technologies on my computer.
So this is why I think I don't have the icon in the system tray anymore.
What you did was uninstall everything. Just do reinstall the Cat 10.4 drivers and everything should be back to normal.

We can't help until you try and reinstall the drivers.

Good luck.
My System SpecsSystem Spec
19 May 2010   #869
Night Hawk

W7 Ultimate x64/W10 Pro x64 dual boot main build-remote pc W10 Pro x64 Insider Preview/W7 Pro x64
 
 

Hello Proex Welcome to the Se7en Forums!

Are you running a crt or lcd monitor? Even with a small lcd Windows by default generally brings thing upto the native screen resolution or down one notch on a standard display to 1280x1024 or down to 1024x768 on the small 14-17" models by default. Lcds start off at 1024x768 for the old 14-15" models. It sounds a bit odd only seeing 800x600 unless a crt is in use.
My System SpecsSystem Spec
20 May 2010   #870
Proex

windows 7
 
 

Hi,
I'm using a Lcd screen.
And I did try to reinstall the cat 10.4 couple of times.
Also what I did was roll back my 8.632 driver version, then it brought me back to 800*600, then I would try to install cat 10.4 but it wouldn't change anything and the only way to update was with the windows device manager that would auto update to the 8.632 wich isn't the latest version.
The Cat 10.4 doesn't update my driver at all.
My System SpecsSystem Spec
Closed Thread

 Latest AMD Catalyst Video Driver for Windows 7




Thread Tools




Similar help and support threads
Thread Forum
Latest AMD Catalyst Video Driver for Windows 7
Latest AMD Radeon Crimson Video Driver Released How to Install AMD Graphics Drivers Without Installing Catalyst Install Manager
Graphic Cards
I need help with installing the latest AMD Catalyst Video Driver
When I install it my resolution goes to like 640x720 or something like that and I can't change it unless I rollback the driver and I need the driver to play minecraft.
Graphic Cards
BSOD after installing Latest AMD Catalyst Video Driver for Windows 7
I have a His Radeon 4850 and it seems like every time I go to install the latest updates, I get a BSOD after restarting. Am I not installing correctly or something? is there a link to the proper procedure I usually just download and install over the old. Thanks for all assistance. :)
Graphic Cards
Crush with the latest Catalyst driver.
Hello Sapphire ‏‏HD 5870 Vapor-X OC 1GB GDDR5 DX11 - my card When I install the latest 10.10 catalyst driver and running FunMark stability check my screen goes black and pc crashes. On 10.9 this never happens but then I got scaling problem with my screen samsung xl2370. Please help!
Graphic Cards
Latest ATI Catalyst Driver for Radeon X1550 on Se7en?
Hi, i'm using a Radeon X1550 on Windows 7 build 7137. What are the latest drivers avaiable for this card? Now i'm using the Catalyst 8.1 for Vista, and I can't install the Catalyst 9.3 for Vista.
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:39.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App