Fix - Catalyst Control Center - CCC - will not open/install

Page 2 of 5 FirstFirst 1234 ... LastLast

  1. Posts : 6,669
    Windows 7 x64
    Thread Starter
       #11

    That is curious
    there is another method to remove the drivers and catalyst using this program.
    Phyxion.net - Driver Sweeper
    Install it normally then reboot in safe mode before using it.
    (when you use it only check the display drivers box..nothing else.)
    That will hopefully get you to where you can start following the remainder of the instructions.
      My Computer


  2. Posts : 2
    windows 7 64bit
       #12

    ccc doesn't load on my computer. I've been doing a lot of searches and the fix that seems to be most effective for people is the one which involves removing some GAC tokens.

    Specifically the one with this number 90ba9c70f846762e

    My problem is that I don't have this number in my windows/assembly folder... hence I don't know what to do...

    Please help, I am not the only one who does not find 90ba9c70f846762e


    Thank You
      My Computer


  3. Posts : 6,669
    Windows 7 x64
    Thread Starter
       #13

    If you don't have that key token this is not the problem you are suffering from.
    You can run by microsoft's download area and make sure your .net framework is at least v3.5
    and make sure you have the latest direct x components. The driver and catalyst require these to work properly

    Then attempt another install.
    It's possible you are missing a prerequisite for the graphics driver
      My Computer


  4. Posts : 2
    windows 7 64bit
       #14

    I have the latest version of .net and direct x..

    amd vision control used to work fine.. I didn't use it very often so I'm not sure when it stopped working and definitely have no clue why.

    Any more help would be appreciated.
      My Computer


  5. Posts : 6,669
    Windows 7 x64
    Thread Starter
       #15

    Well let's do it this way, fill out your system specs a little bit more and post your own thread.
    It seems pretty obvious this isn't the problem you are suffering from so let's put it up on the board.
      My Computer


  6. Posts : 1
    Windows 7 Home Premium 64bit
       #16

    @Maguscreed 11-03-2011

    I registered here specifically to thank you for taking the time to post this solution.

    I have searched for an answer to this problem for months: yours works perfectly.
      My Computer


  7. Posts : 6,669
    Windows 7 x64
    Thread Starter
       #17

    Glad to help its been a very highly viewed thread. I hope others like you have gotten some benefit out of this and just not bothered to sign up and say anything.
      My Computer


  8. Posts : 2
    windows 7 home premium 64bit
       #18

    Maguscreed you are my saviour, your fix was the only one that worked. Ive been searching for a fix for over 4 months and after i tried your fix catalyst control centre is now finally up and running. Thank You!!!!!!!
      My Computer


  9. Posts : 6,669
    Windows 7 x64
    Thread Starter
       #19

    I feel your pain man, I only wrote this after having suffered the problem myself for several months.
    Glad to help :)
      My Computer


  10. Posts : 2
    windows 7 home premium 64bit
       #20

    AMD realy need to adress this problem because it puts many people off buying their great products
      My Computer


 
Page 2 of 5 FirstFirst 1234 ... LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 09:22.
Find Us