Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Strange monitor/graphics card when using Firefox

15 Jan 2012   #11

Windows 7 Ultimate x64

Well folks, installed the 11.12 Catalyst drivers without a problem, which I didn't expect to have in the first place. No noticeable improvement, but also no worse than before. I think I'm going to stay with the FF version I'm using now for the time being. I'll try version 10.0b4 in a few days and see if that provides any improvement.

Does anyone suppose part of my problem could be with a monitor setting? I'm running the native resolution of 1600x900 and it seems to perform just fine. The only gaming I do is GTR2, rFactor and Evo and with the new drivers they are fine as well. I just use the default graphic card settings because I've never had reason to worry about changing anything. Might there be some adjustments I can try in the CCC?

I appreciate the help I've received and I'm apt to stumble on a fix if I get pointed in the right direction. Thanks again to all who have pitched in with suggestions.

My System SpecsSystem Spec
15 Jan 2012   #12

Systems 1 and 2: Windows 7 Enterprise x64, Win 8 Developer

You could bump the rez down and see... only takes a second.
My System SpecsSystem Spec

 Strange monitor/graphics card when using Firefox

Thread Tools

Similar help and support threads
Thread Forum
strange graphics card
Hello all. I have been given another computer today and so have been busy getting the OS on and the drivers installed - but one is proving difficult to track down. It is a chinese PCI-E card with a logo I do not recognise, and the only ID I can find on it is HD-877x-ZH. I suspect it must be an...
Graphic Cards
monitor shutting off not sure if its my graphics card or the monitor
Today I got a new samsung 27" monitor and whenever I run a game the monitor will shut off then back on about every 15-20 seconds. I have a DVI to VGA (VGA into the CPU and DVI into the monitor) plugged in, and am using a 1920x1080 resolution. I have tried lowering the resolution to 1280x720 and it...
Performance & Maintenance
Graphics card and monitor resolution ?
Hi I have a Nvidia GTX 580 GPU I have just bought a Dell UltraSharp U2713HM - running a resolution at 2560*1440.I know it's not a gaming screen, but I still manage to run games pretty well. But I'm thinking. If I get a better GPU will that make the games run even better at 2560*1440 ? ...
Hardware & Devices
Strange sound coming from graphics card
Hi. I have a problem: Yesterday when I was playing a game on my PC a strange sound started coming form my graphics card. I have never experienced this before. I have an ATI Radeon HD 5870. At first I thought it was one of the fans, so I removed the graphics card and cleaned the cooler and...
Hardware & Devices
Graphics Card Change, Strange Booting Before Bios POST
Hello New To The Forums Here So Heya =] This lil issue never really bothered me but is so irritant its like a bad itch. was wondering if anybody would take 2 secs to give a tiddy hand lol basicly: when i press the ON button without my ATI Radeon HD 5450 in the PCI-E slot my pc makes 1 click...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:43.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App