Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: GTX 295 and Windows 7 RTM

14 Aug 2009   #1
loquacious

Windows 7 7600 SP1 64 Bit dual boot Windows 8 CP
 
 
GTX 295 and Windows 7 RTM

I am using NVIDIA 190.56 drivers (64 bit) and my framerate has dropped incredibly. i have gone fro a 8000 score in furmark to 1700 I have reinstalled the drivers but no difference. Anyone got any ideas?


My System SpecsSystem Spec
.
14 Aug 2009   #2
swarfega

Windows 7 Professional 64-bit
 
 

What was your performance like on the current WQHL driver? If it was better I suggest going back to it.
My System SpecsSystem Spec
14 Aug 2009   #3
EarlZ

Windows 7 Ultimate X64 RTM
 
 

Quote   Quote: Originally Posted by loquacious View Post
I am using NVIDIA 190.46 drivers (64 bit) and my framerate has dropped incredibly. i have gone fro a 8000 score in furmark to 1700 I have reinstalled the drivers but no difference. Anyone got any ideas?
It could be that theres only 1 GPU running, have you tried the latest 190.58 beta?
My System SpecsSystem Spec
.

14 Aug 2009   #4
Sassa

 
 

Quote   Quote: Originally Posted by loquacious View Post
I am using NVIDIA 190.46 drivers (64 bit) and my framerate has dropped incredibly. i have gone fro a 8000 score in furmark to 1700 I have reinstalled the drivers but no difference. Anyone got any ideas?
There is no 190.46 driver version o nVidia site...
My System SpecsSystem Spec
14 Aug 2009   #5
dpsypher

Windows 7 RTM
 
 

I have the EVGA version of the GTX295 and my frame rates have increased with the latest drivers from the nvidia site.
My System SpecsSystem Spec
14 Aug 2009   #6
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by loquacious View Post
I am using NVIDIA 190.46 drivers (64 bit) and my framerate has dropped incredibly. i have gone fro a 8000 score in furmark to 1700 I have reinstalled the drivers but no difference. Anyone got any ideas?
Go here: Drivers - Download NVIDIA Drivers

And try again. It's a driver problem. A clean sweep using driver sweeper can help. Then just try another driver. The older Vista drivers are supposed to work better in some cases. 182 or the 185 series.
My System SpecsSystem Spec
14 Aug 2009   #7
loquacious

Windows 7 7600 SP1 64 Bit dual boot Windows 8 CP
 
 

Sorry guys I made error, the drivers I was using were 190.56 Should I uninstall the old driver first and if so what with ?
My System SpecsSystem Spec
14 Aug 2009   #8
loquacious

Windows 7 7600 SP1 64 Bit dual boot Windows 8 CP
 
 

Heard bad things about 190.38 drver but it is latest on NVIDIA site .. should I install that or persist with and re-install 190.56 ?
My System SpecsSystem Spec
16 Aug 2009   #9
XGUNTHERC

Windows 7 Ultimate Edition x64
 
 

Used the latest Signed Driver, or just go back to what was giving you a higher score. I'd try a few different ones and see what works best.

Try the Xtreme G drivers to if you feel like living on the edge, lots of people get boosts from those. Google it.
My System SpecsSystem Spec
16 Aug 2009   #10
loquacious

Windows 7 7600 SP1 64 Bit dual boot Windows 8 CP
 
 

Thanks XGUNTHERC I'll give them a go... I have tried pretty much all latest NVIDIA drivers including the original i had but nothing gives me the benchmarks I was getting using Vista and I am not a fan of Vista at all.
My System SpecsSystem Spec
Reply

 GTX 295 and Windows 7 RTM




Thread Tools



Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:14.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App