Icon went missing in Windows 7? Here's a Fix

Page 1 of 4 123 ... LastLast

  1. Posts : 4
    Microsoft Windows 7 Ultimate x32
       #1

    Icon went missing in Windows 7? Here's a Fix


    Icon went missing in Windows 7? Here's a Fix


    After installing the latest and greatest Mozilla Firefox 3.5 in Windows 7 (RC Build 7100 32-bit) I noticed that after a while the icon went missing. Firefox was still working correctly, and when I checked the icon properties, and the icon was still present. But for some strange reason it wouldn’t show up in on my Desktop, my Start Menu, or my Taskbar, I would just see a broken icon.



    The resolution? Rebuilding the Windows 7 Icon Cache.

    Follow these directions:

    Icon Cache - Rebuild


    Your icons should be as good as new!

    Last edited by Brink; 14 Apr 2011 at 22:10. Reason: added link
      My Computer


  2. Posts : 3
    Windows 7 Ultimate x64
       #2

    Thank you very much for this. It worked perfectly.

    Lots of people around having this problem too.

    Cheers,

      My Computer


  3. Posts : 19
    Windows 7 Ultimate Signature Edition x64
       #3

    Thanks, I never knew how to fix this!
      My Computer


  4. Posts : 2
    Windows 7
       #4

    THANK YOU SO MUCH!! This worked perfectly!
      My Computer


  5. Posts : 3
    Windows 7 Ultimate x64
       #5

    I am finding this happens quite regularly. So I have written a little script to do it automatically. I will post links to it later once tested properly.

      My Computer


  6. Posts : 1,065
    Windows 7 Ultimate x64
       #6

    Thanks for sharing this very handy tip Young Hype. If i have this issue i usually delete the iconcache.db in Explorer an then reboot, this takes the reboot out of the equation i assume?

    I am finding this happens quite regularly. So I have written a little script to do it automatically. I will post links to it later once tested properly.

    That would be extremely handy Phil. I look forward to the link
      My Computer


  7. Posts : 12
    Windows 7 build 7600 RTM (I pre-ordered 2 copies)
       #7

    Thanks a lot man, I just installed Windows 7 Premium, and got all my programs installed using Ninite, then some of my beautiful taskbar icons reverted to generic form. I looked around for a while but only this one helped, thnx! =)
      My Computer


  8. Posts : 4
    Windows 7
       #8

    Hi I tried this, the icon is still missing for me!, I have taken a screenshot for any help.

    Many Thanks
    Hugh
    Attached Thumbnails Attached Thumbnails Icon went missing in Windows 7? Here's a Fix-ff_icon.jpg  
      My Computer


  9. Posts : 1,065
    Windows 7 Ultimate x64
       #9

    hughfraser said:
    Hi I tried this, the icon is still missing for me!, I have taken a screenshot for any help.

    Many Thanks
    Hugh
    Hi hughfraser & welcome,
    Have you tried this tutorial?
    Icon Cache - Rebuild
    Last edited by Brink; 20 Jan 2010 at 22:35. Reason: updated link
      My Computer


  10. Posts : 4
    Windows 7
       #10

    Thanks rsvr85, In the end I had to uninstall Firefox, I never lost any passwords or bookmarks as I use Roboform and Xmarks. Thanks.

    Hugh Fraser
      My Computer


 
Page 1 of 4 123 ... LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 12:27.
Find Us