Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Error when trying to open AMD Catalyst Control Manager(CCC)

20 Sep 2012   #1

windows 7 64 bit ultimate
Error when trying to open AMD Catalyst Control Manager(CCC)

I've been dealing with this issue for a few weeks now. The message that comes up when I try to open CCC is: "Could not load file or assembly 'CCC.Implementation' or one of its dependencies. The system cannot find the file specified." I've tried everything to fix this. I've followed step by step, about a dozen different guides all over the internet on how to fix this issue, but with no luck. My last resort, today, was to reformat my entire hard drive and do a fresh install of windows 7. I was flabbergasted when I still received the error. I have also tried multiple GPU's, so I know it is not a hardware problem, at least I do not think so. My reason for wanting to open CCC is because I just bought another 4890 for crossfire on Ebay but I can't even enable crossfire to get it working.

I should also say that the performance of the single 4890 is perfect, so it is running as it should be.

Rest of my system:
750watt psu

Also tried installing a previous driver from last year, still didn't work.

Latest efforts: I've reformatted my hard disk drive multiple times, installed a fresh version of Windows 7 64bit ultimate. Let windows install any and all updates. Then I install AMD's driver 12.6. I am still getting the same error. One thing I did notice was that directly after doing all of these things, CCC automatically detected my crossfire setup. I clicked enable and then CCC actually opened up. I was able to play games with CF enabled and everything. On the windows shortcut though, the CCC logo, still was giving me that error. I could not figure out a way to close the working CCC and be able to reopen it without getting the error. After restarting though, the working CCC does not come up any more, and all I'm left with is the short cut giving me the error.

My System SpecsSystem Spec
20 Sep 2012   #2

windows 7 64 bit ultimate

This is so weird. I just removed all AMD drivers via the uninstall program in windows, then cleaned up anything left over via driverfusion. Restarted. Downloaded 12.6 AGAIN. Although, this time I did a custom install. Unchecked everything except display driver and CCC. Restarted. Now CCC is up and running and has detected crossfire. I am going to keep my computer running for tonight so I can game and test my new gpu. I have a feeling that after I restart, CCC will not open up again. I don't understand how it works right after installing but then stops after a system restart. How is that possible? Anyway, I will report back later tonight after I restart my computer, to see if it still works or not.
My System SpecsSystem Spec

 Error when trying to open AMD Catalyst Control Manager(CCC)

Thread Tools

Similar help and support threads
Thread Forum
Fix - Catalyst Control Center - CCC - will not open/install
Description of problem: Ati Catalyst Control Center will not open or install in windows 7. Resolution follows: Preparation: Note - As with anything that makes changes to your system it is suggested you create a restore point before proceeding....
Graphic Cards
Catalyst control center error message and monitor resolution low.
My story: Computer: Advent D1411 (Refurbished) Graphics Card: Asus AMD Radeon HD 6670 (Brand new) Monitor: Samsung 21.5" LED Monitor OS: Windows 7 64x Accidently damaged and broke my graphics card Asus AMD Radeon HD 6670, bought a replacement (the exact same card). Plugged it in...
Graphic Cards
Service Control Manager Error
Hello, Received a Service Control Manager Error "The DHCP Client service depends on the Ancillary Function Driver for Winsock service which failed to start because of the following error: A device attached to the system is not functioning." This caused my W7 Ultimate 64 Bit computer to...
General Discussion
Catalyst Control Centre doesn't appear on list in Install Manager
Hi, I've read a lot of other posts about the same issue I'm experiencing but have so far been unable to solve. I ran install for the Catalyst Softward Suite for drivers which had the CCC listed, but there is no CCC option in the install list when I run to install. It just doesn't appear!...
Graphic Cards
ATI Catalyst Control Center wont open
I have the latest verion of the ATI CCC, it will not open, the first error message I recieved was that the GPU wasnt supported, downloaded all new drivers and software, after uninstalling the old ones, and now it wont open at all, looks like it will start but nothing happens. I checked the windows...
Graphic Cards
Cant Open CCC (Catalyst Control Center)
Sorry, if this is in the wrong section. I'm very new to these forums. :) Okay, my problem is this... I cannot open the Catalyst Control Center! I was able to open it a little while ago! I system restored and I uninstalled and reinstalled CCC! Still nothing happens. When i right click on my...
Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:07.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App