Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: sapphire 4670 problem

19 Sep 2009   #11
jfar

Vista Ult64, Win7600
 
 

Also just as a matter of interest, will you type into the search box at the Start button, Dxdiag and run that to see if it shows you any problems.


My System SpecsSystem Spec
.
19 Sep 2009   #12
rover3500

windows 7 Premium
 
 

I would guess it is a power thing as the rating thrashes the card it will need max power.I would have thought that wouldn't happen in xp.Have u tried playing a game with serious graphics in xp though.Like said b4,see what ur power supply rating should be with the calc.I would have said u haven't got the power plugged into the card,but the 4670 doesnt have that.It will make a big difference what other stuff u have plugged in your pc aswell.If u have any external drives,a couple of dvds or anything extra plugged in,it's going to take it from the graphics card.And u didn't mention if it was pci-e or agp.Alot of people r having probs with the agp ver in win7
My System SpecsSystem Spec
19 Sep 2009   #13
ATTILA04

WINDOWS7
 
 

jhongalt my processor is intel dual core E5200.clocked at 2.5 ghz....calculated my power consumption with the extreme calculator and it gives something like 278 watt.


JFAR i did the experience rating without installing the drivers.with the drivers windows7 installs automatically.


ROVER i calculated my power consumption and it gives something like 278 watts.the games i played with 4670 in xp are grid and assassins creed.i played both with full details.are these considered as heavy graphics?and my card is pci express not an agp.i had noting extra plugged in my pc while this happened.think i answered your questions.


by the way my psu is not from a good manufacturer.if you people think my psu is a problem then i will change that psu.hope it works.
My System SpecsSystem Spec
.

20 Sep 2009   #14
rover3500

windows 7 Premium
 
 

As long as ur psu complies to standards,i would have thought it was ok(there will be a sticker on it)I have 500w with the same card,a quad core(a high power 9550) and 2 cd's.I wouldn't want u to buy another psu to have it still happen.I gept blowing cards a while ago and my motherboard was faulty.Use something like hirens tools and do a complete computer check(motherboard,cpu and memory)don't do graphics check in case it blows the card again(i'm sure they wont keep giving u cards if they think theyr'e not faulty)Try googling ur power supply if u haven't already,in case someone else has had probs with it.Turn ur case upside down and shake it to make sure u haven't dropped any screws or bits of wire in there,and plug everything out and in again.Lastly if u have a multimeter,test the outputs of ur psu-u can google to find out what the outputs should be,save me writing them all down, on the molex connector.Safest thing,obviously would be to stick with Xp though i hate to say it.This is what i would try anyway.Let us know if u sort it for future reference.Run out of suggestions after that
My System SpecsSystem Spec
20 Sep 2009   #15
ATTILA04

WINDOWS7
 
 

how do i know i've sorted the problem out or not.cause i cant risk another card running windows experience index again.my psu is deluxe 420 volts.people says its a junk.but its rated 16 amp on 12 volt rail which is enough for 4670 i think.and i did check my mobo and processor.and reconnected everything before i plugged in my 2nd card.but everything in vain.now i am thinking switching to a thermaltech 450 or 500 watt psu is probably the only solution.thanks for your support brother.
My System SpecsSystem Spec
Reply

 sapphire 4670 problem




Thread Tools




Similar help and support threads
Thread Forum
Sapphire R7 240 multimonitor problem
I am using a Dell Optiplex 780. I have added a R7 240 GC to the pc so that I can use multimonitor setup. My setup are: 1x 19" monitor -VGA (1024x768p) 1x 23" monitor -DVI (1920x1080p) However, while I can connect both monitors to the card. I get a duplicated display which is annoying. The...
Graphic Cards
Sapphire radeon hd 4670 - Need Help!!!!!!!!!!
I am facing a lot of problem with my Sapphire radeon hd 46701gb ddr3 card. This is my second thread to help me for solving this problem. Aero doesn't run even with the latest driver or the old drivers i have tried all the things like enable force to run aero that doesn't work. And also use services...
Graphic Cards
ATI Radeon 4670 Display Port Problem
I have an ATI Mobility Radeon HD 4670 (on my Dell Studio XPS 1640 notebook) and I just tried to use my external monitor (Dell P2210) through a DisplayPort cable, but it did not work in Windows 7 (x64). It did display the BIOS and the Windows startup screen, but after the startup the (external)...
Graphic Cards
Sapphire Radeon HD 4670 and second VGA card problem
Had a frustrating afternoon trying to get my triple-monitor setup going again; I had WinXP for years with two video cards: a single, simple VGA / PCI card, and a recent Radeon HD 4670 card with two outputs. Under XP everything was recognized without incident, first repeating all three monitors and...
Graphic Cards
His HD 4670 ATI Vga Problem !
Hello, I have a "HIS HD 4670 IceQ Native HDMI 1GB (128bit) 850 MHz DDR3 PCIe" VGA.in windows xp i can play games need for speed - SHIFT, Resident evil 5 with maximum graphic details.No problems at all But in windows 7 above games are really slow even if i choose medium graphic details. I...
Drivers
help ATI 4670 driver problem
Everytime I try and install catalyst 9.6/driver, my screen will display only the background picture, nothing else. Ctrl-alt-del turns the screen black, esc out and back to background picture. Had to go safe mode and system restore everytime. Driver shows up in microsoft updates and same result....
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:49.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App