Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Sapphire HD 3850 AGP Card driver not working in Win7

27 Oct 2009   #11
sabontrager

Windows 7 Pro x64
 
 

the hotfix worked for me for installing CCC, but it doesn't do squat for installing a driver. and when i modify the .inf file... it appears to be working, but when i restart, i get a brief blue screen, and then it launches into the windows restore. Please help me!


My System SpecsSystem Spec
.
28 Oct 2009   #12
torrentg

7600.20510 x86
 
 

Sabontrager, your help is in post #10 at this link:

https://www.sevenforums.com/graphic-c...my-3850-a.html

Edit: On further analysis, your motherboard has a Southbridge chipset of NVIDIA® nForce3 250.

nForce3 is incompatible with ATI AGP cards, unfortunately. That is why your blue screen has happened. There is no way to get the 3850 to work on your machine.
My System SpecsSystem Spec
28 Oct 2009   #13
TheBigL

Windows 7
 
 

Quote:
Edit: On further analysis, your motherboard has a Southbridge chipset of NVIDIA® nForce3 250.

nForce3 is incompatible with ATI AGP cards, unfortunately. That is why your blue screen has happened. There is no way to get the 3850 to work on your machine.
I have the same problem (with exact settings)...
Everything you told in this forums I read and tried... EVERYTHING!!!

And after all you are saying it is FUTILE!!!...

So I understand windows 7 and my rig will not work...
what about vista... Last time my brother tried to install it he had freezes and he had to revert back to XP... Should I try again?

Thanks for your advices... been reading your posts and it was delight.

Edit: Read a little about vista... Does not supported as well... There is a workaround to make it better but still... nForce3 - Wikipedia, the free encyclopedia

Thanks for your help again.
My System SpecsSystem Spec
.

28 Oct 2009   #14
sabontrager

Windows 7 Pro x64
 
 

but it worked great on xp pro, why should 7 be any different?
My System SpecsSystem Spec
28 Oct 2009   #15
torrentg

7600.20510 x86
 
 

NVidia does not support Vista or 7 with that chipset, hence there never was a driver made for it that will work on these operating systems. This means that if you want graphics acceleration, you must use Windows XP.

This is not Microsoft's fault or Windows Vista/7 fault in any way. It is NVidia that decided to move your chipset to legacy standing a long time ago.
My System SpecsSystem Spec
28 Oct 2009   #16
sabontrager

Windows 7 Pro x64
 
 

ah. i guess that makes sense, except now... i have to go back on the market for a new graphics card! this blows... i just bought this on in july! any suggestions on what i should get?
My System SpecsSystem Spec
28 Oct 2009   #17
torrentg

7600.20510 x86
 
 

I'm sorry. Unless NVidia cards somehow get around the incompatibility, you can not run any card at all with acceleration in Windows 7 or XP.

My educated guess is that there are no video cards that can do that and it is impossible. I could be wrong, I admit. But I don't think so.

So, with your computer to run graphics well on any level, you must use Windows XP.
My System SpecsSystem Spec
28 Oct 2009   #18
sabontrager

Windows 7 Pro x64
 
 

so its my board then... i cant use any graphics card with vista/windows 7?
My System SpecsSystem Spec
28 Oct 2009   #19
torrentg

7600.20510 x86
 
 

Windows Vista Incompatibility

"Even using nforce3 with an Nvidia card causes it to only negotiate AGP 4x not 8x, and causes the system to restart repeatedly.[citation needed] There are however workarounds allowing the use of the Windows XP 32bit nForce3 GART driver under Vista 32bit, allowing use of AGP8x, and providing a more stable system."

nForce3 - Wikipedia, the free encyclopedia

My sincere advice to you is to upgrade to a new system as soon as you possibly can. I feel bad that you can't enjoy a new OS like the rest of us, but it's not within my control to do anything about it.

That being said, you could perhaps locate that GART driver and give it the good ol' college try. Or install Windows XP.
My System SpecsSystem Spec
28 Oct 2009   #20
sabontrager

Windows 7 Pro x64
 
 

if you look on my board, it also has a 1 x PCI Express x16 slot. could i use that? and not the AGP?
My System SpecsSystem Spec
Reply

 Sapphire HD 3850 AGP Card driver not working in Win7




Thread Tools




Similar help and support threads
Thread Forum
Sapphire Radeon HD 3850 - Dual/triple monitors problem.
Hi, For the last 3 years i have worked with Windows XP , 2x Sapphire Radeon HD 3850 512 MB videocards and 3 monitors connected (2x 22inch and 1x 19inch). This worked without a single problem. Since i got a terrible virus i was forced to upgrade to Windows 7. And from this moment the...
Graphic Cards
Windows 7 x86 + Sapphire HD 3850 = problem
Hi! I have a Sapphire Radeon HD3850 AGP card in my system but when i try to install the latest (or not latest) drivers (Catalyst 9.9 HOTFIX for HD2k/HD3k/HD4k AGP cards and Vista 32-bit for Windows Vista 32-bit Edition) i think it only install the defaults to standard VGA, and if I try to run...
Graphic Cards
Sapphire HD 3850 PCIe
Dear friends, I have just built my very first PC but am having problems with the above graphics card. In device manager I am able to see that my HD 3850 is being detected, but I cannot see any of the monitors I have plugged into it. I have updated the latest version of ATI Catalyst (10.1)...
Graphic Cards
SAPPHIRE HD 3850 512MB GDDR3 AGP driver
tried every ati/sapphire/amd package/hotfix and still wont work my graphic card :/ any think i should list for some help wif this?
Drivers
Sapphire HD 3850 agp help please
i looked at the stickys about this card and i cant get the driver to work no clue why i have a ASUS P4R800-VM motherboardm 2gb ram, intel pentium 4 cpu duel core 3.0ghz,Sapphire radeon HD 3850 512 agp i used 2 b on win xp but got a deadly virus and had 2 install windows 7 32bit and havnt got my...
Graphic Cards
Sapphire Radeon HD 3850 AGP + Win7 x64 = Code 43
Hi all, I know that the Sapphire card has recvd a lot of attention in the forums which made me register here. My m'board is Gigabyte GA-K8U-939 with Athlon X2 2.6 GHz and 3GB DDR. Windows 7 x64 detected the card but had an yellow symbol with the status code 43. Aero could not be enabled because...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 21:41.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App