Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: updated to catalyst 13.3 but it still shows 13.1

05 Apr 2013   #1
archer

Windows 7 ultimate x64
 
 
updated to catalyst 13.3 but it still shows 13.1

Hey all, I just saw the beta drivers 13.3 for AMD. Downloaded them and did a clean install. Everything went well. But to my surprise, when I checked the version, it still says 13.1.

Not sure why this is happening. Any suggestions friends?


My System SpecsSystem Spec
.
05 Apr 2013   #2
Solarstarshines

Windows 10 Home Premium 64bit sp1
 
 

lol it's a beta driver mine says 13.3 I installed it after a fresh install of win 7 but like I said since it is beta it is going off the WHQL version instead of the beta I'm guessing
My System SpecsSystem Spec
05 Apr 2013   #3
archer

Windows 7 ultimate x64
 
 

thank solarstarshines......I guess then I will go back to 13.1 and install 13.3 after the full release. Wouldn't this better?
My System SpecsSystem Spec
.

05 Apr 2013   #4
Solarstarshines

Windows 10 Home Premium 64bit sp1
 
 

Quote   Quote: Originally Posted by archer View Post
thank solarstarshines......I guess then I will go back to 13.1 and install 13.3 after the full release. Wouldn't this better?
it probably be the same I would just leave it if it installed correctly
My System SpecsSystem Spec
12 Apr 2013   #5
archer

Windows 7 ultimate x64
 
 

hey! I resolved it....( I think I did)....anyways, I uninstalled and installed it back....now it is 13.3
My System SpecsSystem Spec
12 Apr 2013   #6
roboticarm

Windows 7 Home Premium x64
 
 

In my opinion, one should not update drivers unless and until the newer drivers are already known to improve performance and give added benefits. Newer drivers can even bring in new problems in some cases, latest drivers are not always stable.
My System SpecsSystem Spec
12 Apr 2013   #7
archer

Windows 7 ultimate x64
 
 

Quote   Quote: Originally Posted by roboticarm View Post
In my opinion, one should not update drivers unless and until the newer drivers are already known to improve performance and give added benefits. Newer drivers can even bring in new problems in some cases, latest drivers are not always stable.
I agree with you roboticarm. But, I have always found AMD drivers very stable and regarding the beneficial updates with the new drivers, AMD has always delivered good updates for games.
My System SpecsSystem Spec
12 Apr 2013   #8
roboticarm

Windows 7 Home Premium x64
 
 

Quote   Quote: Originally Posted by archer View Post
Quote   Quote: Originally Posted by roboticarm View Post
In my opinion, one should not update drivers unless and until the newer drivers are already known to improve performance and give added benefits. Newer drivers can even bring in new problems in some cases, latest drivers are not always stable.
I agree with you roboticarm. But, I have always found AMD drivers very stable and regarding the beneficial updates with the new drivers, AMD has always delivered good updates for games.
Yeah, if it's AMD, you should download and install the latest "application profiles".
My System SpecsSystem Spec
Reply

 updated to catalyst 13.3 but it still shows 13.1




Thread Tools




Similar help and support threads
Thread Forum
Windows File Explorer shows wrong time for updated file
In File Explorer - navigate to a folder in Documents, a recently saved file by Sketchup application shows date = 9/28/17 6:48 PM do a search for the same file, date shows = 9/29/17 1:32 PM << this one is correct. Open either file and they are the same content. This happened last night...
General Discussion
Win7 connection icon shows 802.11n, but ASUS utility shows 802.11ac!
Win7pro 64bit, USB-AC56 adapter plugged into USB3.0 The windows connection icon in the task tray shows an 802.11n connection. But the ASUS "WLAN Control Center" utility shows 802.11ac. Are they both trying to control the connection? ASUS is a nightmare for driver installation.
Network & Sharing
Failed Update 0x800706be driver...but device mgr shows updated driver?
I tried to update my older Radeon ATI 5450 GPU via windows update... I received the message from windows update, and showed it failed update with the 0x800706be However when I go to device manager and check the details of the installed driver it clearly shows the new updated version? So I...
Drivers
No AMD Catalyst Control Center shows anywhere after installing driver?
I have a PC with HD 2600 Pro AGP video card. I downloaded the drivers, afterwards though there is no CCC? I see it installed a Catalyst install manager. I installed twice, so what to do to fix it? Legacy
Graphic Cards
Catalyst Control Center shows second video card as 'Disabled Adapter'
Under hardware in CCC Primary adapter: AMD Radeon HD 6900 Series Disabled adapter: AMD Radeon HD 7800 Series Drivers are up to date. I installed the 7800 as a replacement for an older (second) graphics card. I hooked them together using a Crossfire bridge. Still, the device remains...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:24.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App