Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: AMD Drivers Suddenly Broken on Upgrade

11 Aug 2013   #1

Windows 8 Pro x64
AMD Drivers Suddenly Broken on Upgrade

Until recently, I had two Gigabyte HD 6850s (no CrossFire) in one of my machines and an HD 6950 in another. Well, the two 250mm fans in the 6950's case both died within a day of each other, and of course replacing them would cost as much as a decent new the 6950 hadn't been used in a while. I also realized that perhaps this "CrossFire-ready" budget PSU is probably designed for two 6450s and not two 6850s, because the machine would not run at all smoothly unless I really downclocked one or both cards. It would often just turn off without warning. It was obviously the GPUs drawing too much power, so I swapped them out for the one 6950.

I had Catalyst 12,10 installed, if I remember correctly, and had never gotten any BSODs or other obvious signs of driver incompatibility or corruption. I'd upgrade whenever a driver was released that didn't actually hurt DP performance and never had any issues.

Until I installed the 6950, at least. Now the machine won't even get to the login screen unless I am in Safe Mode. The screen glitches up as though the card is fried (it is not, for the record) and I get a BSOD specifically naming atikmpag.sys as the culprit. It does a memory dump and reboots.

I have yet to analyze the crash dump itself - working on it.

The most irritating and frustrating thing is that, since I assume it's a driver issue, I try removing the drivers only to have Windows immediately install them again and not allow me to stop the installation at all. I was told to use gpedit.msc to prevent this, but this particular machine runs Home Premium, which does not have Group Policy Editor. I tried "deleting" the drivers during uninstall (which as it turns out doesn't really delete them) and immediately rebooting to normal mode, only to have Windows immediately install the drivers again.

So the drivers Windows automatically installs (and for some reason thinks are the best for my 6950) are dated 25 April um no. Even if I try and install Catalyst over them, the system won't boot into anything but Safe Mode successfully.

Frankly, I am at my wit's end here. I don't have the patience to manually replace individual INFs or what have you, nor can I justify the cost of a better PSU to resume using the two 6850s instead. I read a lot of threads out there like this issue, mostly from a year ago or more, and saw a lot of fixes involving uninstalling SP1 (and putting it back after drivers installed) and lots of clean Windows installs. Of course, I don't know where I wrote down my product key (I know I can find it out easily) and the best part is I don't have Windows 7 install media at all.

Of course I can't install Catalyst in Safe Mode (but I can somehow uninstall display drivers). I'm stuck.

Am I missing/overlooking something, or is this really as complicated and frustrating as it seems?

Thanks in advance for any insight you may be able to offer on this...I appreciate it.

My System SpecsSystem Spec
11 Aug 2013   #2
Mark Phelps

Win7 Pro 32-bit, Win8 Pro 32-bit

Don't know if the attached info will do what you want, but you could try it: Uninstall Drivers from Vista & Windows 7#
My System SpecsSystem Spec
13 Aug 2013   #3

Windows 7 ultimate x64

Hi NullCoding, It seems that you have installed a lot of drivers over the other drivers, without uninstalling the old ones. If this is the case, this is not recommended. Get on to Safe mode and Uninstall all the GPU drivers and then run Guru3D - Driver Sweeper. This little app will remove all the bits of old drivers. After all is done, reboot to normal mode and then install the latest drivers for your card.
Keep us posted.
My System SpecsSystem Spec


 AMD Drivers Suddenly Broken on Upgrade

Thread Tools

Similar help and support threads
Thread Forum
Skype broken after upgrade?
I fired up Skype this afternoon and it immediately launched into an upgrade. When the new version came up, it declared 'Skype Home unavailable'. All contacts were shown as offline, including the Call Testing Service, which is always available usually. The firewall is set to allow Skype. In any...
Various problems, possible drivers/services broken or missing
I've started having various problems cropping up for a couple month now.. Among them being: Periodic, random de-selection of the current active window, rendering it seemingly unresponsive to input until clicked on again. "The Windows Security Center service can't be started." "windows Update...
General Discussion
Windows 7 OEM Suddenly Not Genuine after HD Upgrade
Hi, I upgraded the HD on my HP Elitebook 8540w laptop. WIndows 7 Premium, OEM, from HP, system still under warranty. No problems for a couple weeks after the upgrade, then Windows is suddenly not valid. It is wierd. The System Properties shows Windows is Valid. But Windows Update and Microsoft...
Windows Updates & Activation
Headphone seems to be broken suddenly
Hi, I've been using Skype with my working mic for weeks and never had an issue. Today, I tried to talk to my friends but they can't hear me. However when I play a song they hear it. I didn't update anything or change any settings. Tried restarting the PC but that didn't work. Checked...
Sound & Audio
Intel G45 drivers broken
Intel G45 WDDM drivers are highly unstable and give consistant BSODs in media center. This includes the drivers that ship with Win7 RC (7100). Any ideas where/when we can get some more stable/better drivers?
Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:14.
Twitter Facebook Google+