Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: 2nd monitor screen is blank

01 Sep 2013   #1
Faris123

Windows 7 home premium 64 bit
 
 
2nd monitor screen is blank

Hello ,
I recently bought a 2nd monitor and i was intending to have my old one as the 2nd monitor however it's not working properly. The PC detects a 2nd monitor and when i drag my mouse far left side the cursor disappears meaning it went to the 2nd monitor but the monitor is blank so any help would be appreciated.:)


My System SpecsSystem Spec
.
01 Sep 2013   #2
Faris123

Windows 7 home premium 64 bit
 
 

I've read the following thread 'Dual monitor problem - 2nd monitor is blank'. Both of my Monitors are using VGA adapter and are connected to the video card not the motherboard
My System SpecsSystem Spec
01 Sep 2013   #3
PeaB4YouGo

Microsoft Windows 10 Home Build 15036
 
 

Hey Faris,

Welcome to the forums.

According to most pics I find of your vid card, you don't have 2 VGA ports on the card. You DO have two DVI plugs, and if that's what you're using, then we're good. New Egg Card Specs

One thing is to be sure that the power supply your system uses is good enough to drive the card. 600watts should be fine, but you never know. Check and be sure that the card is seated correctly, and that your system is setup to handle it. Use your NVIDIA control panel to check the card and be sure that it sees two monitors, and that both are active. I'm sure there's more to check, but this is a start, anyhow.

You may want to check to be sure the second monitor is powered up. I know it sounds stupid, but when you start your sys, it probably powers up your primary monitor by default. Check the power switch (and, I suppose, the power cable to the monitor) and be sure it's plugged in. I'm not saying that you're not smart enough to have done so earlier, but you never know what you may have missed when hooking things up.

Good luck
My System SpecsSystem Spec
.

01 Sep 2013   #4
Faris123

Windows 7 home premium 64 bit
 
 

Hey


thanks for your reply my GTX 660(non TI) has 2 DVI plugs however the monitors i'am using uses VGA connector so i use a VGA adapter to plug them.

I have checked my Nvidia control panel and it shows that the 2monitors are connected to the video card just fine.

I'am positive that the 2nd monitor is powered up because whenever i press the menu button on the monitor i receive a message 'Test good' Therefore it's powered up.

Anymore help would be appreciated :)
My System SpecsSystem Spec
01 Sep 2013   #5
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

The reason that it isn't working is that only one of the DVI ports supports VGA via adapter, the other is DVI/digital only.
My System SpecsSystem Spec
01 Sep 2013   #6
Faris123

Windows 7 home premium 64 bit
 
 

Aha isn't there a solution for it?
My System SpecsSystem Spec
01 Sep 2013   #7
Boozad

W7 Pro x64 SP1 | W10 Pro IP x64 | W8.1 Pro x64 VM | Linux Mint VM
 
 

A DVI cable.
My System SpecsSystem Spec
01 Sep 2013   #8
Faris123

Windows 7 home premium 64 bit
 
 

Ok i'll get one and will see how it goes i'll mark it as solved if it works thanks for your response all

Also if i get a DVI cable wouldn't it be impossible to connect it to the monitor since the monitor has VGA connector on it?
My System SpecsSystem Spec
01 Sep 2013   #9
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Correct, a DVI cable won't work any better than the adapter you are using, as you would still need the adapter, only on the monitor end instead of the card end.

The only solution in this case is short of a new monitor that has a DVI connection, is to use a DVI to VGA converter (totally different animal than an adapter). Only problem with that is that you can buy a new monitor for less than the converters sell for,

DVI to VGA Converter - DVI VGA Video Format Converter | StarTech.com
My System SpecsSystem Spec
01 Sep 2013   #10
Faris123

Windows 7 home premium 64 bit
 
 

I see thanks for your reply looks like i wont be able to play on 2 monitors for a while

Isn't there a way to tweak my video card or anything to have my 2nd monitor to work i'am really dying to play multi monitors
My System SpecsSystem Spec
Reply

 2nd monitor screen is blank




Thread Tools




Similar help and support threads
Thread Forum
Monitor goes blank before "welcoming screen"
Hello guys, My pc has a problem lately. Whenever it sleeps, the monitor was like turn off forever even though i moved my mouse or pressing any keyboard button. Then i tried to restart it, everything was fine till the windows logo, but then suddenly monitor went blank just exactly before the...
General Discussion
Blank screen on external monitor
So, recently my computer's files got corrupted (I think). I was loading up CS:S as usual, joined a server I love playing on and waited until I downloaded the map. I waited 10 minutes and guessed it wasn't responding, so I tried to force close it's process "hl2.exe" multiple times, but it didn't...
Graphic Cards
Dual monitor problem - 2nd monitor is blank
I have dual monitors set up for extended displays. The monitors are correctly positioned in the virtual display. When I move a window to the second monitor, it disappears from monitor 1 but doesn't show up in monitor 2 - that screen is black. Thanks
Graphic Cards
Monitor goes blank before log-in screen, stays off
When I boot-up my computer, it takes about 2 seconds longer for the monitor to turn on then usual, and right before the log-in screen the display will disappear, and stay off. The PC continues working normally, as far as I can tell. What precluded this issue? Why, I haven't the foggiest....
General Discussion
Monitor goes blank
My windows 7 has been a complete nightmare. Upgrade from Vista, didn't work since it got stuck and the rollback to vista was corrupted. I lost all my data, but that's not why I am here. After cursing at Microsoft I did a complete fresh install of windows 7. It seemed to work except for this...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:48.
Twitter Facebook Google+