Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: ATI Radeon drivers install, but fail to initialize

13 Nov 2009   #91
torrentg

7600.20510 x86
 
 

Sure Fuchser. Follow this to install but only using this .inf in my attachment here. Copy and paste it over the original .inf you will have somewhere in C:\ATI when you extract from the ATI file from their site. Then go to step 6.




Attached Files
File Type: rar CL_83742.rar (8.6 KB, 95 views)
My System SpecsSystem Spec
.
14 Nov 2009   #92
axp318

windows 7
 
 
radeon hd 4650 with windows

Hi I got the same problem when installing my agp ati hd 4650 with windows 7 all the installation complete with success but it stay to standard vga adapter my hardware id is 9495

can you help me to resolve
Thanks
My System SpecsSystem Spec
14 Nov 2009   #93
torrentg

7600.20510 x86
 
 

Quote   Quote: Originally Posted by axp318 View Post
Hi I got the same problem when installing my agp ati hd 4650 with windows 7 all the installation complete with success but it stay to standard vga adapter my hardware id is 9495

can you help me to resolve
Thanks
Yes. Follow this to install.

The only thing you have to do differently is to add this line to the .inf you'll use (in my attachments) in the section where all other similar ones are, then save it. Copy and paste it in.

"ATI Radeon HD 4650" = ati2mtag_R7X, PCI\VEN_1002&DEV_9495
My System SpecsSystem Spec
.

14 Nov 2009   #94
axp318

windows 7
 
 
torrentg

where is your attachement
Thanks
My System SpecsSystem Spec
14 Nov 2009   #95
torrentg

7600.20510 x86
 
 

At the link I gave in my last post.
My System SpecsSystem Spec
14 Nov 2009   #96
Im0rtality

Windows Seven
 
 

Hi, im having issues with HD 2400 PRO PCI...

I downloaded ATI Catalyst™ 9.10 Suite for Windows 7 (32-bit),
Added "ATI Radeon HD 2400 PRO PCI" = ati2mtag_RV610, PCI\VEN_1002&DEV_5834 to file (no other entries with 5834),
Installed drivers, changed theme, rebooted. But nothing changed. Drivers seems to be installed and device managed shows that device is ok.

Any help plz?




Copy&Paste from Properties/Details/Hardware Ids:
PCI\VEN_1002&DEV_5834&SUBSYS_81071043&REV_00
PCI\VEN_1002&DEV_5834&SUBSYS_81071043
PCI\VEN_1002&DEV_5834&CC_030000
PCI\VEN_1002&DEV_5834&CC_0300
My System SpecsSystem Spec
14 Nov 2009   #97
axp318

windows 7
 
 

I don't have your last post can you link it to me please
Thanks
My System SpecsSystem Spec
14 Nov 2009   #98
torrentg

7600.20510 x86
 
 

Quote   Quote: Originally Posted by axp318 View Post
I don't have your last post can you link it to me please
Thanks
ATI Radeon drivers install, but fail to initialize
My System SpecsSystem Spec
14 Nov 2009   #99
luckiwondr

Windows 7
 
 
OMG I finally found someone who could help!!

TorrentG,

I have been suffering with my display drivers for nearly a month. You are the closest I have been in all that time to finding help and I hope you are the one.

I situation is similar to the others. I get a blank screen with only my mouse visible whenever Win7 loads with (512mb) ATI 4650 Radeon driver installed. I hear the win7 startup tones but thats it. It works under safe mode (which is what I am using now). I hate not being able to use the full capability of my monitor.
My Win7 is 64 bit

My hardware ID is 9498.

Can you save me too?
My System SpecsSystem Spec
14 Nov 2009   #100
torrentg

7600.20510 x86
 
 

Quote   Quote: Originally Posted by luckiwondr View Post

I situation is similar to the others. I get a blank screen with only my mouse visible whenever Win7 loads with (512mb) ATI 4650 Radeon driver installed.

Can you save me too?
Sure. With system off, detach any 2nd monitor and television currently attached to video card. Leave only primary monitor with nothing else attached. Could also boot to bios to see if onboard vga is enabled and set it to disabled if it is.

Boot to Windows and see how it goes.
My System SpecsSystem Spec
Reply

 ATI Radeon drivers install, but fail to initialize




Thread Tools




Similar help and support threads
Thread Forum
New USB Device Drivers Fail to Install
I have a problem with my laptop, which is a Dell M4800 Precision running Windows 7 x64 Pro. What happens is whenever I plug in a usb device (keyboard, usb stick, usb floppy drive, etc) that this computer has not seen before, windows fails to install the device, stating that it could not find the...
Hardware & Devices
Radeon HD7570 Not Detected - Can't install drivers
Hi all. I recently installed a Radeon HD 7570 GPU into my Dell Inspiron 660s and everything was going fine until I got around to installing the relevant drivers. I opened up Device Manager to see the card being listed as "Standard VGA Graphics Adapter". Attempting to update drivers results in...
Graphic Cards
black screen after drivers install / windows update fail
hi, i am having real trouble getting this card installed again on a new install (win 7 64) when i install the AMD drivers and restart, it gets past the bios ok, the windows logo loads ok - then blank/black screen. the card is a radeon HD 6450. i have tried custom install and unticked...
Graphic Cards
How do I have Windows check for USB drivers when they fail to install?
Just purchased a new Lenovo laptop & was having unknown USB devices shown under printers & devices. It was a external usb hub & a fan. I had a choice to check let Windows Update & forgot to check the box to search for best drivers. Both werworking fine after the error. Is this a problem...
Windows Updates & Activation
Drivers fail to install everytime
For some reason, most likely a virus, all of my network adapter drivers and usb controller drivers were uninstalled. I tried manually downloading the drivers from Intel and HP for the wireless since that is all I have right now. I can only burn discs on another computer and pop it into the computer...
Drivers
Radeon 4650 AGP drivers will install, but won't initialize.
So theres an old post out there explaining my problem: https://www.sevenforums.com/graphic-cards/31442-ati-radeon-drivers-install-but-fail-initialize-10.html As well as a solution: https://www.sevenforums.com/graphic-cards/35299-install-agp-drivers-hd-3850-3650-2400-pro.html However the post...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:01.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App