Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: ATI Radeon drivers install, but fail to initialize

14 Nov 2009   #101
luckiwondr

Windows 7
 
 
Wow!

You are like...the messiah of win7. Awesome.

Thanks so much. A month of agony and figuring out what was wrong...ended in a matter of minutes. You even beat out win7 tech support 'cause they couldn't figure out a resolution. They just had me deactivate the driver and work around the problem. thanks again.


My System SpecsSystem Spec
.
14 Nov 2009   #102
torrentg

7600.20510 x86
 
 

lol glad it's working for ya.

That's mostly skill built up from following others around here and what they've said since the beta testing times.
My System SpecsSystem Spec
15 Nov 2009   #103
Im0rtality

Windows Seven
 
 

torrentg,
maybe you know anything about how to solve problem i posted before? ( ATI Radeon drivers install, but fail to initialize )
My System SpecsSystem Spec
.

15 Nov 2009   #104
torrentg

7600.20510 x86
 
 

Quote   Quote: Originally Posted by Im0rtality View Post
torrentg,
maybe you know anything about how to solve problem i posted before? ( ATI Radeon drivers install, but fail to initialize )
Check that there are no yellow exclamation points in the device manager. Either way, try to update your chipset drivers from motherboard manufacturer.
My System SpecsSystem Spec
15 Nov 2009   #105
Im0rtality

Windows Seven
 
 

Only exclamation point is at PCI standard 1/3 PCI-to-PCI bridge (This device cannot find enough free resources that it can use. (Code 12)). problem is, that I couldn't find (Vista/win7)drivers for my MB (ASUS P4R8L, Pundit-R Barebone) except Original CD which is for XP (throws an error during installation, that OS is not supported)
My System SpecsSystem Spec
15 Nov 2009   #106
torrentg

7600.20510 x86
 
 

Quote   Quote: Originally Posted by Im0rtality View Post
Only exclamation point is at PCI standard 1/3 PCI-to-PCI bridge
There' the problem. You need that working well. Find driver for it or no go.

Update your bios to latest made as well. After, disable all unused ports such as floppy, serial, parallel...etc...
My System SpecsSystem Spec
15 Nov 2009   #107
Im0rtality

Windows Seven
 
 

Quote   Quote: Originally Posted by torrentg View Post
Quote   Quote: Originally Posted by Im0rtality View Post
Only exclamation point is at PCI standard 1/3 PCI-to-PCI bridge
There' the problem. You need that working well. Find driver for it or no go.

Update your bios to latest made as well. After, disable all unused ports such as floppy, serial, parallel...etc...
I'm using latest BIOS version. I also tried to disable various stuff (serial ports, CardBuss, 1394, etc) - no success.
There are 3 PCI-to-PCI bridge devices in win7 and 2 in winXP (dual boot).

I tried to disable one of bridges via Device Manager and 1st one lost its exclamation icon... however, that device was for LAN - i lost connection to internet. Rebooted, but devices restored themselves - 1st not enough resources, LAN ok...

I think I need to free up one PCI slot, but there are only 2, and one is free (other for graphics card)... But I might be wrong here...

Any ideas?
My System SpecsSystem Spec
15 Nov 2009   #108
torrentg

7600.20510 x86
 
 

Quote   Quote: Originally Posted by Im0rtality View Post

Any ideas?
Yeah. You're going to need some kind of chipset update compared to what's running now. If you can't find one or none available, unfortunately, it's not going to work.
My System SpecsSystem Spec
15 Nov 2009   #109
Im0rtality

Windows Seven
 
 

Quote   Quote: Originally Posted by torrentg View Post
Yeah. You're going to need some kind of chipset update compared to what's running now. If you can't find one or none available, unfortunately, it's not going to work.
What exactly you mean by chipset?
My System SpecsSystem Spec
15 Nov 2009   #110
axp318

windows 7
 
 
big thank you

Thank you torrentg it was really appreciate for your big help and it really rare that you can see people share there experience.
My System SpecsSystem Spec
Reply

 ATI Radeon drivers install, but fail to initialize




Thread Tools




Similar help and support threads
Thread Forum
New USB Device Drivers Fail to Install
I have a problem with my laptop, which is a Dell M4800 Precision running Windows 7 x64 Pro. What happens is whenever I plug in a usb device (keyboard, usb stick, usb floppy drive, etc) that this computer has not seen before, windows fails to install the device, stating that it could not find the...
Hardware & Devices
Radeon HD7570 Not Detected - Can't install drivers
Hi all. I recently installed a Radeon HD 7570 GPU into my Dell Inspiron 660s and everything was going fine until I got around to installing the relevant drivers. I opened up Device Manager to see the card being listed as "Standard VGA Graphics Adapter". Attempting to update drivers results in...
Graphic Cards
black screen after drivers install / windows update fail
hi, i am having real trouble getting this card installed again on a new install (win 7 64) when i install the AMD drivers and restart, it gets past the bios ok, the windows logo loads ok - then blank/black screen. the card is a radeon HD 6450. i have tried custom install and unticked...
Graphic Cards
How do I have Windows check for USB drivers when they fail to install?
Just purchased a new Lenovo laptop & was having unknown USB devices shown under printers & devices. It was a external usb hub & a fan. I had a choice to check let Windows Update & forgot to check the box to search for best drivers. Both werworking fine after the error. Is this a problem...
Windows Updates & Activation
Drivers fail to install everytime
For some reason, most likely a virus, all of my network adapter drivers and usb controller drivers were uninstalled. I tried manually downloading the drivers from Intel and HP for the wireless since that is all I have right now. I can only burn discs on another computer and pop it into the computer...
Drivers
Radeon 4650 AGP drivers will install, but won't initialize.
So theres an old post out there explaining my problem: https://www.sevenforums.com/graphic-cards/31442-ati-radeon-drivers-install-but-fail-initialize-10.html As well as a solution: https://www.sevenforums.com/graphic-cards/35299-install-agp-drivers-hd-3850-3650-2400-pro.html However the post...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:01.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App