Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: ATI Radeon drivers install, but fail to initialize

27 Oct 2009   #21
rrlundbo

Windaows 7 64-bit Home Premium
 
 

Thanks torrentg,

I am at work right now so I will have to wait till later on to work on the Windows 7 computer at home. I will try a few things and get back to this thread.

I did email Gigabyte tech support for updated drivers so only time will tell.

thanks again,

Rick


My System SpecsSystem Spec
.
28 Oct 2009   #22
rrlundbo

Windaows 7 64-bit Home Premium
 
 

Okay,

In my haste I missed teh part where torrentg says to use the straight up, latest and greatest Catalyst driver for this inf fix.

I goofed around last night to no avail with the drivers from Gigabyte and the ATI Hotfix.

My suspicion is that there is something up with the Vista x64 AGP Hotfix and Gigabyte driver that is a no go in Windows 7. My BSOD mentions atikmdag.sys it is possible this is tweaked in the Hotfix and Gigabyte drivers in such a way as to not work in Win 7.

I will try again this evening...and then if I have no success I will begin pleading for help.

It's all in the details I suppose. I will keep you posted.

Rick
My System SpecsSystem Spec
28 Oct 2009   #23
torrentg

7600.20510 x86
 
 

x64 will need this workaround to run any of my .inf edits.

SG FAQ :: How to disable driver signing (integrity checks) in Vista 64 / Server 2008 x64 ?
My System SpecsSystem Spec
.

28 Oct 2009   #24
rrlundbo

Windaows 7 64-bit Home Premium
 
 

I wonder if this is why the Vista x64 dirvers for AGP don't work in Win 7...since ATI is not offically supporting AGP maybe Win 7 x 64 does not see the Hotfix drivers as "signed"?
My System SpecsSystem Spec
28 Oct 2009   #25
sevjr112175

windows7 build 7264
 
 

@ torrentg.. hi i have a problem with my ATI as well i can't play games on full screen maybe you can help me.. mine is ATI Mobility Radeon HD 4530 Series... 9553 is the last four digits T.I.A already downloaded the latest driver
My System SpecsSystem Spec
28 Oct 2009   #26
torrentg

7600.20510 x86
 
 

Works differently with yours because mobility.

Right click adapter in device manager, properties, details tab, change dropdown to hardware ids. Copy and paste all you see there, to a post here.
My System SpecsSystem Spec
29 Oct 2009   #27
sevjr112175

windows7 build 7264
 
 

PCI\VEN_1002&DEV_9553&SUBSYS_3060103C&REV_00
PCI\VEN_1002&DEV_9553&SUBSYS_3060103C
PCI\VEN_1002&DEV_9553&CC_030000
PCI\VEN_1002&DEV_9553&CC_0300

hi torrentg thanks for the quick reply here is mine T.I.A
My System SpecsSystem Spec
29 Oct 2009   #28
rrlundbo

Windaows 7 64-bit Home Premium
 
 

Mercy! Uncle! etc.

Well I give. I have exhausted my limited experience. I will start a new thread replete with minidumps and Hardware Id's tonight if performing an upgrade from a new install of Vista X64 does not work.

Hopefully it works though.

Rick
My System SpecsSystem Spec
29 Oct 2009   #29
torrentg

7600.20510 x86
 
 

Sevjr, please see this resource. It will help you install the latest driver ATI offers for desktop models.

http://www.driverheaven.net/modtool.php

Good luck RR. On the plus side, with a great member's help here, I've started reading minidumps much better than I was able to...so...

I hope you won't need much help further and things go well.
My System SpecsSystem Spec
29 Oct 2009   #30
The Dark Legacy

Windows 7 32-bit
 
 

Hi Torrentg,

Would be greatful if you could help me out dude, this looks like a working solution;

PCI\VEN_1002&DEV_9495&SUBSYS_0028174B&REV_00
PCI\VEN_1002&DEV_9495&SUBSYS_0028174B
PCI\VEN_1002&DEV_9495&CC_030000
PCI\VEN_1002&DEV_9495&CC_0300

I've got the ATI HD4650, I tried to use the files you upped on pages 1 and 2 but they were down. I just really want to get my AGP card working again. Thanks
My System SpecsSystem Spec
Reply

 ATI Radeon drivers install, but fail to initialize




Thread Tools




Similar help and support threads
Thread Forum
New USB Device Drivers Fail to Install
I have a problem with my laptop, which is a Dell M4800 Precision running Windows 7 x64 Pro. What happens is whenever I plug in a usb device (keyboard, usb stick, usb floppy drive, etc) that this computer has not seen before, windows fails to install the device, stating that it could not find the...
Hardware & Devices
Radeon HD7570 Not Detected - Can't install drivers
Hi all. I recently installed a Radeon HD 7570 GPU into my Dell Inspiron 660s and everything was going fine until I got around to installing the relevant drivers. I opened up Device Manager to see the card being listed as "Standard VGA Graphics Adapter". Attempting to update drivers results in...
Graphic Cards
black screen after drivers install / windows update fail
hi, i am having real trouble getting this card installed again on a new install (win 7 64) when i install the AMD drivers and restart, it gets past the bios ok, the windows logo loads ok - then blank/black screen. the card is a radeon HD 6450. i have tried custom install and unticked...
Graphic Cards
How do I have Windows check for USB drivers when they fail to install?
Just purchased a new Lenovo laptop & was having unknown USB devices shown under printers & devices. It was a external usb hub & a fan. I had a choice to check let Windows Update & forgot to check the box to search for best drivers. Both werworking fine after the error. Is this a problem...
Windows Updates & Activation
Drivers fail to install everytime
For some reason, most likely a virus, all of my network adapter drivers and usb controller drivers were uninstalled. I tried manually downloading the drivers from Intel and HP for the wireless since that is all I have right now. I can only burn discs on another computer and pop it into the computer...
Drivers
Radeon 4650 AGP drivers will install, but won't initialize.
So theres an old post out there explaining my problem: https://www.sevenforums.com/graphic-cards/31442-ati-radeon-drivers-install-but-fail-initialize-10.html As well as a solution: https://www.sevenforums.com/graphic-cards/35299-install-agp-drivers-hd-3850-3650-2400-pro.html However the post...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:32.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App