Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: ATI Radeon drivers install, but fail to initialize

05 Nov 2009   #71
torrentg

7600.20510 x86
 
 

Quote   Quote: Originally Posted by clowninasack View Post
I seem to be having the same problem! My card is an nVidia 8800GT (two of them, actually). Does your solution work on these cards as well? I'm using the latest driver for Vista x64 (191.07).
Hi.

No, all you need is the driver straight from this link for GeForce 8 series x64, Windows 7.


My System SpecsSystem Spec
.
06 Nov 2009   #72
SevenDragon

Windows 7
 
 

I have an ATI HD4600 card and i cant install the catalyst control center.
When i run the setup it closes with a message "the program has encountered an error and needs to close.

I have tried version 9-9 and 9-10 without sucess.
Running Windows 7 32bit professional and the program as administrator.

Any tips?
My System SpecsSystem Spec
06 Nov 2009   #73
torrentg

7600.20510 x86
 
 

Use "uninstall or change a program" from Computer (Windows Explorer.) Use Catalyst ATI Install Manager to remove all ATI stuff from the system.

Right click on video card in device manager. Uninstall and tell it to remove the driver too.

Install from latest driver .exe off ATI/AMD website.
My System SpecsSystem Spec
.

10 Nov 2009   #74
Darren Link

Windows 7 32 bit edition
 
 

I managed to get my Gigabyte ATI Radeon HD 4650 graphics card working under windows 7 with my ASUS K8VSE Deluxe motherboard by following torrentg's advice of modifying the drivers .INF file. Many thanks Torrentg. I was pulling my hair out. I downloaded driver "9-10_vista32_win7_32_dd_ccc_wdm_enu" from The Ultimate Experience for Gaming | GAME.AMD.COM and added the following line to C:\ATI\Support\9-10_vista32_win7_32_dd_ccc_wdm_enu\Driver\Packages\Drivers\Display\W7_INF\CL_83742.inf.

"ATI Radeon HD 4650 AGP" = ati2mtag_R7X, PCI\VEN_1002&DEV_9495

The graphics card is working brilliantly with my main display but when hooked up to my HD TV via HDMI the picture is displayed but with a 2-3 inc black border all around the image. Under Windows XP (dual boot setup) the display is full screen. No matter what I do with Catalyst Control Center I cannot get a full screen display on my HD. The resolution is 1920x1080 (60 Hz). If I can get this working I will be really pleased as my 5 year old PC has a far better windows user experience index (4.9) than my parents brand new PC (3.2).

Many thanks for any advice you can give me. In the meantime I'm using Windows XP to drive my TV and am hoping for a driver release that requires no manual modifications.

Thanks

Darren
My System SpecsSystem Spec
10 Nov 2009   #75
torrentg

7600.20510 x86
 
 

Quote   Quote: Originally Posted by Darren Link View Post
The graphics card is working brilliantly with my main display but when hooked up to my HD TV via HDMI the picture is displayed but with a 2-3 inc black border all around the image.
Quite welcome. Look for an "overscan" adjustable setting in the Catalyst Control Center and/or the tv itself.
My System SpecsSystem Spec
10 Nov 2009   #76
Darren Link

Windows 7 32 bit edition
 
 

Thanks once again Torrentg.

It took some finding but reducing the underscan from 15% down to 0% solved my problem.

In ATI Catalyst Control Center version 2009.0925.1707.28889 the configure option is missing from the context menu for the large graphics reprsenting your displays. You need to right click on the triangle in the smaller displays in the bottom right hand corner to find the configure option. (Just above the Basic.. button).

Thank you so much for all your help Torrentg. A few days ago I had default VGA graphics and no HDMI output. Now I have everything working and even have HDMI audio working to the TV.

Thanks for replying so quickly. We can now spend the rest of the evening watching a film from Windows 7
My System SpecsSystem Spec
11 Nov 2009   #77
ALBIG

Windows 7 (just upgraded from XPMCE)
 
 
Sapphire HD 3650 AGP

Torrentg, I have q question for you. I have been following this thread as I had been having the same problem of not being able ti install the ATI drivers. I have a Sony Vaio Desktop with 2GB and Windows 7 upgrade, and I finally got the machine to install the ATI driver. The driver it installed was the 8.6 version, July, 2009. My question is this; Should I try to install the ATI 9.10 version?
My System SpecsSystem Spec
11 Nov 2009   #78
torrentg

7600.20510 x86
 
 

Quote   Quote: Originally Posted by ALBIG View Post
Torrentg, I have q question for you. I have been following this thread as I had been having the same problem of not being able ti install the ATI drivers. I have a Sony Vaio Desktop with 2GB and Windows 7 upgrade, and I finally got the machine to install the ATI driver. The driver it installed was the 8.6 version, July, 2009. My question is this; Should I try to install the ATI 9.10 version?
Yes you should, but you've been following the wrong thread.

Install AGP Drivers for HD 3850, 3650, 2400 PRO
My System SpecsSystem Spec
11 Nov 2009   #79
Halfway Ash

Windows 7
 
 

Hey torrentg

Wonder if you can help
I have ATI Mobility Radeon HD4570 and also HD3200, two GPU's, one is discrete and the other embedded I think

When plugged in the 4570 should be used and the 3200 when on battery as power saving.
Since I installed windows 7 I can't select the high performance GPU.
The CCC doesn't seem to work neither

HARDWARE ID's FOR 4570

PCI\VEN_1002&DEV_9553&SUBSYS_02371025&REV_00
PCI\VEN_1002&DEV_9553&SUBSYS_02371025
PCI\VEN_1002&DEV_9553&CC_030000
PCI\VEN_1002&DEV_9553&CC_0300

HARDWARE ID's FOR 3200

PCI\VEN_1002&DEV_9612&SUBSYS_02361025&REV_00
PCI\VEN_1002&DEV_9612&SUBSYS_02361025
PCI\VEN_1002&DEV_9612&CC_030000
PCI\VEN_1002&DEV_9612&CC_0300

What should I do next.
All I have done so far is try windows update.
The driver update for the 4500 series via windows update always fails

Thanks in advance
My System SpecsSystem Spec
11 Nov 2009   #80
torrentg

7600.20510 x86
 
 

Halfway, upload the .inf from the driver package - after compressed to .rar - use the paperclip function at top of a new post.

I'll edit it and tell you how to install, to attempt to get this to work.

Download the desktop version, first. Then extract to C:\ATI
My System SpecsSystem Spec
Reply

 ATI Radeon drivers install, but fail to initialize




Thread Tools




Similar help and support threads
Thread Forum
New USB Device Drivers Fail to Install
I have a problem with my laptop, which is a Dell M4800 Precision running Windows 7 x64 Pro. What happens is whenever I plug in a usb device (keyboard, usb stick, usb floppy drive, etc) that this computer has not seen before, windows fails to install the device, stating that it could not find the...
Hardware & Devices
Radeon HD7570 Not Detected - Can't install drivers
Hi all. I recently installed a Radeon HD 7570 GPU into my Dell Inspiron 660s and everything was going fine until I got around to installing the relevant drivers. I opened up Device Manager to see the card being listed as "Standard VGA Graphics Adapter". Attempting to update drivers results in...
Graphic Cards
black screen after drivers install / windows update fail
hi, i am having real trouble getting this card installed again on a new install (win 7 64) when i install the AMD drivers and restart, it gets past the bios ok, the windows logo loads ok - then blank/black screen. the card is a radeon HD 6450. i have tried custom install and unticked...
Graphic Cards
How do I have Windows check for USB drivers when they fail to install?
Just purchased a new Lenovo laptop & was having unknown USB devices shown under printers & devices. It was a external usb hub & a fan. I had a choice to check let Windows Update & forgot to check the box to search for best drivers. Both werworking fine after the error. Is this a problem...
Windows Updates & Activation
Drivers fail to install everytime
For some reason, most likely a virus, all of my network adapter drivers and usb controller drivers were uninstalled. I tried manually downloading the drivers from Intel and HP for the wireless since that is all I have right now. I can only burn discs on another computer and pop it into the computer...
Drivers
Radeon 4650 AGP drivers will install, but won't initialize.
So theres an old post out there explaining my problem: https://www.sevenforums.com/graphic-cards/31442-ati-radeon-drivers-install-but-fail-initialize-10.html As well as a solution: https://www.sevenforums.com/graphic-cards/35299-install-agp-drivers-hd-3850-3650-2400-pro.html However the post...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:24.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App