Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No Aero Support on ATI mobility radeon 9800

04 Nov 2009   #31
torrentg

7600.20510 x86
 
 

Has nothing to do with Microsoft or kinks to be worked out. Time is no cure in this instance.


My System SpecsSystem Spec
.
13 Nov 2009   #32
Maattt

Windows 7
 
 

Quote   Quote: Originally Posted by torrentg View Post
Sorry.

ASUSTeK Computer Inc.

Anything nForce3 or below is impossible to work in 7 or Vista. Must use XP.
I GOT IT TOO WORK ON THE NFORCE2
just to let any of you know..

I wiped windows 7 off..
Installed XP.. installed the Unified Driver for my motherboard instead of just the standard one included with xp and got everything running fine.

made a new partition and installed windows 7.. got full Graphics card support including Aero

and for some reason it now works
My System SpecsSystem Spec
13 Nov 2009   #33
torrentg

7600.20510 x86
 
 

Quote   Quote: Originally Posted by Maattt View Post
Quote   Quote: Originally Posted by torrentg View Post
Sorry.

ASUSTeK Computer Inc.

Anything nForce3 or below is impossible to work in 7 or Vista. Must use XP.
I GOT IT TOO WORK ON THE NFORCE2
just to let any of you know..

I wiped windows 7 off..
Installed XP.. installed the Unified Driver for my motherboard instead of just the standard one included with xp and got everything running fine.

made a new partition and installed windows 7.. got full Graphics card support including Aero

and for some reason it now works
Awesome! Can you show us a screenshot?

Edit - (something tells me this is never going to happen.)
My System SpecsSystem Spec
.

13 Nov 2009   #34
Maattt

Windows 7
 
 

Quote   Quote: Originally Posted by torrentg View Post
Quote   Quote: Originally Posted by Maattt View Post
Quote   Quote: Originally Posted by torrentg View Post
Sorry.

ASUSTeK Computer Inc.

Anything nForce3 or below is impossible to work in 7 or Vista. Must use XP.
I GOT IT TOO WORK ON THE NFORCE2
just to let any of you know..

I wiped windows 7 off..
Installed XP.. installed the Unified Driver for my motherboard instead of just the standard one included with xp and got everything running fine.

made a new partition and installed windows 7.. got full Graphics card support including Aero

and for some reason it now works
Awesome! Can you show us a screenshot?

Edit - (something tells me this is never going to happen.)
here you go.. sorry i had to go out


Attached Thumbnails
No Aero Support on ATI mobility radeon 9800-screen1.jpg  
My System SpecsSystem Spec
14 Nov 2009   #35
torrentg

7600.20510 x86
 
 

Hey, if this is for real, then congats.

Did you install some kind of MCP update driver or something made by a 3rd party or end user?

In case I have to tell others, how exactly did you get this to work?
My System SpecsSystem Spec
14 Nov 2009   #36
Maattt

Windows 7
 
 

Quote   Quote: Originally Posted by torrentg View Post
Hey, if this is for real, then congats.

Did you install some kind of MCP update driver or something made by a 3rd party or end user?

In case I have to tell others, how exactly did you get this to work?
i dont know really mate, i didnt do anything.

i decided i wanted to install XP so i can run games, cause they wouldnt run on 7 with the graphics card driver not working.
so I install XP on another partition, one of the drivers with XP wernt working correctly so i downloaded the Unified driver for xp and then everything was fine.
i then tried to dual boot both..
windows 7 BCD registry was corrupt apparently (using VistaBootPro)

I then deleted the Windows 7 partition and reinstalled it after installing XP.. let it do the setup and the aero was working straight away..
so either it got them from update or i dont know..
My System SpecsSystem Spec
15 Nov 2009   #37
jaredgood

Windows 7 Ultimate
 
 

Ya, this is how I got mine to work. Do a fresh Install of Windows 7. Then install any drivers necassary to "connect to the Internet ONLY." Then immediatley the first thing you do, open windows update. Windows Update will provide you with an updated driver that supports Aero.

It will not work if you install a driver for your graphics card first and then check Windows Update. It will recognize your driver as good and not provide you with the updated Aero supported driver. Then I would goto the Microsoft Windows Update Cateloge and download and save that driver to and external HDD or USB Stick so the next time you need it or do a clean install of your OS just use that driver.
My System SpecsSystem Spec
25 Nov 2009   #38
fishnbanjo

Vista 64 Ultimate, Windows 7 64 Ultimate, Ubuntu 9.10
 
 

I have a DELL XPS Gen 1 laptop with an ATI 9700 128 Mb mobility card and W7 Pro 32 and AERO worked right off the bat when W7 installed.
My System SpecsSystem Spec
25 Nov 2009   #39
torrentg

7600.20510 x86
 
 

Quote   Quote: Originally Posted by fishnbanjo View Post
I have a DELL XPS Gen 1 laptop with an ATI 9700 128 Mb mobility card and W7 Pro 32 and AERO worked right off the bat when W7 installed.
The million dollar question here is - were you disconnected from network access when installing Windows?
My System SpecsSystem Spec
25 Nov 2009   #40
fishnbanjo

Vista 64 Ultimate, Windows 7 64 Ultimate, Ubuntu 9.10
 
 

Quote   Quote: Originally Posted by torrentg View Post
Quote   Quote: Originally Posted by fishnbanjo View Post
I have a DELL XPS Gen 1 laptop with an ATI 9700 128 Mb mobility card and W7 Pro 32 and AERO worked right off the bat when W7 installed.
The million dollar question here is - were you disconnected from network access when installing Windows?
Yes, and no. I did a fresh installation because I had XP Pro SP 3 loaded so an update was not in the offing and I did a clean install. I also have wireless which is WPA-2 protected so I did not have immediate access until I put the encryption data in the connection field but did once Windows launched for final installation. The whole process took 35 minutes and then 10 minutes for MS Updates which included new drivers for the ATI Radeon Mobility 9700 with 128 Mb RAM.

p.s. As you would surmise this is my laptop and not the PC in my system specs.
My System SpecsSystem Spec
Reply

 No Aero Support on ATI mobility radeon 9800




Thread Tools




Similar help and support threads
Thread Forum
Windows Aero Effect on ATI MOBILITY RADEON X300 Card
i have installed windows 7 recently on my dell 6000 inspiron, it has ATI MOBILITY RADEON X300 Card 2GB ram, but iam not able to experience Windows Aero Effect, i have tried roubleshooter, but still iam unable, PLEASE HELP!
Graphic Cards
ATI MOBILITY RADEON X600 and Aero
I am unable to find any drivers for this Graphic Card. :( I am using TOSHIBA SATELLITE M65-S909 laptop and on the Toshiba web page I can download only drivers for Windos XP. Is there any help to get Aero?
Graphic Cards
ATI Radeon 9800 pro won't install!
:mad: Using Windows 32bit (x86) and trying to install my ATI Radeon 9800 pro (AGP) card. This card WAS working just fine before but I cannot remember how to properly install it again. I AM aware that this card is not supported with it's own windows 7 legacy drivers and must use ATI's...
Graphic Cards
ATI Mobility Radeon X2500 vs Aero DWM.. pls help!
Hello, I have an ACER TravelMate 5720G notebook with ATI Mobility Radeon X2500. Unfortunately the Latest Windows 7 ATI Catalyst Beta Driver Package does not support this card. The only driver I found that works is DNA's ATI-VISTA/WIN7 9.3 x32. Do Not Argue | DNA-ATi Vista/Win7 9.3 x32 | ...
Graphic Cards
ATI Mobility Radeon not support by windows 7?
My laptop spec Manufacture : Acer Model : Aspire 4810TG Processor : Inter(R) Core(TM)2 Duo CPU Memory(RAM) : 2.00GB DDR3 Storage : 320 GB HDD System type : 32-bit OS OS : Windows 7 Ultimate 32 bit Graphic Card : ATI Mobility Radeon HD 4330
Graphic Cards
Will a ATI Mobility Radeon x1400 be able to support W7?
I have a kind of old laptop, a Dell Inspiron E1705, and it has an ATI Radeon x1400 graphics card. I really want to install Windows 7, but I'm not sure if this card will be able to support the Aero interface. Will everything go smoothly?
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:14.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App