Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Graphics Card not recognised

17 Sep 2014   #1

Windows 7 Ultimate x64
Graphics Card not recognised

Hi everyone,

A few weeks ago i noticed that Windows was not using the usual Aero theme with the see-through task bar etc. I didn't worry about it until last night. I typed "Aero" into the windows search box in the Start menu and selected "Find and fix problems with transparency and other visual effects."

I ran the troubleshooter and got the message - "Update the driver for your video card. The current video card may support Aero with a driver that is compliant with the Windows Display Driver Model (WDDM). Contact the manufacturer of your computer or video card for a WDDM-compatible driver."
This is strange as Aero has been working fine up until a couple of weeks ago and i haven't changed anything.

My monitor is plugged into the graphics card and the fans are spinning, so i don't think it's dead.


All windows updates are installed.

I have entered Device Manager and under "Display Adaptors" i see Intel(R) HD Graphics 4000" and "Standard VGA Graphics Adaptor".

I went to AMD's website and navigated through some drop down menus to this page:

I downloaded the software and ran it. After the installation Catalyst Control Centre was not installed on my machine anywhere that i could find. In the "Program Files" folder on C: there is an "ATI Technologies" folder that is empty. There is also a "ATI" folder with a "CIM" subfolder.

I did some googling and tried using Add/Remove Programs to remove "AMD Catalyst Install Manager", then deleted the folders mentioned above as well as my AMD folder, as recommended by AMD in the link provided above. I then rebooted the PC and tried to install again. Same result. It seems to only install the "AMD Catalyst Install Manager" and "HDMI Audio Drivers". During the installation it only briefly stops on "Detecting hardware" before skipping over this step.

After some more googling i tried uninstalling the above again, then ran CC Cleaner, then booted into Safe Mode and ran "Display Driver Uninstaller" program which seemed to be successful as when i rebooted the screen resolution was really large. After adjusting that to something workable and trying to reinstall Catalyst/Drivers from the AMD website, i got the same result as before. I then tried an earlier version of the software both from the website and disc that came with the card. No luck.

I also tried going to Device Manager and Uninstalling the "Standard VGA Graphics Adaptor", rebooted, then tried to manually choose the folder, in Device Manager, that i downloaded from AMD to force it to install the correct driver, but it just tells me the most up to date driver is already installed.

I have checked in UEFI motherboard menu, and it is set to preference PCIe, where the card is installed. I have tried installing it in another PCIe slot to no avail, although the UEFI menu System Browser did register that the card had been moved to a different slot. It referred to it as a VGA device though.

When installing the files from AMD i have run them as Admin (although my user account is already admin) and also ensured the file is unblocked.

I have also tried a system restore to a couple of months ago, this also didn't help. Catalyst Control Centre was installed then, but wouldn't open. I have since tried reinstalling it and have gotten no where.

The last thing i attempted was to update the BIOS on my motherboard, which also has not helped, although it did update successfully.

At this stage i am simply stumped and very stressed over this issue, if anyone could be of assistance i would be VERY grateful.

Here are my system specs, i entered them when i registered my account but i don't know how these forums work so i will enter them here again anyway to be sure:

CPU: Intel Core i5-3570K 3.4GHz Quad-Core

Motherboard: ASRock Z77 Extreme4 ATX LGA1155

RAM: G.Skill Ares Series 8GB (2 x 4GB) DDR3-1600

Storage: Crucial M4 128GB 2.5" SSD & Seagate Barracuda 2TB 3.5" 7200RPM

Graphics Card: Gigabyte Radeon HD 7970 GHz Edition 3GB

Power Supply: Corsair 750W ATX12V / EPS12V

My System SpecsSystem Spec
18 Sep 2014   #2

Windows 7 Ultimate x64

I'm sorry to post again but i am really getting desperate. I have tried a Windows system restore to a few months ago and this hasn't helped.

I have also tried Display Driver Uninstaller again, in safe mode, and it recognises the model of graphics card that i have in it's logs, so i think the card is fine, i just can't get the drivers to install. Does anyone have any suggestions at all?
My System SpecsSystem Spec
18 Sep 2014   #3

Windows 7 Ultimate x64

After Googling around some more i found a case where someone had my exact card and had to flip a BIOS switch (apparently the card has 2 BIOS?) from 2 to 1 to get it to work.

I did this, and when i rebooted the PC the resolution was messed up and new drivers were installing. Usually this would be the VGA graphics adaptor drivers, but this time it was slower and i had time to check what it was doing. It said it was installing drivers for my card and listed its name - progress!!

However in device manager it is still listed as Standard VGA adaptor and still not working, even after reboot and attempting to resintall the drivers again... damn... but something changed...

EDIT: I just rebooted into safe mode and used the Display Driver Uninstaller, which is still detecting what sort of card i have in it's logs. In safe mode the resolution was normal, whereas previously it has been huge. Another change. After the uninstallation, back in normal Windows, the driver software installed again, and it was the VGA driver software, just as before. I still can't install catalyst control manger or the drivers manually through device manager. Damn.
My System SpecsSystem Spec

18 Sep 2014   #4

Windows 7 Ultimate x64

The next thing i have tried is reseating the graphics card again, and changing the BIOS switch back to option 2. Upon reboot, device manager displayed the correct card, but there was a yellow excalamation mark next to it. I tried pointing device manager to the correct driver but it kept saying it wasn't compatible with my version of windows.

I uninstalled the AMD software, at which point the device manager reverted to displaying standard vga adaptor.

Leaving the software uninstalled i switched the gfx card bios switch back to 1, rebooted and then the resolution was large and device manager was displaying vga adaptor again.

Next, i tried to install the drivers again. This time the AMD installer said it was installing catalyst and the amd drivers, when every single time previously it has just skipped these and the install has been extremely fast. It took ages to install some amd gaming evolved app, then just sat there on this for so long i just ended the process.

However i can now launch catalyst control manager, and device manager is displaying my graphics card! However when catalyst control manager launches it says that some features aren't supported by my display driver and to update the driver.

I rebooted the pc having done nothing else, the resolution was large again, device manager says it is using the standard vga driver again. What the hell is going on? Catalyst is still installed and still launches, with the same advice to update my driver.
My System SpecsSystem Spec
18 Sep 2014   #5

Windows 7 Ultimate x64

So as a last ditch effort before reinstalling Windows itself, i swapped the BIOS switch back one more time, not changing anything else from the last post, now on position 2.

It's suddenly working good as new. Windows Aero is enabled again, games are launching again... i have no idea what has been going on but it seems to be fixed. I even rebooted again just to be sure... yep, still works.

I am just posting this here in case anyone stumbles upon this thread with a similar issue in the future... 4 days of stress and bullcrap, i was actually losing sleep over this issue... and now it's done. Thank heavens. I need a drink...
My System SpecsSystem Spec

 Graphics Card not recognised

Thread Tools

Similar help and support threads
Thread Forum
Reinstalled OS, graphics card not recognised, BSOD on driver update
Well, first of all I am a total computer neophyte so any advice needs to be really simple. I use my laptop for my Internet research, translating 18th and 19th century documents, word processing and GTA IV :) I never had an issue with graphics or game play until a period of BSOD/Black screen...
Graphic Cards
New installation of ATI HD3650 graphics card not recognised by Win 7
I have just installed a new ATI Radeon HD3650 PCIE 1Gb graphics card in my HP dc5750. At the same time I replaced the 165 Gb HDD with a new WD 465 Gb drive and did a clean install of Win 7 Professional. I have run all the updates, including SP1. The machines has a 2.2 Mhz dual core cpu and has 3 Mb...
Graphic Cards
Random restarts with AMD graphics card but not Nvidia graphics card
Hi for the last 4 months ive been trying to fix a problem that ive been having with my computer. about 4 months ago I did a major pc upgrade where i replaced my motherboard, processor, ram, heat sink, power supply and case, the only things I used from the original computer where 2 HDD's, 1 SDD and...
Graphic Cards
My TV is not being recognised by MSI R7770 graphics card anymore.
I have got a problem which has occurred just few days ago. My TV could not and still cannot be recognised by my graphics card, meanwhile my monitor is working properly. I always use TV for watching movies, videos and whenever I am too lazy to get off my bed. Recently I have changed my graphics...
Graphic Cards
8 gig sd card not being recognised
Hi I have 2 8 gig sd cards, 1 Transcend and the 2nd a Sandisk, however Windows 7 refuses to recognise them in either the card reader or the usb adaptor. XP reads them fine and Windows 7 can read the 2 512 meg cards I have. Any ideas to resolve would be greatly appreciated. Regards Idak

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:07.
Twitter Facebook Google+