Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Radeon Mobility HD 4570 Not working after win 7 upgrade

17 Dec 2009   #51
arkeo

Windows 7 Ultimate amd64
 
 

I tried the driver from Acer, the one from ATI and the Mobility Mod (64 bit all of them); then Windows Update usually says it has a newer driver available, but it doesn't matter whether I install it or not, the 4570 won't start, always reporting error code 10.

I'm at a loss, I don't know what else to do except wait for a new driver from Acer or ATI--but this is frustrating and absurd, how can they launch a product without proper drivers? As I understand it, the Puma platform has been around for a while, and I kinda think they saw Windows 7 coming, or did they???


My System SpecsSystem Spec
.
17 Dec 2009   #52
arkeo

Windows 7 Ultimate amd64
 
 

Quote   Quote: Originally Posted by rflair View Post
I don't know if this will help but Gateway released newer drivers for most of their ATI mobility line.
Do you think they might install/work on an Acer laptop? Or could it be a sort of sign that Acer might release updated driver relatively soon?
My System SpecsSystem Spec
17 Dec 2009   #53
paultanneruk

Windows 7 64 Professional
 
 
Gateway drivers don't work...

Thanks 'rflair' for your suggestion.. I have tried the new Gateway drivers and unfortunately the same issue... I am aware there is a new Bios on the Acer site (2.04)... anyone think this could fix the issue? I'm not that techy and have been a bit disconcerted around the warnings and dangers of flashing a BIOS in terms of trashing motherboard potential so this is something I have not tried... Acer support refused to comment as to whether it would fix issue and said if I do it is is my own risk... of course if I phone their premium number they will be able to fix the issue... erm I think NO!???? Does anybody suggest whether they think a BIOS update could have potential to fix this kind of issue?

Many Thanks,

Paul.
My System SpecsSystem Spec
.

17 Dec 2009   #54
arkeo

Windows 7 Ultimate amd64
 
 

Funny, until yesterday (or the day before) there were two BIOS versions on the Acer support page, 3342 and 3344. I couldn't install either of those as the BIOS flash utility reported some error (corrupted source, or something like that).

I'm trying now with version 2.04 and I'll let you know.

Let's hope this works...
My System SpecsSystem Spec
17 Dec 2009   #55
arkeo

Windows 7 Ultimate amd64
 
 
New BIOS won't install

No luck (AGAIN!!!): the new BIOS won't install, reporting error 0x4d0 (whatever that means). I also tried running the flash utility as administrator, but it doesn't seem to change anything. I'm getting a feeling that there's some problem with Acer supplied bios flashing utilities under Win7 (at least the 64-bit version).

Maybe tomorrow I'll swap the internal hard disk with a spare one I got, try install XP on that and then flash the bios again... Who knows, maybe it'll work...
My System SpecsSystem Spec
18 Dec 2009   #56
paultanneruk

Windows 7 64 Professional
 
 
4570 Now Working on Win 7 Pro 64!

I don't quite know why it has worked this time as I have tried this previously as suggested on this forum (may be using I'm using a different driver this time though?) but I now have my 4750 gpu working on Win 7 64!

I was inspired by 'dam89' at the following forum to retry using Mobility Moder to 'mod' a gpu driver (ATI HD 3200 & HD 4570 in laptop not working - Windows 7 Forums)

I downloaded Mobility Moder (http://www.radeon.ru/downloads/modto...otNETSetup.exe) and also the the 'Windows 7 64 Bit Edition - Radeon - Radeon HD 4550 driver' from the ATI site (Graphics Drivers & Software).

I then unistalled all ATI software via control panel and to ensure all evidence of it was gone I ran drive sweeper (Guru3D - Driver Sweeper) to delete any thing left.

After a restart I double clicked on the downloaded driver so it extracted to C:\ATI\Support and cancelled it before it installed.

I then installed and ran Mobility Modder and using 'browse' located the driver folder within C:\ATI\Support\.... I ensured Disable UAC box was ticked and then clicked Modify. This modifed the driver.

Once done I disabled the 3200 gpu via Device Manager and then ran the setup file in the modified driver folder (c:\ATI\Support\[Driver Folder Name]\Setup.exe).

Once this had installed I was prompted to reboot and once restarted I checked device manager and both the 3200 gpu and the 4570 gpu (it shows as ATI MOBILITY RADEON 4530/4570) are running OK (NO 'CODE 10' & NO '!')

As with Sebs solution you can then simply switch between gpu's by switching displays (one is on a virtual display and the other is the actual display under screen resolution) or you can disable the 3200 gpu in device manager so the 4570 alone will be in use.

To prove it is working my windows experience index is now 4.1.

Thanks to all for your helpful discussion and information... I hope this fix works for you as well.
My System SpecsSystem Spec
24 Dec 2009   #57
lewisa123

Windows 7
 
 

Quote   Quote: Originally Posted by paultanneruk View Post
I don't quite know why it has worked this time as I have tried this previously as suggested on this forum (may be using I'm using a different driver this time though?) but I now have my 4750 gpu working on Win 7 64!

I was inspired by 'dam89' at the following forum to retry using Mobility Moder to 'mod' a gpu driver (ATI HD 3200 & HD 4570 in laptop not working - Windows 7 Forums)

I downloaded Mobility Moder (http://www.radeon.ru/downloads/modto...otNETSetup.exe) and also the the 'Windows 7 64 Bit Edition - Radeon - Radeon HD 4550 driver' from the ATI site (Graphics Drivers & Software).

I then unistalled all ATI software via control panel and to ensure all evidence of it was gone I ran drive sweeper (Guru3D - Driver Sweeper) to delete any thing left.

After a restart I double clicked on the downloaded driver so it extracted to C:\ATI\Support and cancelled it before it installed.

I then installed and ran Mobility Modder and using 'browse' located the driver folder within C:\ATI\Support\.... I ensured Disable UAC box was ticked and then clicked Modify. This modifed the driver.

Once done I disabled the 3200 gpu via Device Manager and then ran the setup file in the modified driver folder (c:\ATI\Support\[Driver Folder Name]\Setup.exe).

Once this had installed I was prompted to reboot and once restarted I checked device manager and both the 3200 gpu and the 4570 gpu (it shows as ATI MOBILITY RADEON 4530/4570) are running OK (NO 'CODE 10' & NO '!')

As with Sebs solution you can then simply switch between gpu's by switching displays (one is on a virtual display and the other is the actual display under screen resolution) or you can disable the 3200 gpu in device manager so the 4570 alone will be in use.

To prove it is working my windows experience index is now 4.1.

Thanks to all for your helpful discussion and information... I hope this fix works for you as well.
I did exactly this and my rating droped down to 2.7. Also both cards were running very slow after doing this. Any advice?
My System SpecsSystem Spec
28 Dec 2009   #58
karrir

acer
 
 

Hi all,

I just want to know enybody have HDMI problems with ACER 7535G after upgrading Win7.
Before I had Vista and HDMI works fine with TV but after upgrading Win7 laptop finds pnp monitor when i connect hdmi cabel to TV but i dont´t have signal. I have tryed to install latest catalyst 9.12 with no success. I have 4500 series video card installed. I don´t have any conflicts in device manager. If this sounds familiar and you have fix this problem please help needed.
My System SpecsSystem Spec
29 Dec 2009   #59
seb1188

Windows 7
 
 

Quote   Quote: Originally Posted by karrir View Post
Hi all,

I just want to know enybody have HDMI problems with ACER 7535G after upgrading Win7..
I haven't tried HDMI but I've been using the VGA output so perhaps it is the same. As with switching between the two cards, right click your desktop and choose screen resolution. With the HDMI connected, click detect and hopefully it should show an additional two monitors (so 4 in total now). You need the settings so that it duplicates your desktop on monitors 1 and 2 or 3 and 4. With the VGA on mine, it labels the new ones as "projector" so maybe it does something similar that will help for HDMI.
My System SpecsSystem Spec
04 Jan 2010   #60
paultanneruk

Windows 7 64 Professional
 
 
In Response to Lewisa123...

... erm that's strange... works for me fine... have you tried following the same process with some different drivers... i.e. the ATI driver on the Acer Support website for this model of laptop?... (available from: Service & Support )?
My System SpecsSystem Spec
Reply

 Radeon Mobility HD 4570 Not working after win 7 upgrade




Thread Tools




Similar help and support threads
Thread Forum
ATI Mobility Radeon HD 4570 Series problem
I have laptop ASUS K50AB, with 2 graphic cards, one is ATI Radeon HD 3200 and it works fine, but another one is ATI Mobility Radeon HD 4570 Series, and I have huge problems to instal drivers on it. First I reinstaled my Windows 7 Ultimate x64, and all drivers are updated except this one(there is...
Graphic Cards
ATI Mobility Radeon HD 4570 problem
can anyone tell me how to see this graphic card performance as when i havent installed this graphic card (512MB) and after i installed there are no changes yet.....if yes then how can we take full use to it
Graphic Cards
Not enough resources for Mobility Radeon X1400 after RAM upgrade
Hi! I've been running Windows 7 Professional 64bit on a LG laptop with Mobility Radeon X1400 graphics with no problems. I went from 2GB RAM (2 x 1GB) to 3 (1 x 2GB, 1 x 1GB) two weeks ago and everything went on working without a hitch. Now, I've just tried to upgrade from 3GB to 4 (2 x 2) and...
Graphic Cards
ATI Mobility Radeon HD 4570 and Windows 7
Hi boys and girls :) I am a new windows 7 user after just buying a brand new Acer Aspire 5738G laptop. Here are the specs (maybe that will help someone try fix my problem :)) Windows 7 Core 2 Duo T6600 (2.2GHz, 800MHz FSB) 4GB RAM ATI Mobility Radeon HD 4570
Graphic Cards
Any way to get a Mobility Radeon 9200 working?
...without using a generic driver? I never got it to fire under Vista so I figured I would give it one last shot. The notebook is pretty nice for its age so I wanted to see if it will work. Thank you! Eric
Graphic Cards
ati radeon mobility 4570 windows7
Hi, just bought a vaio vgn-nw21sf (windows 7)with ati radeon mobility 4570. everything looks nice on my laptop but when I plug it in my LG 226WTQ-sf then the problems begin. when I duplicate screens the resolution at the LG can get up to something rubbish. When I use only the LG or extend...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 18:52.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App