Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 with Radeon HD 5770

05 Dec 2009   #71
sygnus21

Windows 10 Pro
 
 

I'd go ahead a RMA/return it. It might actually be a bad card.

Good luck


My System SpecsSystem Spec
.
05 Dec 2009   #72
Fishdoc

Win 7 Ultimate 64bit Signature Edition
 
 

The only thing that fixed my problem was RMAing my sapphire 5770 back to newegg. I kept getting the "driver not responding error". I downloaded all the latest drivers etc Mobo, chipset etc you name it I did it. Well, I am happy to say I have not had a single problem (touches wood) since RMAing that card and getting another. I have not changed a thing, so I know it had to be a bad card. IMO, I think there is a bad batch of 5000's cards out there. I have my specs filled out so you can see my build.

Plus still running 9.10 driver.
My System SpecsSystem Spec
05 Dec 2009   #73
hotpandesal

Windows 7 64 bit professional
 
 

Thanks guys I'll probably try to use different os first and if it fails i'll bring my pc to the shop so they can see for themselves
My System SpecsSystem Spec
.

05 Dec 2009   #74
AmazinT

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by Fishdoc View Post
The only thing that fixed my problem was RMAing my sapphire 5770 back to newegg. I kept getting the "driver not responding error". I downloaded all the latest drivers etc Mobo, chipset etc you name it I did it. Well, I am happy to say I have not had a single problem (touches wood) since RMAing that card and getting another. I have not changed a thing, so I know it had to be a bad card. IMO, I think there is a bad batch of 5000's cards out there. I have my specs filled out so you can see my build.

Plus still running 9.10 driver.
That is LAME.
My System SpecsSystem Spec
05 Dec 2009   #75
hotpandesal

Windows 7 64 bit professional
 
 

Ok so i borrowed an xp 64bit cd from a friend and surprisingly everything is ok. i never experienced a crash with the ati 9.11 driver? is it my system or its just the 5770 is not for windows 7? I don't think so. this is really weird, some of our local forum have windows 7 32 bit and 64 bit with sapphire 5770. I will try this on vista. I do really hope I can make this work on windows 7 if not crap I just wasted my money.
My System SpecsSystem Spec
05 Dec 2009   #76
blathermouth

Windows 7 Ultimate 64 Bit
 
 

I'm running into simliar problems with my Asus EAH 5770 (appears to be a new version 2 of their card). It locks up my system (screen freeze) while doing mundane Windows GUI tasks like resizing or moving windows. Usually I have to do a system reset, but sometimes (maybe with different driver than I'm now using) Windows would actually recover with some error about having recovered from a fatal video driver failure or something. But mostly I have to reset, although strangely, while the screen is frozen, my HDD light continues to flash as though something is happening.

I'm not a gamer or an OC'er. I've played and edited a bunch of AVCHD 1080p video with no trouble at all (BTW for those who care, MTS and M2TS formats of video from HD Camcorders is supported natively in Win7 - and this is a big deal!), but if I open device manager and try to resize the window it will lock (For some reason this particular sequence is quite repeatable). Very frustrating, especially after researching, planning, selecting components and the $$$ I spent building this rig!

I have tried all versions of drivers available from Asus, as well as v9.11 from ATI. In each case I have completely uninstalled whatever was there first. I've also fully updated and patched everything I can (BIOS, all other drivers etc), I've run a MemTest86 (DOS version) overnight, which shows memory is working perfectly.

I've monitored the Video card's temperature, and it has never gone above 40deg C. The Antec case I have has a massive 200mm fan in the side panel, blowing right at the graphics card anyway. I'm certain there is no cooling issue.

ASUS has agreed to RMA the board, but I was curious to hear from anyone else with such issues, if a board swap (and I don't mean to a different model) fixed their problem. I guess I'm not sure if I should RMA it, or just return it to the vendor and get something different (nVidea?). I'm getting the distinct feeling this is all driver related, so swapping the card seems dubious.

Full machine specs in my profile...
My System SpecsSystem Spec
06 Dec 2009   #77
torrentg

7600.20510 x86
 
 

Quote   Quote: Originally Posted by blathermouth View Post
I'm getting the distinct feeling this is all driver related, so swapping the card seems dubious.
I don't. You said you tried all versions of drivers and your troubleshooting methods seem solid. To me, it sounds like a defective card itself or too much heat.

AVG causes the most problems and bsod of all software. If anyone having this problem is running AVG, completely uninstall it.
My System SpecsSystem Spec
06 Dec 2009   #78
mwahaha

Windows 7 x64
 
 
Does RMA work?

Hi All

I too would be interested in knowing whether an RMA for another HD 5770 worked for anyone. Or should I simply swap out for a GeForce GX 260?
My System SpecsSystem Spec
06 Dec 2009   #79
AmazinT

Windows 7 Ultimate x64
 
 

I don't seem to experience the problem when the Catalyst drivers are uninstalled, and someone reported in this thread that the problem didn't occur when they installed the ATI drivers, but not CCC. I will try that when I go back home in ~1 week. If that works, that would indicate it is not a hardware problem but a software conflict.
My System SpecsSystem Spec
06 Dec 2009   #80
curtis

Windows
 
 

An update for everyone that was asking. Here is what I recommend from what I have seen on our testbenches.

The new Gigabyte 5770s with the revised fat heatpipe cooler are resolving issues that we were seeing when running other cards in the same Gigabyte P55 systems.

Also, even though D-Link have denied any issue with their hardware, their DWA-547 was causing some major stability problems with the system they have been installed in when running Windows 7 64bit. I would recommend removing this card from your Windows 7 64bit installs. I have not had tested it in 32bit Win7 yet.
This D-Link card was the cause of all the problems in 2 other systems that were suspected to be related to the 5770 or P55 mobo.

The reference 5770s (the ones with the plastic shroud over the heatsink for the length of the card) seem to be the most problematic. I have had 1 system with warm boot issues, and another 2 that were either faulty or incompatible (we are waiting to see if the cards will be replaced still) all with the same reference cooler.
My System SpecsSystem Spec
Reply

 Windows 7 with Radeon HD 5770




Thread Tools




Similar help and support threads
Thread Forum
Radeon HD 5770 not recognized
Hi guys, I purchased a Radeon HD 5770 not to long ago, I just tried to install it but windows does not recognize it! I Know people had trouble with this is the past but with other cards. I Have Windows 7 Home Premium 64 bit. So if anyone knows how to fix it I would really appreciate it...
Graphic Cards
Radeon 2600XT to Radeon HD 5770
Some thoughts please. I want to add a blueray drive (not burner for now) to my system as well as a 2d monitor. According to a program I downloaded and ran all my stuff SHOULD be bluray compatible, HDCP compliant and etc. However, I've seen that the Radeon 5700 series is specifically...
Graphic Cards
ATI Radeon 5770
Hi all, Looking to get this and, after some research, have realised my PSU won't be able to supprot it. Can anyone suggest a good and reliable PSU? I'm assuming I'll need at least 450W from what I've read, with a 6-pin connector for the card. Any suggestion or pointers welcome!
Graphic Cards
XFX Radeon HD 5770
Hello Guys I have a big Problem since 2 weeks.. My Problem is that my Display flickers when i connect a second Screen..:( I tried everything but nothing helped me Maybe u guys know the Reason for the Problem. Im very Happy when someone would help me Thank You and sorry for my bad English...
Graphic Cards
Ati radeon 5770
Just upgraded my pc from a 400w psu to a 750w, and from a 9500gt to a ATI 5770. Now I'm getting an error "NTLDR is missing, CTRL + ALT + DEL to restart. I've checked and checked to make sure all the cables from the PSU are int he right place but I cant find anything. And the error "NTLDR" is hard...
Graphic Cards
Integrated Radeon HD 5770
This is pretty awesome, but I wonder how much performance the 5770 would lose being integrated. Read more: ASUS Immensity Concept Motherboard Pictures - Lucid Hydra & Integrated Radeon HD 5770 - Legit Reviews
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:34.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App