Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Gefore 8400M GT card and Bluray not playing

14 Nov 2009   #1
westgstreet

WIndows 7 64 bit
 
 
Gefore 8400M GT card and Bluray not playing

I have a vaio vgx-tp25e/b HTPC. I upgraded from 32 bit Vista premium to 64 Bit Win 7 ultimate. I installed Nvidia driver version 190.40 from laptopvideo2go.com, and this is the latest driver for my card when I go a search on laptopvideo2go site using my graphics card hardware ID. The nvidia control panel says that my system is HDCP-capable but when I play bluray using powerdvd 9 (trial), the player displays this message:

"Playback stopped because your graphics card driver is incompatible."

I also have Windvd pro 2010 is crashing when I play bluray and it is an activated version. I can read the bluray disc from explorer so I don't think it is a bluray driver issue. Anyone else have had this problem and know the fix? I think it's with the HDCP requirement becuase when I run the cyberlink BD advisor it says that my graphics driver is NOT HDCP capable but NVIDIA control panels states the opposite. Thanks for the help in advance!


My System SpecsSystem Spec
.
14 Nov 2009   #2
torrentg

7600.20510 x86
 
 

My System SpecsSystem Spec
14 Nov 2009   #3
fmvazque

WIndows 7 Ultimate
 
 

Hi,

I had the same problem with a NVIDIA ION Gpu. The problem occurs when the resolution is set to somethig more than 1600x900. The only thing that worked was to set the resolution to 1600x900 and the PowerDVD 9 playback started working. This is not ideal I know, since I would like to use higher resolutions. If you have other information regarding this, please update this thread.

Thanks!
------
Fabio
My System SpecsSystem Spec
.

19 Nov 2009   #4
tokioman

W7 64 bit
 
 
Solution to Sony nVidia 8400M GT Blu-ray Problem

This worked!!!

http://forums.guru3d.com/showthread.php?t=304257

I have a Sony Vaio VGC LT19U on which I did a clean install of W7 64 bit, but had the nVidia driver problem with the nVidia GeForce 8400M GT. I have looked high and low. Tried several modified nVidia drivers from laptops2go.com. Tried modifying inf files myself, used the nVidia Mobiiity Modder Tool. All allowed the display to work properly but I COULD NOT PLAY BLU-RAY disks! This worked! The Cyberlink PowerDVD still has a red mark next to the newly installed driver but it works so I don't care. I am having some issues burning DVDs in some video creation software (Ulead VideoStudio X2) but not sure yet whether that is problem with driver or the poorly documented and explained software package...
My System SpecsSystem Spec
24 Nov 2009   #5
dpetro

Windows 7
 
 
Vgx tp 25e

I have exactly the same HTPC as you. With exactly the same problem, no blu ray using Windows 7 Ultimate. And, by chance, I have tried the exact same programs (WinDVD and PowerDVD) that you have with exactly the same results. Question for you, did you try the suggestions in the previous two or three posts about installing different NVidia drivers, other than the one for Vista? I have tried 190.40 off of Download NVIDIA drivers | drivers for mobile cards and laptops | laptopvideo2go.com with the same results as the Vista driver that came preinstalled. I'm really at a loss with this one.

Sony, in their policy of corporate indifference, isn't going to be of any help for us since, "we don't support anything except the OEM system."

I think I might try the procedure outlined in one of the previous posts NVIDIA Driver - Convert from Desktop to Mobile (Laptop)

At this point, I'm not convinced the problem is solely a NVidia driver problem, but then what else could it be?
My System SpecsSystem Spec
24 Nov 2009   #6
dpetro

Windows 7
 
 

Added note, the solution proposed by tokioman did not work on this PC. Blu ray refuses to play with PowerDVD 9, although it seemed to read the disc fine. On top of that, Corel's WinDVD 10 refuses to even work at all! Back to the drawing board.

This solution, which appears to install the latest NVidia drivers, does fix a few other problems though. It appears to me that the error message that Westgstreet got in Power DVD is bogus, since this does appear to be the latest driver. I'm suspecting something other than video drivers now. Since the actual player has the latest firmware and it DOES play blu ray discs on Vista, there's probably something else missing on the Win 7 install that Sony has put on the Vista install that I don't know about. Sony support is useless, so this will require more research.
My System SpecsSystem Spec
24 Nov 2009   #7
Superdog

windows 7
 
 

Hi All - I have a Sony FZ-480e/b and I'm using the 186.91 driver and everything is working. Including the blu-ray hdmi and also s-video out to an old 55" Toshiba rear projection tv. When you unpack that driver there is a folder that has a couple .inf files you need the whql file from that folder. It has our 8400m gt info. I am running win7 32 bit so i'm not sure about your 64 bit use. I tryed that 195.55 beta. It didn't install and luckily went back to the 186.91. The Windows adviser says that my gpu driver is not compatible with win7. I have know idea why it says that.

I hope this is some help to you
Harold
My System SpecsSystem Spec
24 Nov 2009   #8
dpetro

Windows 7
 
 
VGX TP 25e

I'm glad your blu ray is working. What software are you using to play the disc? I'm using the exact same driver and no go. Since my computer can't run the 64 bit version, we probably have very similar hardware and if it works for you....well, that tells me I'm likely missing something.
My System SpecsSystem Spec
24 Nov 2009   #9
dpetro

Windows 7
 
 
Solution to problem on VGX TP25E

Here's the solution to the problem for the benefit of westgstreet, the original poster.

The problem is the video driver. Use the one indicated at 186.91 WHQL at Microsoft Update (all desktop + notebook cards) - Guru3D.com Forums

It will not work initially because for some reason or other the actual driver file (*.SYS) will not get updated. Go into device manager and update it there, pointing to the directory where that driver was unpacked. It will take about 10 minutes to complete and look as if it has crashed, so give it time. Once the actual driver has been installed, this model will play Blu Rays.

And, thanks for all the thread participants who at the very least, pointed to the correct driver that Sony will NEVER place on their support site.
My System SpecsSystem Spec
24 Nov 2009   #10
Superdog

windows 7
 
 

That's Great! dpetro - I am using Windvd 2010.

Harold
My System SpecsSystem Spec
Reply

 Gefore 8400M GT card and Bluray not playing




Thread Tools




Similar help and support threads
Thread Forum
Graphic card 8400m gt issue on Vaio FZ190
Hello guyzz i have Vaio VGN FZ190. former os : Vista ultimate 32bit i am having issue with graphics card( see attached pics for graphics card details) 1) originally my laptop is with FULLHD 1080 support, but when i play fullhd 1080 video screen lags and then graphic card stops working. 2)...
Graphic Cards
Trouble all of a sudden playing bluray?
ive been using cyberlink powerdvd 10 for quite a while and its been great, now it says the blu ray disc isnt supported, even though ive played it on here before. ive tried other players and they say the same thing. i thought this was weird since its always been fine. so ive downloaded k lite codec...
Music, Pictures & Video
Problem with graphic card NVIDIA GeFore 7150M / 630M
Hi all, I have a problem with my Graphic card, I have a notebook HP Pavilion dv6710ec and seconder monitor Philips 23" w E-line 1920 x 1080 Full HD, and my problem is: that monitor cant displayed full HD 1920x1080, I dowload some drivers from CD driver and interent,but it no one work, I can max...
Graphic Cards
Can't add my GeForce 8400M GT Graphics Card
So, I have upgraded my laptop from Vista-32bits to Windows 7-32bits. I often play games and once my graphics card failed and made my laptop restart. In my attempt to fix it I think I only made it worse by messing up in the device manager, it seems I deleted my graphics card to try and reinstall it....
Graphic Cards
Graphic card driver for geforce 8400M GT GPU
Hello, My notebook is Sony Vaio(Model: VGN-FZ21E) with following specs: Intel® Core™2 Duo T7250 2.0GHz 2GB/Go DDR2 SDRAM 250GB/Go, 15.4" WXGA 1280x800 X-black LCD, nVidia GeForce 8400M GT GPU Windows 7 professional
Graphic Cards
Windows 7 won't detect GeForce 8400M GS graphics card
I just installed windows 7 professional last night and when trying to personalize my theme, i realized that i couldn't change window color. It only gave me the contrast themes unlike in vista where i could choose the color and it would still look like vista. I'm not sure if that last sentence...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 16:56.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App