Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Multicolored Lines, computer crash, Drivers?

26 Feb 2016   #21

64 bit win 7

lol, Yea I do dabble a bit, mostly in high voltage related things. I am definitely not a computer/software engineer.
That cylinder (if I am looking at the pic you are looking at) is fairly mundane, a strange precipitate formed in the bottom of some fertilizer I use for my fish tanks plants, was trying to figure out if it was good or bad on another forum.

It looks like my RAM is F3-12800CL9D-8GBRL (Is that a model id number you wanted?) I consulted the interwebs and was unable to conclude as to if it was single or double sided.

So, I have things set such that steam does not start until I open it. I can accomplish all other tasks with no issue. In-fact i had a fairly complex inventor model open the other day and it functioned beautifully. So as long as i don't want to play a game, via steam, I am apparently good to go.
But as soon as i open steam... Well not as soon as i open steam, if its not downloading something it is fine. but as soon as i tell it to begin downloading something, or it starts to update something, definite crash coming down the pipeline.

Yes, i am running service pack 1, in fact SP1 came preloaded on my install media.

I also completely uninstalled Norton, with no change.

I forgot to upload a pic of my case previously, Here is is now

I ran the BSOD compiler thing you wanted, the output .zip file is attached.

So what course of action should i take, regarding the potential RAM incompatibility?

Thanks again for the assistance

Attached Files
File Type: zip (920.8 KB, 1 views)
My System SpecsSystem Spec
26 Feb 2016   #22

64 bit win 7

Slight update for the day,

It seems the mode of my failure has changed, I am not quite sure why. But I suspect it is related to my uninstalling something called xFast LAN, which got installed with my ASROCK installer pack. I'm going to reinstall it tomorrow and see if the failure mode reverts back. As I am not entirely sure if that is the only thing i changed before the failure mode changed.

Anyway, on these last 4 tests I have done, the crash has simply locked up the computer forcing a hard reset. I haven't gotten the multicolored death screen. Which is new...

But that's all i've got for now, ill update again if i hit on something more specific.

Thank youall for your assistance.
My System SpecsSystem Spec
27 Feb 2016   #23
Mellon Head

Win 7 Pro x64/Win 10 Pro x64 dual boot

Nice looking case. :)

Were there any other LAN software packages or utilities installed by the ASROCK install disk? That could be part of the problem. It might be worth it to make a trip to the ASROCK website and check to see if they have an updated LAN driver for your motherboard.
My System SpecsSystem Spec

27 Feb 2016   #24

64 bit win 7

Mellon Head,

Thanks =)
Were there any other LAN software packages or utilities installed by the ASROCK
install disk?
Not that I am aware of, but when I return home, I plan on carefully scrutinizing everything in my install folder, and attempting the NIC I have on hand again, now that this xFast Lan thing is uninstalled.
Does anyone think it is worth it to throw 30 bucks at a nice intel NIC, the one I have cost like 9 bucks and is very generic.

The driver I am currently utilizing, came from the asRock site directly, I didn't use the windows driver update or whatever to find it, but yes I shared your sentiment in making sure it is the most up to date version, which it is.

I also read something on another forum about how I can apparently start windows with only certain services activated, I plan on reading more into that, and will be systematically testing to see if a single service is responsible.

Thanks again =)
My System SpecsSystem Spec
27 Feb 2016   #25

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1

Yes, F3-12800CL9D-8GBRL was the number that was needed, and thank you for posting it.

If you go to the gskill site for that number then click on the QVL tab >open the ASRock listing >then open the 990FX/990X/970 drop down list, it shows that number is okay with the Extreme3 board not the Pro3, but your board is working with the ram for all apps except Steam. This has been known to happen.
  • Are you overclocking (OC) the memory or the board?
  • Have you tried the ram sticks in different slots?
  • Your memtest showed the ram as a unit to be okay, did you try testing only one stick in each of the four different memory slots? Tedious and time consuming, yes, but it might show an intermittent problem with either, one of the sticks and or a slot.
So what course of action should i take, regarding the potential RAM incompatibility?
  • Replacing the ram to what is known to be compatible with your board is your call, going back to the ASRock site you have AMD, Kingston, and Geil to choose from if you want to stay with 16GB of DDR3-1600 memory. They are listed 22nd to 29th on the list.
  • Can you RMA the ram for a refund or exchange?
  • Will it really make a difference? I'm not sure, the only way to find out for sure is to swap and test, but at least you will know you have the proper ram, and that concern would be moot.

If I may ask a question; when you decided to build your machine, what process did you use to select the parts?
  • In looking at xFast LAN I noticed the AMD Socket AM3+ / AM3 section has two Pro3 MB's. Is that the CPU you used?
  • If there is not a major difference I would reinstall xFast.
  • What do you mean by "failure mode?
  • You could throw the 30bucks, but make sure the NIC has better specs than the one you're replacing i.e. faster, and more adjust-ability.

  • Your ram is a Dual Channel Kit which means it is dual sided and that relates to dual channel, DIMM = Dual In Memory Module.
  • You should update your specs to reflect that you do indeed have win7 SP1 to avoid any further confusion.
  • Thank you for D/L'd BSOD report, I have it, but have been too busy to get to it yet, maybe later tonight.
  • By selective Services, do you mean Safe Mode? If you go to the Services link I provided earlier you will see a link in the yellow Tip box that will send you to the Black Viper Site use the SP1 link, his is a well known and trusted site and can offer a baseline as to what and how Services should be set.
My System SpecsSystem Spec
27 Feb 2016   #26

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10

I agree wit Mellon Head on the case and also that the software disk that come with boards are usually well out of date when they get to the consumer - much better getting th drivers online.

If you want some stats on the RAM have a look with the HW Info software use PART B: of the thing I sent and click on the individual sticks it will tell you timings, frequencies etc ad infinitum In fact you cab check out any components like that.

Edit Meant to mention my Asus laptop I bought about a year ago had to have the BIOS updated too to be able to install 7 drivers - the drivers would not install without the BIOS update - might be worth for you to check that out.
My System SpecsSystem Spec
28 Feb 2016   #27

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1

After looking over your BSOD report your machine did throw a .dmp for the ahcix64s.sys driver. The DRIVER_IRQL_NOT_LESS_OR_EQUAL (d1) bugcheck points to a device driver: http://STOP 0x000000D1: DRIVER_IRQL_NOT_LESS_OR_EQUAL |
Microsoft (R) Windows Debugger Version 6.11.0001.404 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [C:\Users\Amln0\Desktop\BABYLON13-Fri_02_26_2016_144917_00\021916-78000-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: SRV*C:\SymCache*
Executable search path is: 
Windows 7 Kernel Version 7601 (Service Pack 1) MP (6 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 7601.19135.amd64fre.win7sp1_gdr.160121-1718
Machine Name:
Kernel base = 0xfffff800`02e13000 PsLoadedModuleList = 0xfffff800`0305a730
Debug session time: Fri Feb 19 22:00:20.599 2016 (GMT-5)
System Uptime: 0 days 0:00:17.723
Loading Kernel Symbols
Loading User Symbols
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck D1, {400156b76ff, b, 1, fffff88001c820e8}

Unable to load image ahcix64s.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for ahcix64s.sys
*** ERROR: Module load completed but symbols could not be loaded for ahcix64s.sys
Probably caused by : ahcix64s.sys ( ahcix64s+80e8 )

Followup: MachineOwner

2: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If kernel debugger is available get stack backtrace.
Arg1: 00000400156b76ff, memory referenced
Arg2: 000000000000000b, IRQL
Arg3: 0000000000000001, value 0 = read operation, 1 = write operation
Arg4: fffff88001c820e8, address which referenced memory

Debugging Details:

WRITE_ADDRESS: GetPointerFromAddress: unable to read from fffff800030c4100


fffff880`01c820e8 488901          mov     qword ptr [rcx],rax





TRAP_FRAME:  fffff8800339a770 -- (.trap 0xfffff8800339a770)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=0000000000000000 rbx=0000000000000000 rcx=00000400156b76ff
rdx=0000000000000012 rsi=0000000000000000 rdi=0000000000000000
rip=fffff88001c820e8 rsp=fffff8800339a900 rbp=fffffa800f679b10
 r8=0000000000000001  r9=0000000000000001 r10=0000000000000001
r11=fffffa800d72b758 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei pl nz na po nc
fffff880`01c820e8 488901          mov     qword ptr [rcx],rax ds:9620:00000400`156b76ff=????????????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff80002e86969 to fffff80002e873c0

fffff880`0339a628 fffff800`02e86969 : 00000000`0000000a 00000400`156b76ff 00000000`0000000b 00000000`00000001 : nt!KeBugCheckEx
fffff880`0339a630 fffff800`02e855e0 : fffffa80`0d72b758 fffff880`01ca1759 fffffa80`0d7d7338 fffffa80`0f647080 : nt!KiBugCheckDispatch+0x69
fffff880`0339a770 fffff880`01c820e8 : 00000000`00000001 fffffa80`0d72b758 00000000`00008000 fffffa80`0d918a18 : nt!KiPageFault+0x260
fffff880`0339a900 00000000`00000001 : fffffa80`0d72b758 00000000`00008000 fffffa80`0d918a18 00000000`00008000 : ahcix64s+0x80e8
fffff880`0339a908 fffffa80`0d72b758 : 00000000`00008000 fffffa80`0d918a18 00000000`00008000 fffff880`01caae55 : 0x1
fffff880`0339a910 00000000`00008000 : fffffa80`0d918a18 00000000`00008000 fffff880`01caae55 fffffa80`0d728920 : 0xfffffa80`0d72b758
fffff880`0339a918 fffffa80`0d918a18 : 00000000`00008000 fffff880`01caae55 fffffa80`0d728920 fffffa80`0d728990 : 0x8000
fffff880`0339a920 00000000`00008000 : fffff880`01caae55 fffffa80`0d728920 fffffa80`0d728990 00000000`00000001 : 0xfffffa80`0d918a18
fffff880`0339a928 fffff880`01caae55 : fffffa80`0d728920 fffffa80`0d728990 00000000`00000001 fffffa80`0d918a18 : 0x8000
fffff880`0339a930 fffffa80`0d728920 : fffffa80`0d728990 00000000`00000001 fffffa80`0d918a18 00000000`00000000 : ahcix64s+0x30e55
fffff880`0339a938 fffffa80`0d728990 : 00000000`00000001 fffffa80`0d918a18 00000000`00000000 00000000`00000000 : 0xfffffa80`0d728920
fffff880`0339a940 00000000`00000001 : fffffa80`0d918a18 00000000`00000000 00000000`00000000 00000000`00000000 : 0xfffffa80`0d728990
fffff880`0339a948 fffffa80`0d918a18 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x1
fffff880`0339a950 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0xfffffa80`0d918a18


fffff880`01c820e8 488901          mov     qword ptr [rcx],rax


SYMBOL_NAME:  ahcix64s+80e8

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: ahcix64s

IMAGE_NAME:  ahcix64s.sys


FAILURE_BUCKET_ID:  X64_0xD1_ahcix64s+80e8

BUCKET_ID:  X64_0xD1_ahcix64s+80e8

Followup: MachineOwner

2: kd> lmvm ahcix64s
start             end                 module name
fffff880`01c7a000 fffff880`01ce8000   ahcix64s T (no symbols)           
    Loaded symbol image file: ahcix64s.sys
    Image path: ahcix64s.sys
    Image name: ahcix64s.sys
    Timestamp:        Thu Nov 17 01:25:45 2011 (4EC4A8E9)
    CheckSum:         0005295C
    ImageSize:        0006E000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
That lead me to look into your driver list and you do have some that are woefully out of date, the ahcix64s.sys isn't too bad at only being 4.9years old but there are some Kernel drivers that are over 9years old.
I took the liberty of creating a driver list from the report, I use Libre Office and saved it as an MS Excel 2007/10/13 XML (.xlsx) File, I 'm hoping you can open it, it's there at the bottom of my post.

Because of what I found I agree with Mellon Head, and ICIT2 that you should check into [online] and update all the drivers for the parts you used to build your machine especially the BIOS, motherboard (MB), CPU, GPU, hard disk, and solid state drives (HDD / SSD).
You will find that some drivers are easy to find, others not so easy, and some that have only the one that you already have that's 9years old. I suspect that the Steam updates are in conflict with these older drivers.

To help in your quest you can run: Driver Verifier - Enable and Disable to see if there are any obvious problem drivers, you will still have to manually go over the list if the verifier doesn't show much. And this to find them: Drivers - Find and Update Outdated Drivers

  • Do you really need the Glarys Startup Manager? If not please remove it. We find that anything Glary's causes problems, never used to, but it does for win7.
  • One more item I found in your StartUp log, AMD\CNext\CNext\cnext.exe It has to do with your radeon graphics card [Crimson software] some users are having permission problems with it, this may be a way to fix it: CNEXT.EXE bugfix Since I saw this you may want to look into the permissions before you check the drivers. It is a long shot, but I still believe Steam is having problems with those older drivers.
  • When you are D/L'd newer drivers make sure you are getting the proper operating system [OS] and bit versions [32 or 64].
  • Take your time, it's suggested to run the driver verifier for at least a day under normal circumstances to see if your system will find a bad driver.

I used the in-house Windows zip program, all you need to do is D/L'd it >right click and >Extract All:

Attached Files
File Type: zip (26.9 KB, 1 views)
My System SpecsSystem Spec
02 Mar 2016   #28

64 bit win 7

Sorry for the delay,

Windows disagreed with my having updated the bios, and I had to reinstall windows as a result, which then had its own issues.
regardless, now that's sorted I now have a fresh windows install.

I got it back up last night and havn't had a chance to do anything yet.

From previously,
I'm just confused
You say that my ahcis.sys driver is out of date but when I tried to update it using the amd installer, and it indicated that it was the most recent version.

When I reinstalled windows, I used this installer to provide the drivers. Should I be looking elsewhere for these drivers in particular?

My System SpecsSystem Spec
02 Mar 2016   #29

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1

You're welcome. No problem about the delays, it is understood that some things take time.

Using the AMD installer as you did is the preferred way to check for or make updates to your system's hardware. It is the most reliable and safest way to update because one can never tell for sure what is in an important system file if D/L'd from a, to use the term loosely, "dll" site.

If a user has a custom machine like you, you need to stay with the vendor(s) that built the individual pieces of hardware that comprises your build. If a user has a Dell, HP or like me a Gateway/Asus that user needs to stay with those vendors to ensure the user gets the drivers for the hardware that was specifically designed for those different brands and builds. It is helpful if the site has a way for the user to input make/model/serial numbers or has an auto-detect that can take the worry out of wondering if you have the right drivers.

As an analogy; You could replace a Chevrolet engine with a Ford engine and you might get it to work, but with great difficulty and alteration, if you have a Chevy, stick with Chevy parts.

You did well by using the AMD installer, and if it told you, you already had the most up to date ACHI drivers then that is what you have to accept. The short answer? No, don't go looking elsewhere.

Finish setting up your machine without Steam to see if its stable and run the driver verifier for a day or so to see if any problem drivers show up.
My System SpecsSystem Spec
02 Mar 2016   #30

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10

As an analogy; You could replace a Chevrolet engine with a Ford engine and you might get it to work, but with great difficulty and alteration, if you have a Chevy, stick with Chevy parts.
Great advice mate as I never use the Windows feature for updates way too hairy fairy. I always use the manufacturers updates for drivers etc and if I have a job finding what device is in a machine I use HW Info to let me know exactly what for example the WLAN is (see my pic) then go that manufacturers site and download it. HWiNFO, HWiNFO32/64 - Download < go to the installer (green box at bottom I use the US site) after picking the correct bit version and install, Close the running info and click on the part/s you want to find out about again see pic

Plus for example if it was made by Broadcomm then I would either go to the boards drivers list and look for the Broadcomm one (sometimes there are several listed ie Realtek Broadcomm Atheros etc etc)

I have quoted the wifi (WLAN) just as an example you can open out any o the other components for detailed info by opening them out as well ie running frequencies and times for the RAM

Attached Thumbnails
Multicolored Lines, computer crash, Drivers?-drivers.png  
My System SpecsSystem Spec

 Multicolored Lines, computer crash, Drivers?

Thread Tools

Similar help and support threads
Thread Forum
Computer Crashing with multicolored horizontal lines
I have been having this problem since I built my computer in January. My entire computer freezes up and I am presented with the following. I have no Idea what is causing this. Please Help!
Graphic Cards
Post crash computer errors, missing drivers and adaptors
My laptop recently crashed, it wipped everything from my computer and all i have is the basic left, i would usually be able to just start over bot a huge loss, but i can't connect to the internet, via wifi or ethernet cable, i checked and it says it is missing the network drivers, amd i tried to...
General Discussion
HP Pavilion dv5-1125nr vertical lines crash
Hello! I've been experiencing a particular crash for about 3 months now and can't seem to figure it out. -No slowdown or errors prior to crash -display fills compleyely with vertical lines of varying colors in most cases -occacionally, the screen will start to gradually fade to white around the...
BSOD Help and Support
Black or grey&white lines crash
I hope you can help me solve this problem: About a month ago I've upgraded my rig, and since then I'm encountering black or grey and white screeb crash when I'm watching videos on youtube or embedded youtube videos (something like this or this ). But I can play DX9 or DX10 games like Half Life 2,...
BSOD Help and Support
Game Crash, Green lines Please Help [PIC included]
I currently own a 8800gt and happily play cod4 on max, battlefield bad company on medium and a handful of other games which came out within 3 years on max-medium max with reasonable fps. But on some games like eg Crysis, I play in on medium-low fine, i get around 40fps but all of a sudden within 10...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:25.
Twitter Facebook Google+