Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: seems single problem(?) is showing up multiple ways.

12 Apr 2016   #1

windows 7 home premium 64bit
seems single problem(?) is showing up multiple ways.

today i learned f.e.a.r. combat is still going despite gamespy servers shutting down.
i downloaded & installed the free to play game & noticed a problem.
at first i was only getting less than 30 frames per second, but then i read about a logitech HID fix.
that fix involves going into the device manager to disable all the 'HID-compliant' devices.
(they said the game engine does weird things with the logitech hardware because of the way the game engine polls the usb port)
after i did that, my frames per second went up above four times as high.

but i noticed a problem, about every second or two the game would pause for a split second.
i tried flipping around the settings for the game in the nvidia control panel for the specific game, but none of it made the problem go away.

i joined an empty server that was supposedly 50-60 miles away from me (had a ping of about 40ms) and i had fraps running.. well i spawned into the map & ran a fraps benchmark .. the benchmark results are 80fps minimum & 115fps maximum.
i didn't move the mouse or touch the keyboard & everything on the screen was still (nothing was animated) yet the frames were jumping up & down 35 frames per second.

why did i say the problem is showing up multiple ways?
on to that..
it doesn't matter if i use firefox or chrome, h.264 1080p 60fps videos on youtube simply won't play without problems.
720p 60fps videos play smooth with less than a dozen dropped frames the entire length of the video.
yet, my CPU can decode 720p 60fps vp9 videos without any problems either (unless you count the high cpu usage).

i had process explorer open with the game going & was looking for spikes in the CPU usage, but it was less than 50% the whole time.

i had gpu-z open while watching the youtube video & it said the video engine load was in the 70% - 80% range throughout the entire video.
(the heat wasn't high either, i forgot to look at the temps after the video was over - but i know the errors start immediately after stats for nerds says the resolution changes to 1080p 60fps .. plus the fan spins up faster if it gets really hot (and it never-ever does) ..i watched a different 1080p 60fps video earlier & that time i looked at the temps and they were low, & i seen the fan speed went from the normal 40% up to 43%.
(plus i've manually turned the fan up before & it is very loud - enough to grab my attention if it did spin up)

the weird part about the youtube videos is .. sometimes the video will simply pause & then jump ahead as if i tapped the forward seek (because of all the frames dropped) - but other times the video is jerky moving from a start point to a point further into the future & then back to the start point (or even some frames in the past).

put it like this, i watched this roller coaster video & there was a bunch of dropped frames 15025 out of 27112. (the video did some pausing with a buffer icon & it also skipped forward as if i tapped the seek of the progress bar, even though it was simply the dropped frames)

the video i watched before that, i don't remember the number of dropped frames but the video was doing the jerky movement again .. and it is easy to know what i'm talking about considering the video.
the roller coaster goes down the track & the scenery gets closer to the camera until it goes off screen.
well the scenery was moving forwards & backwards as if a strobe light.

i ran latency mon while playing the game & the spikes from that program weren't consistent with the pauses in the game.
plus the results from the latency mon software didn't show anything abnormally high at the top, everything seemed rather smooth going down in time (nothing stuck out as a problem, other than some high latency on the first page)
and of course i tried to run the program again to post the specifics of what was the highest latency, but the window seems to be stuck in the other screen that was recently unplugged.

i even downloaded 3dmark & scored 6231 in cloud gate (not the best, but not the worst either).

i'm running windows 7 home premium 64bit with 4gb of ram
a core2quad q6600 @ stock speed
a gtx285
i've got an ssd drive
the motherboard is an xfx 680i lt
(had to clone the old hard drive onto the ssd because it wouldn't finish the operating system install)

i've got all the unnecessary services turned off.
nothing running in the tray other than asio4all that feeds liveprofessor that i use to do audio calibration with virtual audio cable.
(there's been times when i'll be sitting there listening to music reading an article & the audio will start to crackle & i need to reset the driver to make it go away .. sometimes it would happen repeatedly after clicking the reset button & other times it would go away for months)

i got this used computer from an old counselor who claimed to be 'a hardware guy' & he said it had some problems.
i thought i might need to replace a capacitor or two (or perhaps an bios ic or something) .. well i turned it on and the clocks were at some overclock & i brought everything down to stock & left it there .. things seemed to stabilize for quite a while.
there was a few hiccups with random reboots that basically went away, i thought perhaps the components needed some time to settle & thus stabilize. haven't had any random reboots in many months (maybe a year?).
but after i got it up & running & assumed it was basically the overclock causing the guy to be disappointed with the motherboard (at least), i was happy to give my mother my old computer because it was also a core2quad q6600 with 4gb of ram & a gtx260.

the audio problems started some time after i was visiting a flash chat website.
then they started talking about all the flash vulnerabilities & how flash needed to come to an end.
i thought perhaps flash had something to do with the audio stream hiccups.
after i quit going to the chat room, the longer i stayed away the less and less the problem occured.
yet, it's probably been a year or year anda half since i've been there & i had to reset the audio driver twice today (continues to happen from time to time).
the computer has a seasonic 750 watt power supply & there was two gtx285's & i removed one thinking i could ever take some load off the psu & see what comes of it.

i'm tempted to try flashing another bios onto the graphics card, yet i don't know if that is the root of the issue considering the audio & the good benchmark score & the latency that shows up in latency mon.
i remember ndis was second from the top, but i don't remember what the top one was.. i know direct x was up there near the top too, and none of them showed a big difference between eachother.
i think the highest was 0.7 & i don't remember what the next one down was, but it was half or less.

i'm gonna reboot & leave the magicjack turned off & see if the game runs any better (because it was the one HID in the device manager that reinitialized after disabling it.

oh, i almost forgot, the benchmark was pausing a split second almost every second or every other second too.
and then (though i haven't ran this benchmark with my system) this video shows a core2quad q9300 with a 9800gtx & it scored a minimum of 91 fps with a maximum of 297 fps
(thinking the gtx285 should be 400+ fps , yet i haven't seen 150)

i'm assuming somebody might know of a good driver version, & then from there look into something running in the background?
otherwise i think i'll need to look for a bios file to flash the card & see if that helps.
(i'm looking to buy a gtx960 anyways to do the vp9 encoding|decoding .. but i thought i might try to play some starwars battlefront a little bit since i haven't played games in about 10 years & it's the only shooter that seems tolerable .. i know it probably won't run the game well, but if i can fit it in my day (or night) then i'm gonna want the card anyways, because then this computer could be useful for the internet for what? another 5 years & then i'll probably put it in the vehicle to do audio processing in there since there's hundreds of radios on the market without the features i need)

plus i thought i'd post about it since i read a lot of people with problems watching the new vp9 youtube videos & i'm wondering if there's ever been some resolution for that topic.

My System SpecsSystem Spec
12 Apr 2016   #2

windows 7 home premium 64bit

forgot to mention i turned off aero too, because it was recommended somewhere that it could ever help (haven't turned it back on yet).

i restarted the computer & didn't open my audio processing or my magicjack.
i ran latencymon long enough that it would pick up something right away if there was a problem.
here are the results from that:
seems single problem(?) is showing up multiple ways.-latency.png

there didn't seem to be a problem reported by latencymon, thus i went into the game hoping the problem was sorted - but the pausing for a split second is still there.
i came out of the game & looked at latencymon and it had this to say:
seems single problem(?) is showing up multiple ways.-latency1.png

technically ISR & DPC aren't showing red & that makes me think those two are okay.
but the interrupt to process delay is very high.
this is what the software says an interrupt to process delay is:

'The interrupt to process latency reflects the measured interval that a usermode process needed to respond to a hardware request from the moment the interrupt service routine started execution. This includes the scheduling and execution of a DPC routine, the signaling of an event and the waking up of a usermode thread from an idle wait state in response to that event.'

with that said, i know the DPC routine is low enough to avoid being red flagged by the graphic meter.
that leaves the scheduling, the signaling of an event, & the waking up of a usermode thread from an idle wait state.

but that brings me back to my own hyped notion that i've had, it seems the operating system is growing more & more unorganized as the years go on.
i caught on in windows xp where the many repeated things continued to slow down despite my internet speed going up more than double.
didn't really matter if i erased files keeping the hard drive more empty rather than full .. didn't matter if i defragmented the drive .. didn't matter if i erased the harddrive & reinstalled the operating system.
after some point in time, even the fresh install was a little bit slower than before - and the operating system slowed down a lot more after little time had passed after the fresh install.
yet i was doing the same exact things with the computer.
that was 12-15 years ago & things haven't changed (unless windows 10 is any better, but this operating system remains on the support list).

another thing i noted while looking at the latencymon software was how it listed the ISR & DPC count in execution time categories.
all of my ISR execution times were <250 s.
all but 10 of my DPC execution times were <250 s.
those 10 fell into the 500-999 s category.
the software said the driver with the highest DPC execution time was 'nvlddmkm.sys - NVIDIA Windows Kernel Mode Driver, Version 341.81'
yet i found this to be intriguing:
Highest reported total DPC routine time (%): 0.141141
percentage tells me, despite the amount of microseconds it took - the most active falls into this category:
Driver with highest DPC total execution time: USBPORT.SYS - USB 1.1 & 2.0 Port Driver, Microsoft Corporation

i also thought this was brilliant:
CPU 0 Interrupt cycle time (s): 50.482396
CPU 0 ISR highest execution time (s): 144.720
CPU 0 ISR total execution time (s): 10.308065
CPU 0 ISR count: 1757644
CPU 0 DPC highest execution time (s): 728.520
CPU 0 DPC total execution time (s): 29.451936
CPU 0 DPC count: 6878218

CPU 1 Interrupt cycle time (s): 9.033921
CPU 1 ISR highest execution time (s): 0.0
CPU 1 ISR total execution time (s): 0.0
CPU 1 ISR count: 0
CPU 1 DPC highest execution time (s): 60.92250
CPU 1 DPC total execution time (s): 0.185206
CPU 1 DPC count: 66694

CPU 2 Interrupt cycle time (s): 9.036362
CPU 2 ISR highest execution time (s): 121.436250
CPU 2 ISR total execution time (s): 0.384187
CPU 2 ISR count: 33130
CPU 2 DPC highest execution time (s): 180.75750
CPU 2 DPC total execution time (s): 0.750410
CPU 2 DPC count: 95434

CPU 3 Interrupt cycle time (s): 7.609548
CPU 3 ISR highest execution time (s): 0.0
CPU 3 ISR total execution time (s): 0.0
CPU 3 ISR count: 0
CPU 3 DPC highest execution time (s): 176.463750
CPU 3 DPC total execution time (s): 1.126990
CPU 3 DPC count: 32297

there isn't an ISR count on two of the cores.
the amount of seconds doesn't add up to the number of seconds i was playing the game (though would all of those whole seconds add up to the total number of split second pauses? ..well if a round in the game is 10 minutes and the split seconds are simply half a second, then no there aren't enough seconds listed for that to be possible.
yet, what if the 'event' was much much less than half a second while the consequences of said 'event' are much longer? then perhaps those numbers would add up.

it doesn't make sense why there are DPC's on all four cores, yet the ISR's are only on two of those cores.
it also doesn't make sense why three of the cores interrupt cycle time is about the same, while the other core is almost ten times as high.

the highest DPC execution time on all the cores comes from core 0 and is: 728.520s
the driver with the same amount of time is: nvlddmkm.sys - NVIDIA Windows Kernel Mode Driver, Version 341.81

that made me think the nvlddmkm.sys driver isn't scaling at all & it makes me wonder if it did, would the problem be less or gone entirely?

here's something else interesting, the ISR total execution time + the DPC total execution time = 39.760001 seconds.
yet the software says the interrupt cycle time is 50.482396 seconds.
there's 10.722395 seconds missing & that number isn't anywhere on the other cores either.
what is that, my digital I.D. number for the dark web?!
from 4 to heel, from heel to heal - somebody wants my job dire bad & is willing to torture & abuse me to tell me about it?!

the difference between these two tells me something is seriously wrong:
Highest measured interrupt to process latency (s): 5593.413851
Average measured interrupt to process latency (s): 4.843626

if the industry isn't going to give me a tool to look into the interrupt to process mechanism, as far as each instance of progress & the timing of those instances - then it isn't up to me to fix & thus microsoft should be fixing it rather than me suffering with it.
makes me wonder if microsoft is fighting with another software and|or driver developer causing the two to be less than a harmonious set.
the hardware is sold for microsoft, it is advertised.
how are we supposed to play with legos if the buttons & holes don't line up?!
the industry is supposed to be a solid lock, rather than an unstable situation where the most simplistic forms of life could knock those pieces apart (such as the vibration of the floor when walking away, or too much wind, or any single person that lacks enough care to touch those pieces .. plus how are we supposed to build without wanting to cheat by leaning those pieces up against a wall? walls aren't freedom, they are confinements that hinder freedom.)

it says the direct x graphics kernel ran for 13947.361568 milliseconds.
i don't like the math of those numbers for personal reasons (considering it could ever be conceivable the numbers after the decimal point bite at the numbers before the decimal point with higher priority and|or occurance).

can anybody bring some light upon the scheduling, the signaling of an event, & the waking up of a usermode thread from an idle wait state?

My System SpecsSystem Spec
14 Apr 2016   #3

windows 7 home premium 64bit

well that was a weird experience.
i had flipped the television from port 2 & put it into port 1 (with the other monitor in port 2).
that caused the other monitor to show a yellow hue.
as it turns out, the monitor's color is fine (pressed the onscreen menu & the colors show up without a problem).

i thought the pulsing wasn't happening prior to switching the cables around.
that caused me to unplug the monitor from port 2 & plug the television back into port 2 (without the monitor going into port 1).

first of all, the colors coming from port 2 were back to what they were (not showing a yellow hue).
second of all, the pulsing quit.

then i installed some new ram later that day & after i rebooted, the pulsing came back.

i plugged the television into port 1 & the pulsing went away.

since then i've restarted the computer & the pulsing remains gone.

though now there's something else weird going on.
i can watch a 720p 60fps video on youtube without a single dropped frame.
switched it to 1080p 60fps & there weren't any dropped frames - but i had fraps running and fraps said my frames per second was in the 30's dropping down into the 20's .. yet the stats for nerds said i wasn't dropping any frames.

well that made me curious about the video engine load.
i fired up gpu-z & hit the replay button in full screen.
at the beginning it ran, but a few seconds later i seen the dropped frame counter go up & my audio started to crackle (has been a frequent problem that happens dozens of times a day or dozens of weeks go by without it happening once).

i got out of the video & reset the audio driver & went back to the video & let it play until it was finished.
the video would play for some seconds, 20? & then the dropped frame counter went up with a hundred or more dropped frames - but the audio wasn't crackling again.
the video went back & forth between smooth & lots of dropped frames - the audio didn't crackle for the rest of the video.
i got out of the video & looked at gpu-z & it showed the video engine load with moments of 0% use.
yet my internet is 10mbit/s & it's 1am & besides - the video was technically already fully loaded because it played to completion before a moment ago.

here's a screenshot of gpu-z (max video engine load was 91%)
seems single problem(?) is showing up multiple ways.-video-engine-load.png

i'm gonna try turning v-sync on with nvidia's control panel profile feature for the browser & see what happens.

My System SpecsSystem Spec

14 Apr 2016   #4

windows 7 home premium 64bit

i turned vertical sync on & restarted the browser, went to my favorite reference video for quality & well look for yourself:
seems single problem(?) is showing up multiple ways.-vsync-.jpg

the video was tearing & the frames per second aren't a multiple of 60 either.
the video engine load was steady that time, going back & forth between 90% & 91%:
seems single problem(?) is showing up multiple ways.-second-video-engine-load.png

doesn't make sense to me.
i guess i'll try to turn on vsync globally in nvidia control panel & see what happens.

My System SpecsSystem Spec
14 Apr 2016   #5

windows 7 home premium 64bit

global vertical sync didn't help either.
both times i've had it on (either with the browser specifically or globally) the video looked worse.
it was blurry in some parts & there was compression artifacts in other parts.

seems single problem(?) is showing up multiple ways.-global-vsync.jpg

the video engine load did basically the same thing.
now i'm gonna try global triple buffering.

My System SpecsSystem Spec
14 Apr 2016   #6

windows 7 home premium 64bit

triple buffering didn't help either.
forgot to mention, when i watched the video above (the one with global vsync turned on) the video ended early before all of the content was played on my screen.

here is a picture of the artifacts:
seems single problem(?) is showing up multiple ways.-compression-artifacts.jpg

there's a reduction everywhere in that screenshot really, but especially noticeable on the wall.

i'm using firefox with the 'noscript' extension & it loads a bar on the bottom of the screen.
i seen when i first go to the video fraps says it is running at 60fps & then the noscript bar pops up & the frames per second don't ever recover.
i'm gonna try turning that bottom bar off & see if the 60 fps will hold.

My System SpecsSystem Spec
14 Apr 2016   #7

windows 7 home premium 64bit

okay, i guess i can't capture a screenshot with the video tearing.
i turned the bar off & it doesn't help with the 1080p 60fps video.
if i turn it down to 720p 60fps then the fraps counter shows 60fps (but it tears sometimes).
there's compression artifacts at 720p 60fps & 1080p 60fps with vertical sync on.
look for yourself:
seems single problem(?) is showing up multiple ways.-vsync-720p.png

seems single problem(?) is showing up multiple ways.-vsync-1080p.png

it doesn't seem to matter if the resolution is set to 1080p 60fps even though the dimension of the video on the website (not in fullscreen) is 720p.

i'm gonna turn triple buffering off & vsync off & see if i can get a picture with 60fps 720p at least.

My System SpecsSystem Spec
14 Apr 2016   #8

windows 7 home premium 64bit

suffice to say, i can get 60fps with vsync shut off at 720p .. but the compression artifacts are still there (i think it might be the h.264 codec honestly, because i noticed it looks a little bit better when streaming vp9).
the tearing is still there @ 720p 60fps with 60fps shown by fraps.
when i turned triple buffering on, the video engine usage went to 92% with the global setting, but didn't go up that high when using triple buffering only with the browser profile (if that matters any).

the movement is clearly slower with the 1080p 60fps video - such as when the cat comes along and jumps up.

anyways, this video looks superb:
really does a job of showing you the quality of a screen.

i'm still wondering if there are improvements with the driver using an older version or if i could see an improvement after flashing a different bios onto the graphics card.

i'm also wondering about why the audio stream keeps breaking, i'm wondering if there's some clock drift going on; either between virtual audio cable & the realtek hd soundcard or one of those two with the graphics card (one of the vst plugins i use has gpu acceleration).

i did some media class scheduling tweaks & turned off hpet in the bios, i don't know if that has helped with the 1080p 60fps video playing with less frame drops (or if it might of been simply unplugging the cable from the graphics card - or if it is because there's only one monitor going right now).

it's a mess & one thing clear to note is the video engine load isn't at 100% thus it isn't suggested that the graphics card hardware acceleration has simply ran out of processing power.

two of the vst plugins i use has gpu acceleration.
one of them was opencl & listed as experimental (though it has worked for days without the audio stream breaking).
i turned it to software rendering & i'm gonna wait to see if that helps any.
typically, i would think using a less accurate timing could cause it to happen - but the audio stream has broken with hpet enabled too (yet that doesn't suggest hpet being off allows it to happen any more or less considering windows xp ran without it).

i might try to turn off the gpu acceleration with the other program too & see if the audio stream stops breaking.
seems as if the audio stream will break for whoever or whatever wants it to break & i'm simply trying to avoid it.

makes sense to me that i need to get rid of this graphics card either way.
because the gtx960 decoding vp9 is a plus (since vp9 shows visual improvements compared to h.264).
then there's the fact that i can encode with the graphics card too, another plus if i ever want to play a video game or use open broadcaster software (i don't know if the software has gotten around to doing the processing on the graphics card yet, but if they wont somebody else will).

doing the multimedia class scheduler tweaks got my 3dmark cloud gate score up from 6 thousand something to 7 thousand something.
with that much performance boost, i might be able to play some battlefront (since the fear combat community seems to be less than 30 people).

**edit again**
oh, forgot to mention that i'm trying to get 10 bit color guaranteed with the consideration of the gtx960 since vp9 supports 10 bit color & 12 bit color with 4:4:4 chroma upsampling.
they said the gtx285 can do 10 bit color, but from what i've gathered there doesn't seem to be much support or talk about it other than it being available with direct x.
the operating system still says 32bit 'true color' when really it should be 30bit 'deep color' - because from there it is still a matter of 36bit & 48 bit 'deep color'
the first version HEVC supports 8bit or 10bit color with 4:2:0 chroma upsampling.
the second version HEVC supports 8bit through 16bit color per sample.

i'm hoping they factor in the 1080p televisions with 10bit color for the new UHD blu rays, because i know my television isn't the only one supporting 1.07 billion colors.
My System SpecsSystem Spec

 seems single problem(?) is showing up multiple ways.

Thread Tools

Similar help and support threads
Thread Forum
BSOD in multiple ways error 0x01E
Hello, A few years ago I got my HP Pavilion dv6 laptop for college. It worked well, but now it crashes multiple times daily. It seems like it can crash at any time whether I'm video gaming, youtubing, even trying to open Google Chrome. My laptop still boots up fine and it does not crash in safe...
BSOD Help and Support
Connect to Multiple WIFI APs with single NIC
Hello everyone! Happy diwali to all of you. I would like to know the procedure to connect to multiple Access points with my laptop. For example, my laptop is connected to office WIFI for file sharing. Now, I would also like to connect to another AP for internet connectivity. If i currently do...
Network & Sharing
Single HDD Showing 2 Volumes (not partitions) cant merge
as the title says i just got two 3TB HDD's and for some reason after 2TB its showing a new volume. any idea how to fix it? shoot me a question for more details if you need it
Hardware & Devices
Ways, to install software to multiple computers at the same time?
I want to know the possibilities from the guru's around here. Ways, to install software to multiple computers at the same time? Simply explained, if possible, i don't wanna run by every pc by hand, or put an iso on network drive and still walk pcs by hand. There must be software that can do the...
Backing up multiple computers to single HDD
Hi Folks, After wasting a bunch of my time, I discovered that Windows easy transfer cannot be used to move user data from a 64 bit computer to a 32 bit computer. Upon discovering this, another question came to mind; I partitioned a 500GB external USB drive into 4 partitions, and created an...
Backup and Restore

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:33.
Twitter Facebook Google+