Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: ATI Catalyst drivers and Dell Radeon HD 3470?

20 Nov 2009   #11
beefmissile

windows 7
 
 

Dieter i have the same problem on my optiplex 760 with windows 7 ultimate x64. I've tried an HD3470 out of another 760 and a Radeon HD4850 that i jimmied up to work in the system, all have the same problem you describe, bluescreen about 20% through the detection phase. The drivers from dells site install fine for me as well, but the ones from AMD all bluescreen in the same way. As an interesting note when i was searching around on this issue last week i saw on another post on this forum(i think, can't find it now, should have bookmarked it) where someone was having the same prob but found that the catalyst 9.6(or 9.7) installs fine, sure enough they do install fine. Not sure what the fix for this will be but it seems to be that detection phase on the 760 specifically.


My System SpecsSystem Spec
.
20 Nov 2009   #12
DieterW

Windows 7 Professional x64
 
 

:beefmissile: That's good to know. I was thinking I was going crazy, since Google searches did not really reveal anything else. I may contact Dell to submit a bug; I'm sure their official stance will be to install the Dell ATI drivers, but I'll come up with some reason, especially if you tried another ATI card with the same results. Perhaps a BIOS update could fix the issue.

Thank you!
My System SpecsSystem Spec
20 Nov 2009   #13
beefmissile

windows 7
 
 

i'm hoping a future bios can fix it as well, in the meantime you may want to try installing the catalyst 9.6 as i think they will install. I'm not sure if they come with avivo though (i've never used it). I'm going to stick with the whql drivers from windows update for the time being because i'm using the card (4850) to run modern warfare 2 and i'm pretty sure that they're newer than the catalyst 9.6. I'm hoping to figure out a way to get the 9.11 cats on here so that i can tweak some settings in the CCC.
My System SpecsSystem Spec
.

20 Nov 2009   #14
DieterW

Windows 7 Professional x64
 
 

Well, as noted, I was able to get 9.11 installed, but drivers only. I don't generally use CCC, so if you need that, you might have to wait for a fix from Dell.

If you just need the drivers, then torrentg's suggestion to install the drivers from Device Manager in safe mode worked for me. The newer drivers did improve performance slightly for me, at least in Windows' Aero benchmark.

I doubt it, but I wonder if you had your full suite installed (drivers, CCC, etc) at your current level, and then just attempted to update the drivers only as described above? I wonder if the new drivers would work with the older CCC?
My System SpecsSystem Spec
20 Nov 2009   #15
torrentg

7600.20510 x86
 
 

Quote   Quote: Originally Posted by DieterW View Post
I wonder if the new drivers would work with the older CCC?
I don't think so. They usually complain of a version mismatch in this case.

Did you try to run NvCplSetupEng inside C:\NVIDIA somewhere (search it if you need to)?

This should install it.
My System SpecsSystem Spec
27 Jun 2010   #16
Philzegore

Windows 7
 
 

Hi

I register on this site for giving you a solution, it works for me (ATI HD 3470 and DELL computer):

Unplug all USB hardware during ATI Catalyst installation only the first part (mouse and keyboard too).
If you use a wireless mouse: click on install, unplug fastly usb mouse adapter, after hardware detection, plug again your adapter.

Bye
My System SpecsSystem Spec
10 Jul 2012   #17
ashlea

Windows 7 Professional x64
 
 

Quote:
I register on this site for giving you a solution, it works for me (ATI HD 3470 and DELL computer):

Unplug all USB hardware during ATI Catalyst installation only the first part (mouse and keyboard too).
If you use a wireless mouse: click on install, unplug fastly usb mouse adapter, after hardware detection, plug again your adapter.
That totally fixed my issue updating the driver. I had various issues with Aero stuff - the thumbnail preview on the taskbar kept disappearing too quickly (making switching to applications with multiple open windows impossible via the taskbar) and my windows key would not bring up the start menu even though the windows key shortcuts all worked just fine. Updating the video driver fixed it, but I was having the blue screen issue during install except for when I tried unplugging all my USB devices, including keyboard and mouse.
My System SpecsSystem Spec
26 Dec 2012   #18
wickeddude12

64
 
 
Weird fix works for me as well!

This fix makes no sense at all but this worked for me as well on an Optiplex 755! Must have something to do with the chipset...thanks!

Code:
Hi

I register on this site for giving you a solution, it works for me (ATI HD 3470 and DELL computer):

Unplug all USB hardware during ATI Catalyst installation only the first part (mouse and keyboard too).
If you use a wireless mouse: click on install, unplug fastly usb mouse adapter, after hardware detection, plug again your adapter.

Bye
My System SpecsSystem Spec
Reply

 ATI Catalyst drivers and Dell Radeon HD 3470?




Thread Tools




Similar help and support threads
Thread Forum
amd radeon 6950 catalyst/driver errors
hi, im trying to run three hanns hz281s off a radeon 6950 and trying to run just the one atm straight from the gpu. Catalyst 11.6 and 11.5 wont show up in the programs after attempting installation. http://i1182.photobucket.com/albums/x450/johnwhtt/3.png...
Drivers
no signal with catalyst drivers on hd tv (radeon hd 5700)
hi... I did use a crt up untill today, an iiyama vision master pro but i decided to switch to using my hd tv instead since it's bigger. so i turn it on and get no signal. No problem i thought, booted in safe mode, removed the ati driver and rebooted.... booted fine and the system driver allowed me...
Graphic Cards
ATi Mobility Radeon HD 3470 Problem
Ok so I updated to windows 7 and downloaded the latest driver from the ati website and it all installed perfectly but now its showing in the ccc as hd 3400 and also in device manager which I cannot understand when I have an HD 3470 and when i load most games it says your graphics driver is not up...
Graphic Cards
problem with ATI Mobility Radeon HD 3470
hi all :D last day I upgrad my windows vista to a windows7 ultimate 32bits since them i can play games in the pc(Asus X59 Sl):cry: every time that i start playing a game (like counter strike 1.6) the image appears with 2 black strips in each side of the screen and the image shrinks and i canīt...
Graphic Cards
ATI Mobilty Radeon 300X Catalyst!!
I am working on Dell Inspiron 6000 Laptop and I Installed Win 7 Fully Activated and working well. Windows Update downloads the graphics card as shown below: http://i383.photobucket.com/albums/oo271/Kayyali101/graphic_card_proberties.png and when I was searhing for Catalyst for My Graphic driver I...
Graphic Cards
ATI Radeon HD 3470 problem
Hi! I have an Acer Travelmate 5530G notebook with an ATI Radeon HD 3470 Hybrid X2 vga in it. I installed the latest catalyst (9.4 , and tried the 9.3 later .. no change) and i have a very strange problem.. First of all the games doesn't 'recognise' my vga or something .. they work like i have a...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Đ Designer Media Ltd

All times are GMT -5. The time now is 05:03.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App