Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: my HD5970 experience

17 Dec 2009   #51
sygnus21

Windows 10 Pro
 
 

Hey Skunksmash, you might want to try out the "official 9.12" drivers, including the new 9.12 hotfix driver. You can read about it here Catalyst 9.12 Released - Rage3D Discussion Area then download from ATI's website.

Good luck


My System SpecsSystem Spec
.
17 Dec 2009   #52
Bare Foot Kid
Microsoft MVP

W 7 64-bit Ultimate
 
 

Congrats on the card Mitch.
My System SpecsSystem Spec
22 Dec 2009   #53
skunksmash

SEVEN x64
 
 

Cheers Ted....


ok.... so its time for an update on the never ending ATI saga....., since my last post in this thread my gaming experience has dropped no end.

somehow the driver corrupts itself with continued use, one minute its fine & all is well & then something happens (ive yet to pin down a cause, which tells me its simply driver corruption), i mean i can run ''furmark'' @ 1920x1080 8xAA with a clean crisp 200fps AVG..... there is no stuttering in this bench which tells me the H/W is fine

but out of the blue my desktop colours go back to default settings & i get TERRIBLE ''microstutter'' while gaming, i know this is a driver issue as it was not present with the 9.11 drivers, & the FPS are not affected..

benchmarks still run VERY well, i actually gained 2k in vantage with the 9.12 but gained the stutter.

its certainly related to the on-board crossfire b/c when i disable AI in CCC (in affect disabling one core), the stuttering goes...

i would just roll back to the 9.11s but these drivers had the downclock issue, which 9.12 fixed.

so im left with a choice.......

run the 9.12 drivers & disable 1 core, or run both & put up with the stutter

or

run the 9.11 driver, games perfectly but i get artifacts all over the screens while in 2D mode.

i have tickets open with ''sapphire'' & ''AMD'' in the hope of getting some quick fixes formulated.

i would like to add, even though im at wits end with AMD's driver support , the card itself is still amazing & on the previous drivers you could really see this card performing, ppl are sending these cards back left, right & center.... but these issues will get ironed out, just like the 4 series finally did.

these issues are not just 5970 ones either, they stretch across the whole 5 series range, driver bugs GALORE!!

my advice to anyone looking to upgrade their GPU's would be to hold off 3 or 4 months, drivers will mature on the 5 series cards & you'll have a much better experience off the bat

or

go Nvidia & ASSURE yourself 100% compatibility & EXCELLENT driver support.
My System SpecsSystem Spec
.

22 Dec 2009   #54
A320

Win 7 Ultimate x64
 
 

I gotta say, my 5870 along with 9.12 drivers is working like a charm right now on my setup. No issues whatsoever. I too gained huge numbers in vantage after upping from 9.11 to 9.12. I think it's time now to consider making the switch from Phenom over to i7 as I fear that my mobo/cpu might be keeping this video card back. I'm not sure how much I'll gain though as I felt I was doing well with my Phenom II x4 OC and my current mobo. But all in all my experience is good, card performs like stink.
My System SpecsSystem Spec
22 Dec 2009   #55
ThePizzaMan

Windows 7 Ulitimate Beta 32 Bit, Windows Vista 32 Bit, Ubuntu 9.10 32 Bit
 
 

Quote   Quote: Originally Posted by skunksmash View Post
Cheers Ted....


ok.... so its time for an update on the never ending ATI saga....., since my last post in this thread my gaming experience has dropped no end.

somehow the driver corrupts itself with continued use, one minute its fine & all is well & then something happens (ive yet to pin down a cause, which tells me its simply driver corruption), i mean i can run ''furmark'' @ 1920x1080 8xAA with a clean crisp 200fps AVG..... there is no stuttering in this bench which tells me the H/W is fine

but out of the blue my desktop colours go back to default settings & i get TERRIBLE ''microstutter'' while gaming, i know this is a driver issue as it was not present with the 9.11 drivers, & the FPS are not affected..

benchmarks still run VERY well, i actually gained 2k in vantage with the 9.12 but gained the stutter.

its certainly related to the on-board crossfire b/c when i disable AI in CCC (in affect disabling one core), the stuttering goes...

i would just roll back to the 9.11s but these drivers had the downclock issue, which 9.12 fixed.

so im left with a choice.......

run the 9.12 drivers & disable 1 core, or run both & put up with the stutter

or

run the 9.11 driver, games perfectly but i get artifacts all over the screens while in 2D mode.

i have tickets open with ''sapphire'' & ''AMD'' in the hope of getting some quick fixes formulated.

i would like to add, even though im at wits end with AMD's driver support , the card itself is still amazing & on the previous drivers you could really see this card performing, ppl are sending these cards back left, right & center.... but these issues will get ironed out, just like the 4 series finally did.

these issues are not just 5970 ones either, they stretch across the whole 5 series range, driver bugs GALORE!!

my advice to anyone looking to upgrade their GPU's would be to hold off 3 or 4 months, drivers will mature on the 5 series cards & you'll have a much better experience off the bat

or

go Nvidia & ASSURE yourself 100% compatibility & EXCELLENT driver support.
eh give it a couple months and it will all get fixed, which will still be before nvidia ever gets their card out
My System SpecsSystem Spec
22 Dec 2009   #56
Dom

Windows Seven Ultimate
 
 

You mentioned this in Vista Forums Mitch, didn't know you would be posting here. I was expecting you to just plug 'n' play (not literally, but you know what i mean ). anyway, sounds great and have a glorious Christmas with it!
My System SpecsSystem Spec
22 Dec 2009   #57
Frostmourne

Windows 7 Ultimate x86-64
 
 

My first ATI card - a 4890 - is performing fine. That said drivers are constantly improving although single gpu cards are probably more stable.
My System SpecsSystem Spec
22 Dec 2009   #58
sygnus21

Windows 10 Pro
 
 

Wow! Seems to me that ATI still has issues with crossfire, whether it be dual cards or a single x2 card. This is the main reason Iíve never went crossfire or stayed away from the x2 cards. Itís just too much money to be putting up with spotty performance. Yeah I know the 5970 doesn't have x2 in the title but it's still a dual card on a single PCB board.

It also seems to me that the entire 5000 series has been problematic as a whole. ATI had better get this sorted out or else.

I've been a long time ATI customer, (since 3DFX was bought out), but I don't see myself getting into crossfire thing until ATI irons out their performance issues with the setup.

Also, seeing the overall issues with the 5000 series, I may wind up holding onto my 4890 until the next generation comes out. I skipped 2000 series for this reason as well.

Good luck and hopefully ATI gets the driver issue(s) fixed for these cards soon.
My System SpecsSystem Spec
22 Dec 2009   #59
A320

Win 7 Ultimate x64
 
 

Are my posts a mirage?! I am having ZERO issues with my 5870.
My System SpecsSystem Spec
22 Dec 2009   #60
sygnus21

Windows 10 Pro
 
 

Quote   Quote: Originally Posted by A320 View Post
Are my posts a mirage?! I am having ZERO issues with my 5870.
Are everyone else's a mirage??? Just because YOU don't have a problem doesn't mean others don't!!!

I don't own a 5870; does that mean they don't exist?


My System SpecsSystem Spec
Reply

 my HD5970 experience




Thread Tools




Similar help and support threads
Thread Forum
Atikmpag.sys BSOD on ATI HD5970
Hi guys, I'm having a major problem with the "atikmpag.sys" BSOD error whenever I try to play video games (and the occasional random crash too). Oddly enough, it never happens while rendering in Cinema 4D, so I've pretty much ruled out it having something to do with how intense the GPU usage is....
Graphic Cards
Anyone Else Experience...
Hello new guy here:D I couldn't really find a suitable place to put this so iv'e placed it here sorry if it's in the wrong section. EDIT: Windows 7 Home Premium x64 and before i updated i had a custom theme which meant i had to patch the system files. i never replaced the patched ones to the...
General Discussion
My PC experience :(
Hi, This is going to be a big story, nay rant but if you want to read it go ahead. I made my own custom PC in late 06' basically being my setup now. It started off working well but now I think of it have had graphics problems and problems in general every since. After upgrading the video...
General Discussion
hd5970 hangs at start up
hd5970 hangs at start up sometimes then you turn pc off then on then press key too start windows normally then works fine. then when you leave off for few hours you have too do the same again.
General Discussion
HD5970 to launch on Nov 18th
ok peeps, introducing the FASTEST dual GPU GFX card on the planet, measuring in at a MASSIVE, 12.5''.... HD5970 (HD5870x2) :D http://alienbabeltech.com/main/wp-content/uploads/2009/10/HD5970b_thumb1.jpghttp://alienbabeltech.com/main/wp-content/uploads/2009/10/HD5970a_thumb1.jpg...
Graphic Cards
What was your first Experience with a PC/OS ???
Well as for me my first machine i ever touched was the Mac OS (i believe it was 6.0...) that was in elementary (1996... yes we were behind the times, this school didnt have much money...) then in 98 to upgraded to Mac 7 and finally to 8..... That was the last i saw or heard of the Mac until OSX...
Chillout Room


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 07:11.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App