Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: ATI 4850 driver issues

29 Dec 2009   #11
rbmorse

Ubuntu Lunix and Windows 7
 
 

I would expect that to be the case if the Catalyst drivers are not installing properly for your HD 4850. Without the drivers you don't get any benefit from that graphics accelerator functions of the GPU...it runs pretty much as a straight VGA card.

Check the install log and event viewer for errors that might have been recorded during the driver installation attempts.


My System SpecsSystem Spec
.
30 Dec 2009   #12
winger

Windows 7
 
 

It does say
Code:
<result>Success</result>
where it needs to, I think the drivers are installing fine, maybe something else is wrong? I'm not sure, anyone who has working drivers for ATI 4850 32bit Win7 , please upload somewhere and link me (I already have tried the one's from ATI's website). Thanks!
My System SpecsSystem Spec
30 Dec 2009   #13
winger

Windows 7
 
 

um, should I actually run the driver setup as an administrator? I mean I was logged in as administrator but just asking if I should enable it via right click..
My System SpecsSystem Spec
.

30 Dec 2009   #14
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Any active anti-virus running? If so you may need to disable it to get the driver to install properly.
My System SpecsSystem Spec
30 Dec 2009   #15
winger

Windows 7
 
 

I did disable that during the last install, after sweeping the old drivers in safe mode. Still.. nothing seems to fix it.
My System SpecsSystem Spec
30 Dec 2009   #16
sygnus21

Windows 10 Pro
 
 

What's your power supply rating?
Did you do a "clean" install?
Are you overclocking?
Did you connect the power connector to the card?

As for the video card drivers - ALWAYS get them from the manufacturer, NEVER from Windows update.
My System SpecsSystem Spec
30 Dec 2009   #17
Guy with a Colt

Windows 7 Ultimate 64bit
 
 

Try installing the latest Directx components.
You can get it from one of the following links. Personally I use the redistributable install.

Web Install
or
Redistributable Install

Commonly, if you don't install directx 9.0c component files, the games that use 9.0c will have problems.

I always make sure I have the latest Directx components and drivers etc.

I hope this helps
My System SpecsSystem Spec
30 Dec 2009   #18
sygnus21

Windows 10 Pro
 
 

Quote   Quote: Originally Posted by Guy with a Colt View Post
Try installing the latest Directx components.
You can get it from one of the following links. Personally I use the redistributable install.

Web Install
or
Redistributable Install

Commonly, if you don't install directx 9.0c component files, the games that use 9.0c will have problems.

I always make sure I have the latest Directx components and drivers etc.

I hope this helps
What he said
My System SpecsSystem Spec
30 Dec 2009   #19
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Another thing that could possibly be an issue is the folders from previous drivers in the DriverStore folder, which keeps enough info in each to be able to rollback to a previous driver. With the trouble you have been having I would go into the DriverStore folder and delete all the ones from the ATI video drivers. They will look something like the one's highlighted here (the numbers before the .inf are the number used to name the INF file in each driver version),

ATI 4850 driver issues-atidriverstore.png

Make sure to set a system restore point (or a full backup) before starting, and then with no driver installed uninstall all but the oldest folder. Then try installing the latest Catalyst from ATI's site.


My System SpecsSystem Spec
30 Dec 2009   #20
rbmorse

Ubuntu Lunix and Windows 7
 
 

Quote   Quote: Originally Posted by sygnus21 View Post
As for the video card drivers - ALWAYS get them from the manufacturer, NEVER from Windows update.
That is very, very ill informed advice. The drivers available from Windows Update may not be the very latest, but they have been validated and validation is important when you're trying to troubleshoot an installation because it removes a critical variable from the process.
My System SpecsSystem Spec
Reply

 ATI 4850 driver issues




Thread Tools




Similar help and support threads
Thread Forum
Driver issues after using Driver Booster 2
I used Driver Booster 2 last night after seeing that it got the update to v2.0, so ran it and saw that my drivers were out of date. I let it update them and ever since this I've been having issues getting these drivers to work properly again. System restore doesn't go back far enough, reinstalling...
Drivers
Strange ATI 4850 and June AMD Driver Issue
Strange ATI 4850 and June AMD Driver Issue Ok, so I am having a strange issue with my ATI 4850. When I get new driver(s) I test the driver(s) on a old IDE hard drive. If the new drivers are stable I install them on my raided hard drives. Here is my issue. My 4850 will only work on the IDE...
Graphic Cards
Ati 4850 problems
Hi, I recently installed RTM Windows 7 Pro. Before i had 7000,7056 and 7100. On 7000 and at 7056 i've had similar problem i have now. When i try to refresh my Windows Experience Index my screen goes black with colour boxes and i have to restart computer. Screen goes black when windows try to...
Graphic Cards
ati 4850
Hi guys I'm getting a new pc in a week or 2 and I have a question about the graphics card drivers. I want to install windows 7 x86 version, but which ati drivers should i install with it? When I looked at the ati driver page, there were no drivers for windows 7 x86 version. Can anyone help me...
Drivers
ATI 4850 gpu
second question. Running win7 and phoshop cs4, how do I know gpu mode is used ? Photoshop seems not to detect gpu it asks to consult a site where no specific information is availaible Would love to see the effect, or is photoshop cs4 picking up gpu automaticaly ?
Graphic Cards
4850 wei
Hi Everyone, I Just installed Build 7057 x64 and usually my GPU makes it to 7.9 in the WEI and now it's gone to 5.9 and gaming graphics to 6.0. There's something really wrong here. I have 2 4850's Can anyone help me out here.
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:28.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App