Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 Professional Won't Detect My Radeon HD 4670

15 Feb 2010   #31
Rik55

Windows 7 Home Premium (64-bit) SP1 RTM
 
 

Is the picture you posted of the actual card you got, cos that is the AGP version.

The PCI-e version below, has a different interface/slot.




Have you tried plugging the monitor into the other port on the card.


My System SpecsSystem Spec
.
16 Feb 2010   #32
Frostplague

Windows 7 Professional 64 bit
 
 

Quote   Quote: Originally Posted by Rik55 View Post
Is the picture you posted of the actual card you got, cos that is the AGP version.

The PCI-e version below, has a different interface/slot.




Have you tried plugging the monitor into the other port on the card.
My bad, however, I have the PCI-E version with 2 HDMI ports. The motherboard only have 1 PCI-E slot. I contacted the website's support, and they told me to test the card in another computer, which I will as soon as I can get a hold of my brother's computer.
My System SpecsSystem Spec
16 Feb 2010   #33
neo101

WIN7 Ultimate 64bit
 
 

Pins/contacts sticking up on the motherboard.

On loads of M'boards you have to short out two pins with a connector to turn the onboard graphic chipset on & off (as well as in the bios)- so you can use a proper full size graphics card. The pin instructions in your motherboard manual can be reversed ie wrong too - Taiwanese english manuals etc are renowned for it!

Are you putting the PCI-e card in the correct slot to fit it's type? ie cope with it's thruput??

Haven't you got any friends you can try this card in their PC to test it then send it back if it's faulty. Plenty are faulty even straight out of the box, you may have statically zapped it if you didn't earth yourself first before handling it.

Have you looked on the net to see if anyone else has a problem with your M/board?

Why are you not talking/contacting your retailer for advice - they did supply the stuff?
My System SpecsSystem Spec
.

03 Jul 2010   #34
alap1983

Windows XP SP3 by eXPerience
 
 

Please refer to my System Specs in the Lower-Left Corner.

I had similar problem: Let me briefly describe it.
My earlier 18" Monitor Worked very well with HD4670. However, when I connected the 22" Full HD Monitor, the System would Boot-Up... Reach the Log-on Screen & then it would go Blank!!

After some trouble-shooting & searching online... I summarized that the Card is the Culprit. Disconnected it & the Ran the system on On-Board Graphics... Got it Working!!!

Further the Problem is slightly unique... Using HD4670... the System Completely / Fully Boots-Up & Starts ALTERNATIVELY!!! i.e First Boot--> Normal Start-Up-->Shut-Down--> Second Boot--> No Display!---> Reset Boot--> Fully Working!!

Hence the ATi is to blame for NOT Releasing corrected drivers.. This is definitely a Software issue.

Here's how I "sorted out" the problem:

1) Remove Card from PCIe & Connect Monitorto On-Board Graphics
2) Enter BIOS & Set Display to Int Display First-->PEG & Int. On-Board Graphics--> If no card on PEG is present (Believe me, this may seem illogical... But the System is being made to understand...)
3) Install Windows 7... If you have an already set-up system...chances are you have also installed Catalyst Control Center (CCC). THEN:
a) COPY the contents of the ATi Display Software (Usually located in: C:\Ati). This is to be done to GET The Drivers... If you do not know where to find the folder... Then reinstall CCC & Note the "Extract Folder"
b) Uninstall CCC & ALL Drivers of ATi Card. The system will then show display at VERY LOW Rez..... eg: 640 x 480... Its OK.
4) Shut-Down
5) Physically install the Card BACK into the system & Connect Monitor to it.
6) Wait 5-10 Sec-->Start-up
7) Win7 should detect the Card & install ITS OWN Drivers for it... Its OK
8) After Install is complete... Go the Screen resolution (Right-Click on Desktop)--> Advanced--> Display Adapter--> Properties--> Driver--Update Driver--> Manually provide location--> Ati Folder--> Win7 will pick-up the relevant drivers & install them....
9) Now you will have Ati Card & Drivers WITHOUT CCC installed on your System... If this is fine... OK... If Not... then install CCC IF YOU WANT.
10) Now REBOOT (It may be Prompted after install... DO IT.. DO NOT Select "Reboot Later")
11) The System will start-up correctly.
12) Now do a Proper Shut-Down--> Wait for 5-10 Sec & Start-Up.
13) You should have a correctly running system
14) If you do---> Create "Image" & store it safe...
My System SpecsSystem Spec
03 Jul 2010   #35
alap1983

Windows XP SP3 by eXPerience
 
 

It is being said that installing the Following will Solve the issues.... Lemme Try...:
Catalyst AGP Hotfix - Radeon HD 4000 Radeon HD 3000 and Radeon HD 2000 Series AGP products
My System SpecsSystem Spec
03 Jul 2010   #36
alap1983

Windows XP SP3 by eXPerience
 
 

Opps My Bad... The above-mentioned Link seems to be ONLY For AGP Cards.. Not PCIe...
My System SpecsSystem Spec
11 Jul 2010   #37
Frostplague

Windows 7 Professional 64 bit
 
 

My problem was solved by replacing the motherboard. Please feel free to contribute additional possible solutions, as it may help others facing similar issues.
My System SpecsSystem Spec
Reply

 Windows 7 Professional Won't Detect My Radeon HD 4670




Thread Tools




Similar help and support threads
Thread Forum
Driver issue in windows 7 (ATI Radeon Mobility 4670)
Quick summary of my issue: I just bought a new acer (link) and proceeded to install windows 7 (64-bit) straight ahead. I must admit i made a bit of a mistake when i didn't check if the box it got shipped in contained any drivers or such (which it didn't to my surprise!) Currently got experience...
Graphic Cards
Sapphire radeon hd 4670 - Need Help!!!!!!!!!!
I am facing a lot of problem with my Sapphire radeon hd 46701gb ddr3 card. This is my second thread to help me for solving this problem. Aero doesn't run even with the latest driver or the old drivers i have tried all the things like enable force to run aero that doesn't work. And also use services...
Graphic Cards
Gigabyte ATI Radeon 4670 HD
pls..i need help..if somebody who have using same GC above, can u give the original backup bios of your...i update my GC bios n then my display flickering....i need to restore back my GC bios :cry:
Graphic Cards
Radeon 4670 trouble
I recently did some upgrading to switch from windows XP 32-bit to windows 7 32-bit. Included in my upgrades was the installation of HIS Ati Radeon HD 4670 graphics card. I chose this card because my motherboard still has an AGP slot, and the reviews said that it works well with windows 7. ...
Graphic Cards
nvidia geforce 9800 gtx+ vs. ati radeon hd 4670
i have both of these graphics cards and I am wondering which one is better. the nvidia has 512mb while the ati has 1 gb. i have put them both in the computer and I can't really tell the difference. The windows experience index rates the nvidia as a 6.3 and the ati as a 6.7, but the nvidia performed...
Graphic Cards
Radeon 4670 device trouble
I recently did some upgrading to switch from windows XP 32-bit to windows 7 32-bit. Included in my upgrades was the installation of HIS Ati Radeon HD 4670 graphics card. I chose this card because my motherboard still has an AGP slot, and the reviews said that it works well with windows 7. However,...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:26.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App