Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: HD5850 "Display driver stopped responding"

30 Jan 2010   #21
CptZiggy

 
 

Yes, id didnt find any errors on my ram.

Tried to install x32 bit 7 but got this error message:

0x80070570


My System SpecsSystem Spec
.
30 Jan 2010   #22
CptZiggy

 
 

Quote   Quote: Originally Posted by smarteyeball View Post
Quote   Quote: Originally Posted by CptZiggy View Post
I did ran driversweeper, no CCC installed.

Bluescreen came out of nowhere.
When did you run driversweeper? before or after letting Windows update install the drivers?

Have you checked your RAM with memtest86+ by any chance?
Unistalled all ATI drivers and CCC rebooten into safemode, ran driversweeper, reebooted, 5 minutes in a got a bluescreen.

Trying another CD with Windows 7 x32, or should I go for XP?
My System SpecsSystem Spec
30 Jan 2010   #23
TVeblen

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

I spent uncountable hours trying to correct my TDR problem with bluescreen crash using a GTX260 after installing W7 (TDR = Timeout Detection Recovery = "Display Driver Stopped Responding and has Recovered"). It turns out that the video card was bad. The strange thing was that I was using it without problems in the same rig for 9 months with XP-SP3! After doing countless diagnostics I finally bought a new GeForce 9500GT card for $50 to use while I RMA'd the GTX260 back to EVGA. Installing the 'new' card ended all my video problems. When I got the replacement card back and installed it there were no problems. Both cards use the same nVidia drivers.
So my advice is to not rule out a bad card. Ultimately that is what you may be dealing with.
My System SpecsSystem Spec
.

30 Jan 2010   #24
CptZiggy

 
 

I'll ship it back on monday!

Damn, than I'll be without a decent computer for weeks!
My System SpecsSystem Spec
30 Jan 2010   #25
TVeblen

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

That's why I bought the cheap card. I wasn't going to go 3 weeks without the puter! Plus for $50 I knew for sure what the problem was.
My System SpecsSystem Spec
30 Jan 2010   #26
CptZiggy

 
 

I wish the 50 bucks cards could easily drive CODMW2 and Bad Company 2..

Well, I got another CD of 7 x86, and trying again.. So atleast I can play 5 minutes at the time
untill monday.
My System SpecsSystem Spec
30 Jan 2010   #27
CptZiggy

 
 

After another reinstall of windows, the problem is still present. That's it, im quitting, I've tried everything, Im shipping it back on monday! But I have a feeling that this problems may happen to all 5850 cards.. Which GPU do I want if I want to stay out of this kinda trouble?
My System SpecsSystem Spec
30 Jan 2010   #28
TVeblen

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

A working card is probably fine. Your card isn't working. Why it isn't working is a good question (maybe I should post it). I theorize that windows 7 is much more video intensive than previous OS's, or is using the hardware differently. This TDR problem is pervasive across both vendors and every product line. The variety and inconsistency of the solutions that work for some people but not for others point out , to me, that a card must be working flawlessly to overcome the error threshold.
But this is all speculation. Maybe if I have one more drink I can solve world peace too!
My System SpecsSystem Spec
30 Jan 2010   #29
CptZiggy

 
 

No, my card isnt working, but is something wrong with card? Doubt it.
My System SpecsSystem Spec
30 Jan 2010   #30
CptZiggy

 
 

Sorry about doble posting.. but after a while on google it appears that I have to turn off TDR?

How do I do that in Windows 7? I found a guide how to do it in Vista, but I can't find the TDR reg?
My System SpecsSystem Spec
Reply

 HD5850 "Display driver stopped responding"




Thread Tools




Similar help and support threads
Thread Forum
"Display driver has stopped responding and has recovered"
I get that loads of times with an accompanying mini freeze which lasts anywhere from 2-4 seconds whenever I attempt to play Final Fantasy XIV. After multiple attempts at trying to fix these problems, I got to the conclusion that it may vary just a tiny bit according to driver version(for me at...
Graphic Cards
"Display driver nvlddmkm stopped responding" only when watching video
Hello, I'm getting the message "Display driver nvlddmkm stopped responding and has successfully recovered." when watching video files or online video streams. I'm sure this is not linked to temperatures or high usage, as I can run FSX with maximum settings for hours at a time without anything...
BSOD Help and Support
Laptop "display driver stopped responding and has recovered" errors
I've been having problems with artifacts (sprinkled dots and rainbow-ish shapes) popping up on my screen whenever I put my laptop to any more demanding use, like games, videos, hi-res images, etc. This leads to the system hanging up, repeated "Driver stopped responding and recovered errors", and...
Graphic Cards
Another "Display driver has stopped responding..." AMD Radeon 6850 new
I got a new AMD Radeon HD 6850 video card just a few days ago and installed it fine. I installed the software from its disc, updated it, and it works great. However, I've found that about once a day, late at night, after the comp has been on for many hours, the screen will freeze for...
Graphic Cards
"Display driver stopped responding and recovered" error
Hi there, I am new here and I am not computer guru. So I ran the test earlier today , and everything was fine. Max temperature after 11 minutes running the test was as far as I can remember not more than 85 it stayed stable with only 1 degree difference from time to time till I stopped the...
Graphic Cards
The nightmare called : "Display driver XYZ stopped responding"
E5200 @ 2.5GHz Gigabyte GA-73PVM-S2H Corsair 2 x 2GB DDR2 800MHz 600W PSU which supplies 36A combined on 2 x 12V rails GeForce GTS 250 1GB (DK version) Win 7 64bit Ultimate Bios settings default, nothing OCed. When Im in windows browsing internet or listening to the music everything is...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:07.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App