Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: ATI Catalyst Control Centre not installing with 7

12 Feb 2010   #1

ATI Catalyst Control Centre not installing with 7

Hey guys
New guy here.
I am in HELL!
I installed Windows 7 on My Vaio laptop a few days ago.
The machine had factory installed Vista.
Its a Due core 2.4 with ATI Radeon HD 3400, 4 GHZ ram

The install went fine and it asked for the nuking of the ATI software to facilitate install. I did that and all was well.

The computer works great except for the fact that when I put out to my Samsung 55" display it majorly underscans.

I remembered that this was previously rectified in the CCC controls.
So I went to ATI downloaded the latest drivers, 10.1 and installed them. Smooth install no problems. The drivers took and all was well.

THe CCC software is no where to be found.
I've since then read so many posts on this topic that I am getting quite sick.:)

I've tried every recommended solution here and in other forums. I've tried many other drivers, I've tried Drive sweeper, I've tried un installing Microsoft .Net Frameworks. Nothing works.

The one thing that I noticed while installing the various ATI packages that never not once is the CCC shown as actually installing. The only thing that ever installs is the drivers, the registration and the Manager.

I use this laptop as my HTPC right now, and untill I installed Windows 7, its been great. But now I am watching all my pretty HD movies with a 1.5 inch black bracket all around the screen.

PLEASE PLEASE PLEASE, has anyone solved this yet? It seems to have been going on for at least 6 months...


My System SpecsSystem Spec
14 Feb 2010   #2


Can anyone help please?
I've spent ridiculous hours on this and still same problem
My System SpecsSystem Spec
15 Feb 2010   #3

Windows 7 Ultimate x86-64

In the installer, do you see a checkbox for CCC?
My System SpecsSystem Spec

16 Feb 2010   #4


Nope. There is never a checkbox for CCC. I've tried every driver combo I could find on the net. It always specifies the CCC in the description of the software and then when you install it, the checkbox is not there.
Usually the only checkboxes are, Driver, Registration, and once a World of Warcraft demo, and sometimes a Folding @ home checkbox. I realize that this may very well be the problem, but I have no idea how to include the CCC installer.
I appreciate your help.

My System SpecsSystem Spec
16 Feb 2010   #5

WIN7 Ultimate 64bit

Are you SURE you are not running on the default VGA driver - double check! If Ati driver is installed

Look in C:ATi folder - fire up catalyst setup again follow instructions and restart and it should work.

Cat 10.1 is a complete 'fubar' version for me on a socket A board and ATi 4670 - causes crashes and glitches of graphic driver.
Neither, by the way, see my card - even the Hotfix!
I have to point device driver section at the C: ATi folder after installing to get it to load the driver.

Trouble is there are (x4) 4600series drivers for my card heh heh - so which is it?

Try Catalyst 9.11 for WINDOWS 7(not XP driver) Make sure you use the correct 32bit or 64bit driver too for your puta!
My System SpecsSystem Spec
16 Feb 2010   #6

7 x64 | 7 x64

You have the .net updates?
My System SpecsSystem Spec
16 Feb 2010   #7

Windows 7 Home Premium (64-bit) SP1 RTM

Standard Catalyst drivers from ATI are for Desktops. Try sony to see if they have any updated drivers for Windows 7 on your system. Alternately you could download Mobility Modder. This will modify the drivers for installation on a laptop.

You may well have other problems.

1:- If the Catalyst installer doesn't seem to install the drivers any more:-
install Visuall C++ 2008 SP1 redistributable
(This is for Cat9.12 onwards. For Cat9.11 and earlier it's the C++ 2005 SP1 Redist).
Download details: Visual C++ 2008 SP1 Redistributable Package (x86) x86
Download details: Visual C++ 2008 SP1 Redistributable Package (x64) x64
For Win 7 x64 install both x86 and x64 versions of vcredist.
afterwards, run windows update to pick up any other hotfixes.

2:- If the drivers and the Catalyst Control Centre are installed but CCC doesn't open or run correctly, then the fix for this is to reinstall the .Net 2 framework.
.Net 3.5 SP1 redistributable - this version also installs/updates all previous .Net's (large download 231Mb).
My System SpecsSystem Spec
17 Feb 2010   #8


Positive i am running on a ATI driver
INfo from the properties on the driver
Driver date
Driver v 8.632.1.2000
Provider ATI

Tried 9.11 same results.

Will try Sony for drivers.

I have the C++ 2008 Redistributable

The whole problem here is that the CCC is Not installing...
The drivers always take.
The CCC is never visible in the checkboxes during installation despite being in the download pack.
My System SpecsSystem Spec
17 Feb 2010   #9

Windows 7 Home Premium (64-bit) SP1 RTM

The drivers arn't taking. It may look like they are, but according to the date & driver version, this is the driver downloaded automatically via Windows Update. It's because it's a Notebook. Standard Cat drivers don't contain the nesesary Device Ids for mobile graphic.
My System SpecsSystem Spec
17 Feb 2010   #10



Rik 55 you rock

I downloaded the drivers from Sony. CCC installed. All good, everything works

Thanks so much guys!

My System SpecsSystem Spec

 ATI Catalyst Control Centre not installing with 7

Thread Tools

Similar help and support threads
Thread Forum
Can't Acess AMD catalyst control centre
HI I installed latest drivers from AMD website but when i right click at the desktop and try to acess AMD CATALYST CENTRE IT SAYS, AMD CONTROL CENTRE CANNOT BE STARTED CURRENTLY THERE ARE NO SETTING THAT CAN BE CONFIGURED USING AMD Catalyst control Centre. Help ?
General Discussion
How To Check Which Version Of Catalyst Control Centre I have
Hey guys Please Tell me how can i check which version of Catalyst Control Centre in windows 7
Graphic Cards
Where's Catalyst Control Centre?
Hey everyone, I noticed that my previous ATI drivers seemed to be outdated a little bit, and so decided to try to update them. I've currently got the AMD Vision Engine Control Centre, which is version 12.2, but where can I download an updated version of Catalyst Control Centre? The CCC version for...
ATI Catalyst Control Centre Not Opening
Hi, I have updated to the latest ATI drivers on this page below for my GFX card. The drivers installed okay. However, I'm no having a problem with catalyst control centre not opening I have removed the drivers and used Driver Sweeper in safe mode and reinstalled the the drivers and catalyst...
catalyst control centre problem
everytime i open my pc i get this message: catalyst control centre: host application has stopped working...
Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:09.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App