Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Just upgraded to 7, no Graphics Card appearing

18 Mar 2010   #11
darkassain

Windows 7 Ult x64(x2), HomePrem x32(x4), Server 08 (+VM), 08 R2 (VM) , SuSe 11.2 (VM), XP 32 (VM)
 
 

Quote   Quote: Originally Posted by booose View Post
Ok, well I am downloading the 64-bit driver for Vista now. I hope this works. I'll post more if this doesn't resolve it. Thanks
allright check back with us...:)
just in case these should be your drivers for windows 7 x64
NVIDIA DRIVERS 195.62 WHQL
just looked up your system and it seems there is also a sbios update for fan control
have you installed this already?
Drivers and Downloads


My System SpecsSystem Spec
.
18 Mar 2010   #12
booose

 
 

Thanks guys. It all worked. I appreciate it a lot
My System SpecsSystem Spec
Reply

 Just upgraded to 7, no Graphics Card appearing




Thread Tools




Similar help and support threads
Thread Forum
System will not post with upgraded graphics card
I have been trying to upgrade my graphics card. system is well behaved with old simple graphics card a GB radeon H6450. A month or two back I tried a GB GTX 750 card and had the same problem. Today I bought a GB R7260X thinking maybe it would do better with a Radeon card rather than a nVidia....
Graphic Cards
Random restarts with AMD graphics card but not Nvidia graphics card
Hi for the last 4 months ive been trying to fix a problem that ive been having with my computer. about 4 months ago I did a major pc upgrade where i replaced my motherboard, processor, ram, heat sink, power supply and case, the only things I used from the original computer where 2 HDD's, 1 SDD and...
Graphic Cards
Upgraded gfx card but getting fps lag - please help
Hi, I recently upgraded my graphics from the 550 ti to the gtx 570 and for some reason I get fps lag. This originally happened when i upgraded my motherboard thinking it was just a graphics problem and now it's happening with the new graphics card for some reason. I'm not complaining about...
Graphic Cards
Just upgraded RAM/Graphics Card
Hello, I just added 2 extra 2GB modules to my computer and an better graphics card. However now my computer doesn't seem to boot up. Whenever I press the on button it starts like it should but it doesn't show anything on my screen. Like if my monitor doesn't see the card. Also note that I...
Hardware & Devices
Upgraded graphics from 8800 GT to Radeon 5770
I upgraded my video card from the old GeForce 8800 GT, 512 MB, to the ATI Radeon 5770, 1 GB. Here's a snapshot the Windows Experience Index: http://i49.tinypic.com/2zi7915.jpg Which I got to thinking.. is there a system out there that reports 7.9 in all categories?
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:54.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App