Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Hd 5970 and multiple displays = bluescreen

31 Mar 2010   #21
glowpipe

Windows 7
 
 

Quote   Quote: Originally Posted by Rik55 View Post
It could be the card was faulty all along. With the 5970 in, check each DVI ports. Boot up with F8 and try Safe Mode. If you can get into safe mode, boot up again with F8 and use Low Resolution Mode 640x480 to try and enter Windows. (You don't get any beeps unless your motherboard has an onboard speaker or you have fitted one). Also, can you still Enter the BIOS with the 5970. The 5970 would still be under the manufacturers warranty and you havn't done anything wrong.
I cant enter bios or anything. Its like the graphic card doesnt send out a signal to the monitor at all. Tried both dvi ports and the minidisplay port. Still nothing.


My System SpecsSystem Spec
.
31 Mar 2010   #22
glowpipe

Windows 7
 
 

Sent them an email now. About the card. Should just send it back and get a new one i hope. Since i believe 100% i didnt do anything to harm the card. Not used the overclocking that followed with xfx or the one in CCC.

This card must have been faulty since i got it
My System SpecsSystem Spec
26 Sep 2010   #23
DeltaKINGxxx

Windows 7 Ultimate x64
 
 
HD 5970 issue's

I have had the issue where the pc doesn't display anything with the HD 5970 in the pci slot. But i got it fixed real easy. Two things could be wrong.
1> The drivers you installed after inserting the card could have been installed incorrectly, so what you need to do is remove the card and put in a other card or us onboard, next step would be remove all traces of software for the graphics card and reboot. The use something like CCleaner to clear the registry of the pc. Now reinstall the drivers without the graphics card in, then shut down after installation. Then reinsert the card and it will work, and the drivers will do the rest.
2> Now here is a nasty one, you OC'ed your card, with more than one OC program, you will have to get rid of all the programs including the CCC program and do the same as in (1), or you just forgot to plug in the power cables.
My System SpecsSystem Spec
.

11 May 2011   #24
Exc3ss

windows 7 64 bit
 
 

I dont think it's ram, I have the same problem running crossfire

I previously had an Nvidia 450 gts - never once got a blue screen

I installed 2 ATI 5700 cards and started getting my blue screen.
I wiped out windows 7 and did a clean install because i thought it coulda been the previous card drivers causing issues.

Still getting a blue screen in it seams like all of my games

I have patriot RAM - not the greatest but i wasnt previously getting blue screens.
Its gotta be CCC
My System SpecsSystem Spec
11 May 2011   #25
Exc3ss

windows 7 64 bit
 
 

Quote   Quote: Originally Posted by DeltaKINGxxx View Post
I have had the issue where the pc doesn't display anything with the HD 5970 in the pci slot. But i got it fixed real easy. Two things could be wrong.
1> The drivers you installed after inserting the card could have been installed incorrectly, so what you need to do is remove the card and put in a other card or us onboard, next step would be remove all traces of software for the graphics card and reboot. The use something like CCleaner to clear the registry of the pc. Now reinstall the drivers without the graphics card in, then shut down after installation. Then reinsert the card and it will work, and the drivers will do the rest.
2> Now here is a nasty one, you OC'ed your card, with more than one OC program, you will have to get rid of all the programs including the CCC program and do the same as in (1), or you just forgot to plug in the power cables.
Drivers have been uninstalled/reinstalled various times

I installed on a fresh copy of windows

and i have not overclocked ANYTHING on my system - i am getting the same problem as the poster.

So, a cleanup wouldnt make a difference when the drive was wiped for windows install.
Hitting next next next - i dont see where we could go wrong there.
My System SpecsSystem Spec
Reply

 Hd 5970 and multiple displays = bluescreen




Thread Tools




Similar help and support threads
Thread Forum
Multiple displays
Dell Precision T3500, 2ea nVidia Quadro NVS420 boards installed controlling 6 monitors (2x2 clones and 2 independant). Curently running Win XP Pro I am running with XP because when my IT Dept installed Win 7 they couldn't get the config. I needed with thr 6 monitors so they put me back on Win...
Graphic Cards
Multiple displays without having multiple displays?
Somehow my computer is detecting that I have two displays. I only have one display and that is my TV. I'm using an HDMI cable that is hooked into my Radeon HD 7950 card. I have went into both Catalyst and the Windows screen resolution tool and they are both detecting multiple displays. I'm not...
Graphic Cards
Hotkey to Multiple Displays
Hi, I've been browsing the web to find an answer for my question, but with no luck. I use Windows 7 on a PC which is setup to be both an office and an entertainment computer. Therefore it's connected to two seperate screens with one graphic card. The screens are one 19" desktop screen...
Customization
Multiple displays
Hi My Laptop detects multiple screens when there arenít any attached to my laptop. When this happens my display graphics goes for a toss. i then have to reset/ uninstall the nvidia display driver and reinstall this. ∑ I have also checked the display in device manager there is no other...
Graphic Cards
HDMI Multiple Displays
Computer specs on bottom. Okay i have multiple displays 1 is 40inch TV and the other being my 24inch monitor. For the past few weeks ive had my TV set up DVI(PC)-VGA(TV) and my monitor dvi-dvi. no problems. I recently purchased 2 Dvi-HDMI cables. 1 for my TV 1 for my monitor. Here is my...
Graphic Cards
Using multiple Displays
Hi, Wan't really sure which forum to post this in, hope it's ok here. I have a tv attached to my pc which I sometimes use as a 2nd display. I want to be able to activate or deactivate it easily, without losing the settings and ideally using a hot key. Does anyone know how this can be...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 06:04.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App