Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Something I've noticed?

24 Apr 2010   #1
alphanumeric

Windows 10 Education 64 bit
 
 
Something I've noticed?

I don't know if this is a PCIe thing but its something I noticed with my 220GT. No video card BIOS message during the POST. It goes straight to my motherboard BIOS screen. I don't remember ever having a PCI or AGP card that didn't show a BIOS screen first thing and then pass off to the motherboard BIOS. Something else I've noticed too is the way my 220GT handles dual monitors during boot up. Only the one connected to the DVI connector shows an image during boot up. The one on the VGA port shows a "no signal" until windows loads the desktop and then it shows my extended desktop. Any AGP card I've ever used would mirror the bios screen onto both monitors during the post and boot up. This isn't a complaint, I actually like it this way, just an observation. I'm just wondering if anybody else has noticed something similar?


My System SpecsSystem Spec
.
24 Apr 2010   #2
Heroxoot

Windows 7 Pro
 
 

Are you supposed to get a gfx card bios screen? I do not. Maybe because I have a radeon? I never got one on my 7300LE geforce either.
My System SpecsSystem Spec
24 Apr 2010   #3
TVeblen

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

I have a GTX260. No BIOS screen. But I put in a 9500GT for a short while and did get the BIOS screen. I'm guessing it's the firmware on the card that determines whether you get that or not.
My System SpecsSystem Spec
.

24 Apr 2010   #4
Heroxoot

Windows 7 Pro
 
 

I didnt even know that the cards had a bios. I figured it was all handled in windows and or by the firmware.
My System SpecsSystem Spec
24 Apr 2010   #5
TVeblen

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

No, what we are talking about is when you boot your computer the very first text that comes up on the black screen is a description of the video card and driver. It flashes very quickly, then the usual BIOS screen comes on and goes through it's routine - finding drives, USB devices, etc.
My System SpecsSystem Spec
24 Apr 2010   #6
bobkn

Windows 7 Pro X64 SP1
 
 

The graphics cards I've had in recent years have all had the card's BIOS display turned off.

There are BIOS editors for nVidia and ATI cards that allow the feature to be turned on. As that requires flashing the modified firmware onto the card, it's only recommended for those willing to risk making an expensive brick.
My System SpecsSystem Spec
25 Apr 2010   #7
alphanumeric

Windows 10 Education 64 bit
 
 

I'm guessing its set to not display. There is a 1 or 2 second pause with just a black screen befor my motherboard BIOS screen comes up. For me this is the first time I can remember not seeing the video card BIOS screen during the POST. All my AGP cards show it. A lot of PC components have a BIOS/firmware. Video cards, optical drives, and hard drives, add in RAID cards, etc. Like Bobkn said you can flash some of them like you do your motherboard BIOS. The thing is though, if it ain't broke don't fix it.
My System SpecsSystem Spec
25 Apr 2010   #8
CarlTR6

Windows 7 Ultimate 32 bit
 
 

Quote   Quote: Originally Posted by alphanumeric View Post
I'm guessing its set to not display. There is a 1 or 2 second pause with just a black screen befor my motherboard BIOS screen comes up. For me this is the first time I can remember not seeing the video card BIOS screen during the POST. All my AGP cards show it. A lot of PC components have a BIOS/firmware. Video cards, optical drives, and hard drives, add in RAID cards, etc. Like Bobkn said you can flash some of them like you do your motherboard BIOS. The thing is though, if it ain't broke don't fix it.
Excellent advice. Spot on.
My System SpecsSystem Spec
Reply

 Something I've noticed?




Thread Tools




Similar help and support threads
Thread Forum
Something I Have Noticed
It seems that 90% of the people on here who have a GFX Badge also have a Sig made by someone else. I find that very strange. Could someone elaborate for me?
Chillout Room
Something odd that I noticed
I don't really know if this is a bug or not, but when I hover over an icon on the status bar, the little selection bars stay on the icon I last hovered over. To show you what I'm talking about, here's a picture: I don't really know if that's normal or not, if it is, I just never happened to...
General Discussion
Just Noticed This
Threads: 102,363, Posts: 985,004, Members: 107,682 It won't be long before the Forum has its One Millionth Post. I'm going for it. :p
Chillout Room


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:46.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App