Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: ATI Catalyst Control Center wont open

07 Jul 2010   #21
Jmusgrave

winodows 7 home premium
 
 

I tried your suggestion smartyball, now the processes CCC.exe, and MOM.exe now start up but shut down immediatly, I installed CCC 10.6, but am unsure if I installed it correctly, when I download and install the suite all that installs initially is the install manager, I have to go through and install the rest,not sure if I am doing that right, is there a way to do a 1 click install? I have thought about the express option, but have been told that it will install unnecessary options like video game trials, thanks for your help and patience, im new to graphics cards, my first experience with anything other than on board stuff......

Jamie


My System SpecsSystem Spec
.
07 Jul 2010   #22
Davidxtux

Windows 7 Home Premium 64bit
 
 

Make sure CCC is opening under an elevated status.
My System SpecsSystem Spec
07 Jul 2010   #23
Jmusgrave

winodows 7 home premium
 
 

how di i do that?
My System SpecsSystem Spec
.

07 Jul 2010   #24
Jmusgrave

winodows 7 home premium
 
 

if you meant run as an administrator, it didnt work
My System SpecsSystem Spec
07 Jul 2010   #25
smarteyeball

 
 

To check whether the correct driver did or did not install:

Go to Device Manager > Display Adapters >r-click card > properties > Driver

The driver version for Cat 10.6 is this:

ATI Catalyst Control Center wont open-10.6-dm-driver.jpg

If the driver number shown on yours is different (lower), then the correct driver hasn't been installed - hence the reason CCC opens and closes.

If this is the case, you will have to manually point to the driver:

still on the properties > driver screen :

Update Driver > Browse my computer for driver software

C:\ATI\support\10-6_vista64_win7_64_dd_ccc_enu\Packages\Drivers\Display\W76A_INF\CH100948.INF

(*NB if you are using x86, it should be 32 instead of 64 - the .INF file may also be a different number)


However,if the driver version does match - then there is some other conflict.


My System SpecsSystem Spec
08 Jul 2010   #26
Jmusgrave

winodows 7 home premium
 
 

I am unable to find that driver, I download the updated driver from ati and the number is 8.632.1.2000 driver date is 8/17/2009, I found this driver in the support/packages/display section of my 10.6 download......help?

Jamie
My System SpecsSystem Spec
08 Jul 2010   #27
smarteyeball

 
 

Sorry for the delay. (If it's been longer than 8 hours or so, you can send either a PM or Visitor Message to 'remind me' to check back)

The open/close of CCC does seem to indicate a mismatched driver and CCC suite.

That's definitely an old driver version. It looks like Cat 9.8 from the date. TBH, I'm not sure why it's in your Cat 10.6 folder...

At this stage, I'd try the driver sweeper routine again, but install CAT 10.3 instead of 10.6
My System SpecsSystem Spec
09 Jul 2010   #28
Jmusgrave

winodows 7 home premium
 
 

I tried that and it didnt work, im not sure if Im installing right.......
My System SpecsSystem Spec
09 Jul 2010   #29
smarteyeball

 
 

When installing the CCC suite, does your screen 'flicker or go blank for a second' at any stage?

If it does, that's when the old driver is being removed and the new one is being installed - if it's not flickering or blanking, then it appears that the new driver is not being installed for some reason.

Is yours the admin or standard user account?

Could you post a screenshot of your current driver that's installed in device manager?

https://www.sevenforums.com/tutorials...en-forums.html
My System SpecsSystem Spec
10 Jul 2010   #30
Jmusgrave

winodows 7 home premium
 
 

the screen does go blank and flicker for a second, im just not sure if im installing ccc right that seems to be something that needs to be done after the fact, there are many options in the packages, just not sure what needs to be installed, when I upgraded to windows 7 i just went to the samsung website, now the software isnt there, its kind of confusing, heres the screen shot of the driver

ATI Catalyst Control Center wont open-capture.png

hope this helps

jamie


My System SpecsSystem Spec
Reply

 ATI Catalyst Control Center wont open




Thread Tools




Similar help and support threads
Thread Forum
Catalyst Control Center wont oepn
this is the error i get http://i.imgur.com/QEuojs2.png
Graphic Cards
No matter what i try Catalyst Control Center Wont Install
Hey guys, Recently ive been trying to use my graphic card for a certain program but it was not detecting it. No biggie. Then i realized i couldn't even open my Catalyst Control Center. So i uninstalled it completely using Driver Sweeper, manually deleting file, and Clearing my registry,...
Graphic Cards
Catalyst Control Center missing/Wont install
Hello, I've seen some useful information on this site so I really hope someone can help. I recently upgraded to a HD6870. Installation went OK, have a much better experience with the new card. Then I learnt about Eyefinity and thought I'd give it a go having some spare monitors around. ...
Graphic Cards
Catalyst control center wont install with the newest drivers
My catalyst control center was bugged so i decided to just do a complete uninstallation, which was successful. When i went to do the fresh install, the install manager would not give me the option of install the catalyst control center even though i uninstalled it. i have been looking through...
Graphic Cards
Cant Open CCC (Catalyst Control Center)
Sorry, if this is in the wrong section. I'm very new to these forums. :) Okay, my problem is this... I cannot open the Catalyst Control Center! I was able to open it a little while ago! I system restored and I uninstalled and reinstalled CCC! Still nothing happens. When i right click on my...
Graphic Cards
ATI Catalyst Control Center Wont Appear...
Hi people. I've just installed windows 7 RTM, 32-bit on my Asus, with an ATI Radeon HD 3470 graphics card. The driver for it is installed and working I think, but I can't seem to get the Catalyst Control Center to work.. I've installed the ATI Catalyst™ 9.7 Suite for Windows 7 (32-bit)...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 22:52.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App