Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: ATI HD 5770 1 Gig - Game freezing

21 Jul 2010   #11
Fumz

7 Ultimate x64
 
 

Quote   Quote: Originally Posted by archie123 View Post
Quote   Quote: Originally Posted by Fumz View Post
The spawn lag bug is a known and common issue. To fix it open your anti virus app and set to exclude the BFBC2 folder in Documents and the Battlefield Bad Company 2 folder in Program Files (x86)\Electronic Arts.
its not the spawning lag bug , that was after a respawn not first joining a server , thats why its called a "spawning" bug , he has NO issues after his first join spawn , it was because certain AV apps would scan a certain folder everytime it was accessed and written to by BC2 which was every spawn , causing lag on every spawn after a cpu spike

Maybe a little help instead of sarcasm would be a better option here?

I had the same issue on a few games mate when i had my ATI card mostly BC2 and MW2 , a sudden and huge drop in fps on joining any map for the first time , i put it down to a driver issue and gave up trying to find the fault , i have no such issues with my current setup
So I've not offered the OP help... really?

I understood what the OP said the first time he said it. Yes, there's a spawn lag bug that happens every time you spawn. That does not mean there's not another spawn bug; the bug which the OP is complaining about, that is also related to your anti virus app. The second is as common as the first.

It's also resolved by doing what I said in my first post. Thanks for chiming in; help, in whatever form, is always appreciated.


My System SpecsSystem Spec
.
21 Jul 2010   #12
archie123

Win 10 Home Premium 64 Bit
 
 

there is no other spawn lag bug...................its related to the way ATI cards cache the textures on entering a new map on a new game
My System SpecsSystem Spec
21 Jul 2010   #13
Fumz

7 Ultimate x64
 
 

You sound very sure of yourself. I'm not sure I'd go that far out on a limb considering the many issues the game has; especially with issues directly related to anti virus software.

Yes, there is another spawn bug. I know this to be true because 3 of my clan mates had the exact same issue as the OP, and they fixed it by doing exactly what I said initially. If I recall correctly, a few guys here solved this issue too by following these simple steps.

You seem to be suggesting that the OP continue to not even try doing the one thing that's been demonstrated to actually work. Why you're advocating that is beyond me, but if anyone in this thread isn't being helpful with advice... it sure isn't me.

I've even gone so far as to describe my particular issues with ATI, anti virus and the game. 10.3, 10.4, 10.5 and 10.6 with a 5X series card exhibited none of the problems you attribute to ATI cards. The only way to fix my issue, again, was the simple way most people resolve issues like this.
My System SpecsSystem Spec
.

21 Jul 2010   #14
Solarstarshines

Windows 10 Home Premium 64bit sp1
 
 

my anti virus has a gamer mode and doesn't conflict with anygame play but it depends on what your running i use spysweeper with anti virus

I bet im going to get alot of heat for using that one hahaha most people love norton and mcafee
My System SpecsSystem Spec
21 Jul 2010   #15
DirtRider

Windows 7 Pro 64 bit
 
 

As I said but let me explain it a bit more. I had an 8800 and purchased this card. Now as I was very interested to see the difference I sat in front of my PC with the old card played a few games with no issues. I then uninstalled the old card drivers took it out. Put the new card in installed it with the latest driver V 10.06 that I had already downloaded. Did all the tuning as required. Once tuned in started a new game and from then on I had this issue. I have since then checked CMOS and it has the latest software. Power supply 700 Watt. My anti Virus has a gaming mode as well and it has never conflicted with any game ever?
My System SpecsSystem Spec
21 Jul 2010   #16
DirtRider

Windows 7 Pro 64 bit
 
 

PS - I have now just turned off the complete internet Security App and it made no difference to the problem?
My System SpecsSystem Spec
22 Jul 2010   #17
Fumz

7 Ultimate x64
 
 

It's not the internet security, per se, that's the problem; it's the anti virus itself. Turning off the firewall component is not the same as excluding the two folders from real time scanning, which is what's causing the problem.

Your issue might also be due to traces of nvidia drivers still present on your system. With a 5X series card and 10.6 drivers, you "should" be having no issues. Did you run Driver Sweeper to get rid of your old nvidia drivers?

Give that a shot, then exclude the folders. Yes, I know you have game mode; however, game mode doesn't always work... at least with BC. Again, I was in the same boat as you in terms of game mode: with Bit Defender it only worked sporadically, and with Nod32 it worked great right up until this latest patch. Now that Nod's game mode is broken, excluding the folders is the only thing that works short of uninstalling my anti virus, which is not advised.
My System SpecsSystem Spec
22 Jul 2010   #18
DirtRider

Windows 7 Pro 64 bit
 
 

I tuned off the whole Internet Security apps that includes the anti virus. I did run Driver Sweeper when I unistalled the old card. I then also did it again and killed all the ATI drivers after I picked up this problem and installed them again. Well I talked to my supplier and they are now ordering in a range of gforce cards for me to try. They will arrive on Monday
My System SpecsSystem Spec
22 Jul 2010   #19
Fumz

7 Ultimate x64
 
 

*sigh*

Dependent on which anti virus you're using, it may not be possible to completely turn off/disable real time scanning.

I would have liked to see what happened had you tried the original suggestion, but since you're doing everything but, I guess this is as far as I can go with this.

I hope the new card works out better for you.
My System SpecsSystem Spec
22 Jul 2010   #20
DirtRider

Windows 7 Pro 64 bit
 
 

Believe me it was off, I know how to do this ...... *sigh* Oh and I am running Kaspersky Internet Security 2010. Disable the IS and all the processes are tuned off, unlike in the capture when it is on lol


Attached Images
ATI HD 5770 1 Gig - Game freezing-bios01-jul.-22-09.26.jpg 
My System SpecsSystem Spec
Reply

 ATI HD 5770 1 Gig - Game freezing




Thread Tools




Similar help and support threads
Thread Forum
Game applications are freezing when I execute them...
Hey guys, Since I got my laptop (Windows 7 Home Premium 32-bit) about one year ago, there was something strange with some of my games. Everytime I try to run them the first time once my laptop booted up, nothing happens, so I always have to look into the task manager, kill the process (the CPU...
Software
Computer freezing when playing any game
Hello, could you help me i get strange freezes when im playing games everything is going smoothly until pc just freezes and sound is frozen too but you can hear it it goes like zzzzzzzzzzz all the time. I will provide any info that you need. Darko
BSOD Help and Support
Game Freezing problem
Hi, The problem is following : If a start any game with graphics at high or medium but sometimes on Low too, the game freezes, not long but the game is not running smooth. That wasn't so earlier, what can I do.
Gaming
5770 vs 5850 Return 1 or both 5770's? ATI gfx
Ok, so the cards in question are the 5770 from SAPPHIRE. X 2 in crossfire Newegg.com - SAPPHIRE 100283L Radeon HD 5770 (Juniper XT) 1GB 128-bit GDDR5 PCI Express 2.0 x16 HDCP Ready CrossFireX Support Video Card - Desktop Graphics / Video Cards and 5850 from SAPPHIRE once again. ...
Graphic Cards
Screen freezing up after paying game
WHEN I FINISH PLAYING A GAME THE SCREEN FREEZES UP :( I CAN CLICK AND GET THE CONTEXT MENU ON DESKTOP BUT WHEN I TRY AND CLICK WITHIN THE MENU IT JUST DISAPPEARS :mad: OFF THE SCREEN, START MENU POPS UP WHEN I HIT THE WINDOWS KEY ON THE KEYBOARD BUT SAME AS THE CONTEXT MENU IF I TRY AND CLICK A...
BSOD Help and Support
Windows 7 64 bit RAM and game freezing problems
Hey guys, I had been using the Windows 7 64 bit Release candidate version for some time now. I have finally a bought copy of Windows 7 professional 64 bit and I installed it last night. Here is my problem: I am finding that on games such as Mass Effect and Dragon Age during the...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:37.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App