Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: ATI HD 5770 1 Gig - Game freezing

26 Jul 2010   #31
DirtRider

Windows 7 Pro 64 bit
 
 

Well that was my first ATI and my last one, think I will rather just stick to what I know and has always worked for me. So after all that my Kaspersky had nothing to do with it as I thought


My System SpecsSystem Spec
.
26 Jul 2010   #32
Fumz

7 Ultimate x64
 
 

Quote   Quote: Originally Posted by Solarstarshines View Post
YUP Some hardware just dont like each other Mobo Ram ect

and still people say that certain graphic cards aren't tailor made for certain cpu's this right here proves it is a true situation if you run intel stick with Nvidia you run AMD stick with ATI i think it is only logical and less headache for anyone who is Building a rig just my opinion though
This is utter nonsense.

While it's always good to see someone solve their issues, your "conclusions" were arrived at based on someone who never actually followed the simple directions given; in fact, he did everything but follow the directions.

Because mid-range cards are always more prevalent than high-end cards (price), I'd wager there are more 5770's in circulation playing Bad Company than any other card. Thousands of guys on all kinds of systems play without issue.

Because of what's transpired in this thread, you can't possibly make the claim ATI card don't get along with Intel chipsets: there's just no evidence of that.
My System SpecsSystem Spec
26 Jul 2010   #33
Solarstarshines

Windows 10 Home Premium 64bit sp1
 
 

well fumz i have no issues with ATI that this user has maybe the user themselves are allergic to ATI no disrespect to you Fumz
My System SpecsSystem Spec
.

26 Jul 2010   #34
Fumz

7 Ultimate x64
 
 

No disrespect taken. It's all good.

Don't get me wrong, ATI certainly has issues they're seemingly unable to resolve; their refusal to write decent drivers being the main issue. However, that's completely unrelated to the issue of whether or not a certain card will work with a certain chipset.

There's a lot of hooey floating around, all urban myth, which says ATI cards "work better" with AMD chipsets and nVidia cards "work better" with Intel chipsets. There exists no evidence whatsoever to support this outlandish claim, yet we keep hearing it over and over again.

At least here on the Seven Forums, I'd like to see guys avoid repeating that myth as it's false and does nobody any good. To be sure, there are reasons not to buy ATI, it's just that having a certain chipset isn't one of them.

Cards are made to adhere to a standard: the pci-e lane; they're not made to be chipset specific. Can you imagine the complicated mess that would ensue if cards were actually designed for specific chipsets instead of all of them? I'd hate to have to do my homework on what to buy in that environment.
My System SpecsSystem Spec
26 Jul 2010   #35
Davidxtux

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by Fumz View Post
No disrespect taken. It's all good.

Don't get me wrong, ATI certainly has issues they're seemingly unable to resolve; their refusal to write decent drivers being the main issue. However, that's completely unrelated to the issue of whether or not a certain card will work with a certain chipset.

There's a lot of hooey floating around, all urban myth, which says ATI cards "work better" with AMD chipsets and nVidia cards "work better" with Intel chipsets. There exists no evidence whatsoever to support this outlandish claim, yet we keep hearing it over and over again.

At least here on the Seven Forums, I'd like to see guys avoid repeating that myth as it's false and does nobody any good. To be sure, there are reasons not to buy ATI, it's just that having a certain chipset isn't one of them.

Cards are made to adhere to a standard: the pci-e lane; they're not made to be chipset specific. Can you imagine the complicated mess that would ensue if cards were actually designed for specific chipsets instead of all of them? I'd hate to have to do my homework on what to buy in that environment.
This myth is blasphemy as I run AMD chip with Nvidia card.. and I only have problems when I attempt to run ATI cards with my AMD chip.
My System SpecsSystem Spec
26 Jul 2010   #36
DirtRider

Windows 7 Pro 64 bit
 
 

[QUOTE=Fumz;864026]
Quote   Quote: Originally Posted by Solarstarshines View Post
YUP Some hardware just dont like each other Mobo Ram ect

While it's always good to see someone solve their issues, your "conclusions" were arrived at based on someone who never actually followed the simple directions given; in fact, he did everything but follow the directions.
What part of the directions did I not follow, short of doing a format and installing W7 again. Oh and BTW I was very close to doing this as well. Further to what I was told here I had also opened a ticket with Sapphire and every last step they gave me had already been done by me. They also had no idea what to tell me further

Quote   Quote: Originally Posted by DirtRider View Post
Ok I uninstalled the anti virus in fact the whole IS Apps (I suppose you cannot do more than this can you) the problem is still as it was before.

Now what ???????
Your conclusion was that the above was the issue. Well as I mentioned here before I installed the new card I had the anti virus running again. Still did not work on the old card (ATI HD) but 10 min later worked on the new card (GeForce). Further to this I had the tech from the supplier here so he could also see what the issue with the HD was. He is also stumped like I was. So in conclusion your analysis of it being the anti virus causing my issue was incorrect.

Also as I mentioned in this thread when I got the new card I played a game on the old card before so I could see the difference straight off, 10 min later when the new card was installed I had the problem. The only thing that had changed was the card. So straight off it tells me I had a card issue. However I followed the advice of the anti virus even when I knew that was not the issue
My System SpecsSystem Spec
26 Jul 2010   #37
Fumz

7 Ultimate x64
 
 

Quote   Quote: Originally Posted by DirtRider View Post
What part of the directions did I not follow... Your conclusion was that the above was the issue.
You didn't follow any part of the directions. I can't make it any more clear than that. Why you can't see that is beyond me? I asked you to try A, you did B, C and D; avoiding A like the plague thinking you just knew better, which is fine, but let's not pretend you followed anything, because you didn't.

You have no idea what my conclusions are; you were dancing to your own drum. If you had actually done what I said and it didn't work, I was going to suggest using 10.5a drivers next... but... since you never got past my very first post (post #2 in this thread), we'll never know if we could have resolved the issue.

Like I said, I'm glad you got your issues fixed, but like I also said, again way back, you can't make the horse drink.
My System SpecsSystem Spec
26 Jul 2010   #38
DirtRider

Windows 7 Pro 64 bit
 
 

Oh boy ok I give up then you are right it was the anti virus.

Simple faulting in my books is you have A working you put B in and you have a problem put A back problem gone then to me it looks like B is faulty, BUT you just could not get past the virus issue lol. Oh and when I uninstalled the anti virus just on that slim off chance an dasked what next no more suggestions were coming from you

Quote   Quote: Originally Posted by Fumz View Post
The spawn lag bug is a known and common issue. To fix it open your anti virus app and set to exclude the BFBC2 folder in Documents and the Battlefield Bad Company 2 folder in Program Files (x86)\Electronic Arts.
And you still did not listen when I said I it worked on my 8800 but 10 min later not on the ATI (The freezing issue that is) I was experiencing the bug that we all know about with the server search. That issue is still with me even on the GTS 470 but it does not worry me as it is not an in game playing issue and I still use the workaround for that one
My System SpecsSystem Spec
26 Jul 2010   #39
Fumz

7 Ultimate x64
 
 

I told you what others had done to solve the same issue you complained about. You didn't try it. It was clear to me a few pages ago that you weren't going to.

I stopped giving you advice for much the same reason as I don't talk to stop signs... the conversation goes nowhere, the stop sign isn't a very good listener. You don't continue to give advice to people who demonstrate they're unwilling to follow it, right? What's not sensible about that?

You solved (almost) your issue all on your own, which is good. Again, that's really the important part.
My System SpecsSystem Spec
27 Jul 2010   #40
DirtRider

Windows 7 Pro 64 bit
 
 

Ag Fumz, I suppose you don't want to see through the fact that I had already done what you suggested even if I knew it was not the issue. I am not a noob when it comes to PC's.

1. Stopping all prossesors of an application means it may as well not be there?
2. Uninstalling said application means it is not there.

WHAT more should I have done to satisfy you that it was not the anti virus that I was having my issue with.

I can understand like was suggested here that I may still have some drivers that were not uninstalled from the NVIDIA. However I ran driver sweep a few times and uninstalled ATI drivers and ran driver sweep also. Then installing the ATI drivers again. Also the fact that I was following all instructions from my support ticket with Sapphire having already done all what they though the problem was.

I still feel as does the tech from the supplier that the card was faulty. IS ATI bad I cannot say I just had a bad experience with it first time using it so I will just rather stick to what I know
My System SpecsSystem Spec
Reply

 ATI HD 5770 1 Gig - Game freezing




Thread Tools




Similar help and support threads
Thread Forum
Game applications are freezing when I execute them...
Hey guys, Since I got my laptop (Windows 7 Home Premium 32-bit) about one year ago, there was something strange with some of my games. Everytime I try to run them the first time once my laptop booted up, nothing happens, so I always have to look into the task manager, kill the process (the CPU...
Software
Computer freezing when playing any game
Hello, could you help me i get strange freezes when im playing games everything is going smoothly until pc just freezes and sound is frozen too but you can hear it it goes like zzzzzzzzzzz all the time. I will provide any info that you need. Darko
BSOD Help and Support
Game Freezing problem
Hi, The problem is following : If a start any game with graphics at high or medium but sometimes on Low too, the game freezes, not long but the game is not running smooth. That wasn't so earlier, what can I do.
Gaming
5770 vs 5850 Return 1 or both 5770's? ATI gfx
Ok, so the cards in question are the 5770 from SAPPHIRE. X 2 in crossfire Newegg.com - SAPPHIRE 100283L Radeon HD 5770 (Juniper XT) 1GB 128-bit GDDR5 PCI Express 2.0 x16 HDCP Ready CrossFireX Support Video Card - Desktop Graphics / Video Cards and 5850 from SAPPHIRE once again. ...
Graphic Cards
Screen freezing up after paying game
WHEN I FINISH PLAYING A GAME THE SCREEN FREEZES UP :( I CAN CLICK AND GET THE CONTEXT MENU ON DESKTOP BUT WHEN I TRY AND CLICK WITHIN THE MENU IT JUST DISAPPEARS :mad: OFF THE SCREEN, START MENU POPS UP WHEN I HIT THE WINDOWS KEY ON THE KEYBOARD BUT SAME AS THE CONTEXT MENU IF I TRY AND CLICK A...
BSOD Help and Support
Windows 7 64 bit RAM and game freezing problems
Hey guys, I had been using the Windows 7 64 bit Release candidate version for some time now. I have finally a bought copy of Windows 7 professional 64 bit and I installed it last night. Here is my problem: I am finding that on games such as Mass Effect and Dragon Age during the...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:10.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App