Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: external HDD can't be initialized "the device is not ready"

27 Mar 2012   #11
Night Hawk

W7 Ultimate x64/W10 Pro x64 dual boot main build-remote pc W10 Pro x64 Insider Preview/W7 Pro x64

Welcome to the Seven Forums! meem

I assume you are plugging the 3tb drive in by usb and not eSata port correct? You need to see the drive initialized by paying the Disk Management tool a visit. You can opt to bring down to bring down the Action menu and click the rescan if needed. (see attached image)

But once you spot the 3tb volume in the DM you simply right click on that to use the Change Drive Letter option. Windows will then detect and mount the volume on the drive as a new logical drive using the drive letter you select and be seen in Windows Explorer. Often you may also see a flashing popup notification that a new drive had been found as well.

Attached Images
external HDD can't be initialized "the device is not ready"-dm-rescan-disk.jpg 
My System SpecsSystem Spec
07 May 2012   #12

Windows 7 Professional 32 bit

Hi, i have exactly the same problem as erikegg69 but for my LaCie Hard Drive, Design by F.A. Porsche, and i can't find anything on the LaCie website. Anyone can help me? I tryed everything but it always say me that the "Device is not ready".

My System SpecsSystem Spec
08 May 2012   #13
Night Hawk

W7 Ultimate x64/W10 Pro x64 dual boot main build-remote pc W10 Pro x64 Insider Preview/W7 Pro x64

Hello Bieffe Welcome to the Seven Forums!

If you just bought the drive new and it shows Windows/Mac compatible it will see an exFat 32bit factory volume on the drive you can simply reformat to NTFS and then right click on the volume in the Disk Management tool to use the Change drive letter option. Other drives may come with NTFS factory volumes you might also want to nuke off of the drive in favor of simply seeing a new NTFS primary partition put on yourself instead.

Simply doing that one thing will immediately see the drive appear in Windows Explorer or Computer. What this does is initialize the drive or in the case of a usb flash drive or memory initialize the device. The information that comes along with the drive like a quick start pamplet would explain this to some extent.

The main reason for the immediate error has nothing to do with a defective drive or Windows glitch but just the need to get the dirive initialized in order to make it available for use.
My System SpecsSystem Spec

08 May 2012   #14

Windows 7 Professional 32 bit

It doesn't work because i just can't see the drive wherever i look for it in the disk management tool...

And thank you for the quick answer and the welcome word!
My System SpecsSystem Spec
08 May 2012   #15
Night Hawk

W7 Ultimate x64/W10 Pro x64 dual boot main build-remote pc W10 Pro x64 Insider Preview/W7 Pro x64

First you would need to look at the basic items since you are not seeing in the DM. If you simply forgot to turn it on... oops!

That happened to me when two ports on a usb hub simply gave out while having something charging by way of usb. I had forgotten that until nothing showed when turning the power on. Took a fast look to find the cord still unplugged and turned the enclosure off until plugged in.

Now if you haven't forgotten anything without realizing it and the drive is still not seen despite checking ac adapter at the wall outlet or back off drive casing, usb cord not only at the pc end but the end that plugs in at the drive end, and the on/off switch or button then you could be looking at either a bad drive if the casing has an led that comes on or a bad ac adapter if this was just bought where you can bring it back for refund or exchange.

While a bad drive should still allow it to be seen in at least the DM first before WE a totally dead drive is possible while nowhere near as likely as a DOA ac adapter! Or a contact inside the casing may have ended up with a cold solder point where the drive while enclosed there will never see power.

The "device is not ready" message definitely points to the drive being detected as an unknown device as Windows sees it but not available if the drive is not getting any power. In the Device Manager one idea besides looking under "disk drives" would be going to the menu bar>View to select the "show hidden devices" option there. If the drive is to be seen at all that would be the place to start unless you know the drive had been working before now.
My System SpecsSystem Spec
20 Jun 2012   #16

Windows 7 Enterprise x64
external HDD can't be initialized "the device is not ready

Dear all, I'm new here.
I had the same problem about an External HDD. All the instructions didn't help.
BUT I discovered something else. I had the HDD connected to the USB on one of the screen USB connection. When I changed the USB connection direct to the Laptop the HDD worked, and I could read all data. So I think some of the USB deliver not enough power!
My System SpecsSystem Spec
20 Jun 2012   #17
Night Hawk

W7 Ultimate x64/W10 Pro x64 dual boot main build-remote pc W10 Pro x64 Insider Preview/W7 Pro x64

Welcome to SF! Kraems

Is your external drive self powered or usb powered? Most see an ac adapter so they won't pull on the usb bus. But some however are usb powered.

When starting up the laptop without the external HS plugged in and then plugging it in you should see a flashing popup as far as how the Auto Play settings in the Control Panel or need to simply take a trip into the Control Panel>Administrative Tools>Computer Management>Disk Management tool to simply scroll down to the new volume found there and right click to change the drive letter. Once you select a letter this will initialize the drive and see the volume on it mounted as a new logial drive in Windows Explorer with the flashing popup usually to open for viewing, etc.
My System SpecsSystem Spec
22 Jul 2012   #18

windows 7 ultimate 32bit

i too have the same problem.
my iomega 160gb ext hd ... the device manager shows the hard disk is connected but when i try to format it using the disk management tool it shows the disk is not ready.

please help me!!
My System SpecsSystem Spec
22 Jul 2012   #19
Night Hawk

W7 Ultimate x64/W10 Pro x64 dual boot main build-remote pc W10 Pro x64 Insider Preview/W7 Pro x64

Hello karthick Welcome o the Seven Forums!

When you go back into the Disk Management tool trying clicking to highlight the external drive and going upto the Action tab on the menu bar to see if the Rescan option will help. The next step if the All tasks>format option fails would be opening up a command prompt and type the following commands.

At the prompt type:

DiskPart = starts up the DiskPart partition manager
List Disk = all hard drives will be listed as Disk 0, Disk 1, Disk 2, etc.
Select Disk # depending on which will be found for that based on actual size
Clean = removes factory NTFS or exFat volume
Create Partition Primary = primary generally preferred over any extended volume even on storage drives
Format FS NTFS or Format FS=NT60 can be typed in lower case
Active = marks partition as active
Exit = closes DiskPart tool

If you see the sucessfully... type message you can close the command prompt and simply go back into the DM to right click and select which drive letter you want to have. You should then see the popup for new hardware found and possibly a prompt to scan the drive by the av program you are running.
My System SpecsSystem Spec
23 Jul 2012   #20

windows 7 ultimate 32bit

they can see the DRIVE in the my computer but mine is completely different... i can't see the drive in my computer but it is detected ............ how can i solve this problem when i tried to put it in offline its showing "the media is write protected" can i solve it.....................
My System SpecsSystem Spec

 external HDD can't be initialized "the device is not ready"

Thread Tools

Similar help and support threads
Thread Forum
WD EXTERNAL HARD DISK 1TB suddenly "unallocated" and "not initialized"
Hi guys. I'm new here. I've tried to read all the discussion about how to fix the unallocated hard drive but I just can't understand it as the cases were pretty much different than I'm facing of. Here's my problem. Yesterday my external hard drive seems normal, everything is fine, until...
Hardware & Devices
"Your device is ready to use" Notification Disappears too Quickly
Recently, I restore to an older system image after I updated my AMD chipset driver incorrectly. And on reboot after the restore, I got the "Your device is ready to use" Notification but it disappear as soon as a moved my mouse. Is there a way to view what device(s) was made ready after...
Hard Disk can't read in "my computer ", "initialized",I/O device error
I have a big problem here, I have used my hard disk for 9month, Yesterday when I watched movie on the half way, My hard disk suddenly disfuntion, And I thought my laptop problem due to always lagging so I restart my computer. But after that I can't read my hard disk (WD)in my computer. It can...
Hardware & Devices
Hard Drive "Not Initialized", "device is not ready",won't recognize
I used a DriveWire - Universal Hard Drive Adapter (IDE / PATA / SATA to USB HDD Adapter) to hook up A 3.5" Hard Drive (Samsung model HD502HJ) to my desktop in an attempt to get my wife's files off her old desktop machine and merge them into mine. It all started off fine, the drive was recognized...
Hardware & Devices
Bought a new hard drive-"Device is not ready" when trying to initializ
A while ago, my desktop was having problems. It would BSOD persistently through restarts and eventually, it stopped working completely. When i turned it on, it would make all the startup sounds (hard drive spinning, fan starting, etc), the hard drive would click a few times, and it would all start...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:52.
Twitter Facebook