Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: external HDD can't be initialized "the device is not ready"

30 Jul 2012   #31
Night Hawk

W7 Ultimate x64/W10 Pro x64 dual boot main build-remote pc W10 Pro x64 Insider Preview/W7 Pro x64
 
 

There's no partition on it to be renamed. vunguyen27 Welcome to SF! by the way.

What you see there is a raw unpartitioned and formatted drive to start with not having seen even a factory volume for either NTFS or exFat. First the Partition Table and then the partition(s) to be seen have to be created as well as formatted before the drive can be made useable.

If both of these drives are 3.5" sized drives you wouldn't be able to install them internally for sure while the use of a live cd program like Partition Wizard or GParted simply to see if a live method is able to work with them would be a thought. The screens back in Post #23 show how to do it while in the Disk Management tool. Those were created after having wiped the drive shown there using the Clean command in the DiskPart tool.

That would be the other option seen in Windows by way of the command prompt to see a new volume created. You first need something on the drive(s) however before they can actually be initialized by simply right clicking on the new volume to select a drive letter. Then Windows will proceed to mount the volume as a new logical drive.

The reeason for suggesting a live cd however is to get past any OS problems or restrictions that could be getting in the way as far as using the simple option right seen right there in the DM tool. If the controllers are good on the external casing as well as the usb enclosure you should have any problem with partitioning either of the two.


My System SpecsSystem Spec
.
31 Jul 2012   #32
uttam

windows 7 ultimate 32bit
 
 

@vunguyen27: there is no solution for this even my HDD got the same problem as yours i have tried all the possibilities but no use the media in that is damaged.....
My System SpecsSystem Spec
31 Jul 2012   #33
Night Hawk

W7 Ultimate x64/W10 Pro x64 dual boot main build-remote pc W10 Pro x64 Insider Preview/W7 Pro x64
 
 

One reason I suggested installing it internally for a 3.5" model would be on a desktop to find out if the drive itself or the controller is toast. Since one drive was placed into a separate enclosure but if still being seen in the DM that shows the drive itself is functional to a certain extend that is.

Some years I had one go belly up when you could read everything on the drive but could not write to it in any form. The write heads part was foobar! That drive wore out prematurely however rather then being a defective HD.

For anything external these days I simply slap a new drive into an enclosure rather then buying anything self contained models. That can help recover data from both ide and sata drives alike when an old case finally gives out.

For a not too pricey fan cooled enclosure some of the Acomdata models can be looked over at Newegg.com - Computer Hardware, AcomData, External Enclosures, SATA & IDE

That would be a consideration for you, erikegg69 over continuing to fuss with what seems like a bad controller. So far I've had one of the three models in use now for the last years and swapped drives in and out both ide and sata without one problem as long as the drive was still working.

I could have opted for one seeing an eSata connection but had to go univeral here since I seem to be the one looking after Vista and 7 laptops as well as XP, Vista, and 7 desktops.
My System SpecsSystem Spec
.

11 Aug 2012   #34
karthick

windows 7 ultimate 32bit
 
 

thank you night hawk for your instructions.

all completed successfully but still the hard drive fails to show up as a drive in mycomputer.

what should i do?
My System SpecsSystem Spec
11 Aug 2012   #35
Night Hawk

W7 Ultimate x64/W10 Pro x64 dual boot main build-remote pc W10 Pro x64 Insider Preview/W7 Pro x64
 
 

I would start looking at the usb port you are using as well as the cable the drive came with and port on the external enclosure as a possible cause. If you have a bad port on the system or enclosure which is always possible or a bad cord needing to be replaced that will stall the works! Often the enclosures use the same type of cord as the usb cable for a printer noting the smaller square shaped connector on one end.

Once you can rule any possible usb problem removing the drive from the enclosure to install internally especially if you are running on a desktop there to see if the drive itself is good or bad. This will isolate the drive itself from everything else.

If it partitions and formats on the spot then you would know the problem is simply tracing it back to a connector or port or even bad controller on the enclosure itself. But if it still fails to see working results then you will know the drive is foobar and should return it for exchange or refund if you had just bought it.
My System SpecsSystem Spec
02 Sep 2012   #36
MukulSharma

Windows 7 Home Premium 32bit
 
 
similar problem

i have got the similar problem with my wd(1 tb). it is showing up in disk management and devices and printers but not in my computer. when i try to initialise the disk in disk management, it says the request could not be performed because of an I/O device error. please tell me how to get it work again...
My System SpecsSystem Spec
02 Sep 2012   #37
Night Hawk

W7 Ultimate x64/W10 Pro x64 dual boot main build-remote pc W10 Pro x64 Insider Preview/W7 Pro x64
 
 

Hello MukulSharma Welcome to SF!

The next time you are in the Disk Management look for the square section at the beginning of the volume for the external drive there. Right click on that to see if you can change it from offline to online. Then go upto the menu bar>Actions to select the rescan option before a right click on the volume itself to use the Change drive letter option.

Sometimes a new drive plugged in or installed internally even will be in the offline status. Once that is back online a rescan will let Windows know it is. From there you simply assign a drive letter to get it going and appear in WE.

The other thing to do in the Device Manager while not generally needed would be looking for any "other devices" usually being the mass storage controller wasn't detected and installed automatically by Windows as it should have been since WD drives are Plug'n'Play to start with. The driver install needs a little push at times to get that going.
My System SpecsSystem Spec
03 Sep 2012   #38
MukulSharma

Windows 7 Home Premium 32bit
 
 

external HDD can't be initialized "the device is not ready"-device-manager.png

external HDD can't be initialized "the device is not ready"-disk-management.png

i am not getting the option for getting it online. please have a look at the attachments. these are the options i am getting in device manager and disk management. also rescanning disk is not helping.
i did get the option to initialize the disk earlier, but i don't know why m not getting it now. bt even on selecting the option for initializing, it just said that the request could not be performed because of an I/O device error. and now if i select the offline option, then again it says the same thing.. I/O device error...


My System SpecsSystem Spec
03 Sep 2012   #39
Night Hawk

W7 Ultimate x64/W10 Pro x64 dual boot main build-remote pc W10 Pro x64 Insider Preview/W7 Pro x64
 
 

Likely the first thing you will need to do there is see a Partition Table created. The DM shows the drive is actually online but lacking what it needs! By right clicking in the volume area you may see the prompt for this.

Is this on a WD Eseentials or newer model series? On the Essentials those are shipped with exFat volumes to be Windows/Mac compatible. The Windows only models will ship with NTFS or be found "raw". With self contained drives generally a factory volume would be present however.

The external enclosure is being reported but not the drive itself apparently. You may received a bad drive. The fact that the enclosure is online indicates the mass storage controller is showing up. This is why I suggested taking a look in the Device Manager there to see if the usb enclosure item is present.

During 7 beta and RC testing I actually followed one guide to remove the drive itself to run it internally. But the drive was seen immediately when first plugged in new with the factory partition on it.
My System SpecsSystem Spec
17 Sep 2012   #40
dellstudio1234

windows 7 home premium 64 bit
 
 
external HDD can't be initialized "the device is not ready

hello night hawk
I have same problem,it says I/O device error and other times data error (cycle redudancy check) from disk manager.I have tried everything you have suggested and now when i try to do a clean all from cmd its says"diskpart has encountered an error,the semaphore timeout period had expired.see the system event log for more info".Have been trying to fix this WD terradisk for 2 sleepless nights now and it was sent from the USA and barely a year old.Please please help me out on this one
My System SpecsSystem Spec
Reply

 external HDD can't be initialized "the device is not ready"




Thread Tools




Similar help and support threads
Thread Forum
WD EXTERNAL HARD DISK 1TB suddenly "unallocated" and "not initialized"
Hi guys. I'm new here. I've tried to read all the discussion about how to fix the unallocated hard drive but I just can't understand it as the cases were pretty much different than I'm facing of. Here's my problem. Yesterday my external hard drive seems normal, everything is fine, until...
Hardware & Devices
Hard Disk can't read in "my computer ", "initialized",I/O device error
I have a big problem here, I have used my hard disk for 9month, Yesterday when I watched movie on the half way, My hard disk suddenly disfuntion, And I thought my laptop problem due to always lagging so I restart my computer. But after that I can't read my hard disk (WD)in my computer. It can...
Hardware & Devices
Truecrypt says "Device not ready" when trying to mount a volume?
Ok I am trying to remount my backup HDD after formatting my main media HDD with truecrypt. But now my media backup HDD isn't mounting and giving me the following error: The device is not ready Your system is not configured to auto-mount new volumes. It may be impossible to mount...
General Discussion
Hard Drive "Not Initialized", "device is not ready",won't recognize
I used a DriveWire - Universal Hard Drive Adapter (IDE / PATA / SATA to USB HDD Adapter) to hook up A 3.5" Hard Drive (Samsung model HD502HJ) to my desktop in an attempt to get my wife's files off her old desktop machine and merge them into mine. It all started off fine, the drive was recognized...
Hardware & Devices
Bought a new hard drive-"Device is not ready" when trying to initializ
A while ago, my desktop was having problems. It would BSOD persistently through restarts and eventually, it stopped working completely. When i turned it on, it would make all the startup sounds (hard drive spinning, fan starting, etc), the hard drive would click a few times, and it would all start...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:12.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App