Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows sees DVD drive, but not the disk

06 Aug 2010   #1

Windows 7 Professional
Windows sees DVD drive, but not the disk

I built my own system (I've done this many times before) and thought I got a quality DVD combo drive - a Plextor sata - and used it to install Windows 7 Professional on my new machine. It was going fine and I last used the drive to install MS Office 2007 Professional's first disk. I restarted the computer and then wanted to install the bonus stuff on disk 2. Windows wouldn't access the disk.

I tried other disks, nothing. I looked in Windows Explorer and, sure enough, the drive was there, but didn't indicate it had a disk in it. I looked at Device Manager and, as usual, it reported the drive was working properly - even though it wasn't. And the drive was recognized in Disk Management and I was able to change the drive letter to V (I always rename the DVD to V).

My assumption was it was a bad drive. I got the royal run-around from Plextor tech support and the guy was very rude, so I opted to buy a new drive. It came yesterday, an Asus DRW-24B1ST. I'll be damned if it didn't have the same problem.

I have uninstalled the drive through Device Manager and physically, changed the sata port on my motherboard - I've got 6 ports and tried 5 of them (the 0 spot is taken by my HDD). No joy. I found a registry fix that I thought might work, but not. I did the fix routine on the Microsoft website and that didn't find anything.

This is driving me nuts. I'm too old for this anymore. I actually thought my last computer was going to be my last computer, but the doctor was wrong and I outlived it.

My mobo BIOS recognizes the drive. Windows recognizes the drive. But I couldn't play a video, listen to music or install a program from the drive to save my life. Surely I can't be the only one with a problem like this. But I can't find anything here, on Google or anywhere else to fix it.

Thanks for letting me be grumpy.


My System SpecsSystem Spec
06 Aug 2010   #2
Crunchy Doodle

Windows 7 Ultimate x64

Sometimes Windows 7 can take several minutes to recognize a DVD or CD that's placed in a DVD drive. I find this quite annoying. Other times it's instant. When it didn't see the DVD you put in, did you allow several minutes (not seconds) for the disk to be recognized? This is made worse if your have more than one optical drive letter, or change the drive letter.

My System SpecsSystem Spec
06 Aug 2010   #3

Windows 7 Professional

Sometimes hours. I left disks in the drive for very long periods of time thinking I would be able to solve the problem and continue. I'd open Windows Explorer (or my favorite, Directory Opus) and try to view files on the disk, but the file manager would never be able to see a disk in the drive. I'd get an error message about putting a disk in the drive. Changing disks did nothing. Using the PlexUtilities was possible and the software could make the drive door open and close and it could do its thing, but it wouldn't play or run a disk.

When I got the first drive, the Plextor, I installed the utilities and Nero Essentials that came with it. I believe now that I installed Office before I installed the drive software because I was anxious to get my email back. It is when I installed the drive's software that it stopped working.

The Plextor software was still on my machine after I installed the new drive from Asus. Based on my experience from years back, I knew there was a possibility that Nero would know the Plextor was gone and would produce an error message if and when I could ever use the software. So, last night I uninstalled Nero and PlexUtilities.

This was about 5am this morning, actually - last night to me. Just before I decided to finally go to bed, I wanted to take the disk I had out of the drive before shutting the computer down. I hit the button and up pops a warning that there is no disk in the drive. Something recognized there was a disk in there, for crimony sakes. I opened the drive door again and put the disk back in. It started right up and asked me if I wanted to install the software.


I am assuming it was either PlexUtilities or Nero Essentials that killed the drive. Now I am afraid to install the copy of Nero that came with the Asus drive. But it works. The drive works now.

On a side note... have you ever lived in Quincy? You look like a guy I'd see around town once in a while up here.

Thanks and sorry for the false alarm - except that now I wish I knew what software killed my drives. :)

My System SpecsSystem Spec


 Windows sees DVD drive, but not the disk

Thread Tools

Similar help and support threads
Thread Forum
Laptop no longer Sees 2nd Sata Drive!
My primary internal Sata HD (C:/ 500gb) was almost full and I wanted to backup Movies/TV/Music/Videos and Data to another supplemental drive. I purchased a Sata HD caddy and a second Sata HD drive (E:/ 750gb) SEE PICS 1, 2, 3, that fits my DVD/CD slot on my IBM/Lenovo optical drive slot and...
Hardware & Devices
Computer sees new hard drive in System recovery but not is Bios
I replaced my hard drive, when I go to startup repair screen and select computer it shows my new hard, C: with X: labeled as boot, however when I check my BIOS it does not show my new hard drive. Also when I try to boot from hard drive I receive the BOOTMGR missing error, I have tried all of the...
Backup and Restore
Computer sees DVD drive but not disk
I have a mysterious problem with my DVD drive. I bought a new Gateway Win 7 computer in April. It came with a Hitachi DVD burner on drive D (which my research has since found is not a very good drive.) Initially the drive worked but over the last two months it has generally lost the ability to...
Hardware & Devices
Help please windows Backup sees DVD drive only
Not able to do a backup because windows backup only sees the dvd drive and not 2 other USB drives..therefore I can not backup.. any ideas..drives are showing in device manger etc no probs
Backup and Restore
Windows only sees part of external USB drive.
I have a new 1 Tb. Western Digital hard drive in a Rosewill USB/eSATA enclosure that I want to use for back up. When I turn on the enclosures power switch I see an icon in the taskbar and when I hover the mouse pointer over it it says 'Safely remove hardware and eject media'. However, when I...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:37.
Twitter Facebook Google+