Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Shows one or the other but not both

10 Aug 2010   #1
imessedup2

win 7 32bit
 
 
Shows one or the other but not both

In BIOS my HDD Drive will be detected as Master but my DVD Rom set as slave is undetected, and when i set my DVD Rom as Master my HDD is not detected.


My System SpecsSystem Spec
.
10 Aug 2010   #2
tezlewis

Windows 7 Ultimate 64-Bit
 
 

are you sure the DVD drive is set to Slave. Check your jumpers on the back of the DVD drive. Are any set to Cable Select"?
My System SpecsSystem Spec
10 Aug 2010   #3
profdlp

Main - Windows 7 Pro SP1 64-Bit; 2nd - Windows Server 2008 R2
 
 

Quote   Quote: Originally Posted by tezlewis View Post
are you sure the DVD drive is set to Slave. Check your jumpers on the back of the DVD drive. Are any set to Cable Select"?
Good idea.

I never used to trust Cable Select to figure it out right and always wanted to set things manually. (I'm an old guy and stuck in my ways.) It works pretty well, though.

It's been a while since I went the Master/Slave route (1864, to be exact - just an inside joke) but you used to also have to have the Master drive at the end of the cable.
My System SpecsSystem Spec
.

10 Aug 2010   #4
alphanumeric

Windows 10 Education 64 bit
 
 

Quote   Quote: Originally Posted by profdlp View Post
Quote   Quote: Originally Posted by tezlewis View Post
are you sure the DVD drive is set to Slave. Check your jumpers on the back of the DVD drive. Are any set to Cable Select"?
Good idea.

I never used to trust Cable Select to figure it out right and always wanted to set things manually. (I'm an old guy and stuck in my ways.) It works pretty well, though.

It's been a while since I went the Master/Slave route (1864, to be exact - just an inside joke) but you used to also have to have the Master drive at the end of the cable.
(Assuming you have the 80 wire 40 pin IDE cable) If you use cable select on both drives the drive connected to the end of the cable will be master, and the one connected to the center will be slave. If you jumper the drive as Master it doesn't matter what connector it is connected to, it will be master.
My System SpecsSystem Spec
10 Aug 2010   #5
alphanumeric

Windows 10 Education 64 bit
 
 

Quote   Quote: Originally Posted by imessedup2 View Post
In BIOS my HDD Drive will be detected as Master but my DVD Rom set as slave is undetected, and when i set my DVD Rom as Master my HDD is not detected.
Some IDE hard drives require "TWO" jumpers to be set if they are a "MASTER with a SLAVE". Check the sticker on the drive to see if it lists the required jumper settings. It might be easier to set both drives to CS, cable select. Also you can't mix and match, if one drive is set to cable select the other has to be also if they are both on the same IDE cable.
My System SpecsSystem Spec
Reply

 Shows one or the other but not both




Thread Tools




Similar help and support threads
Thread Forum
DXDiag shows DirectX 11 but Windows Experience Index shows DirectX 10
Hello, I just did a clean install on my laptop after installing a new SSD. I installed the drivers that I had to install manually, and then I did a Windows update for anything else. After getting everything setup I ran my first Windows Experience Index. Surprising, the graphics score was...
Performance & Maintenance
1tb hard drive shows unallocated & shows error cyclic redundancy error
Hello, My toshiba extrnl 1tb hard disk changed to raw aftr abrupt power cut whn drive was cnnectd to pc. After sum research tried method of test disk on win 7. I followd the procedure and writed partion. But aftr rebootng nw disk changed to unallocated. I tried initializing disk to mbr but it...
Hardware & Devices
NVIDIA Geforce 210 shows 1GB when box shows 512
Hey so I have an Nvidia Geforce 210, and the box says its 512 MB, but both the info displays on Windows XP and 7 say It has 1 GB. I'll add a screenshot. Any clues? Thanks guys!
Graphic Cards
my 750 GB HD shows only 698 GB
Hi, I just got a new HD and tried to just plug it in on my old HD with w7 but I can't find it anywhere no meter that it get recognized and installed at the beginning, I tried to install my old XP and it shows only 698 GB on the other hand W7 shows 715GB.This HD is 750GB.And shouldn't those anti...
Hardware & Devices
64 Bit Os shows only 3,25 GB ram of 4
Hello I got an problem, i installed 2x Patriot 2GB stick on my board. But system only shows 3,25 GB of 4GB ram. I not found any memmory remaping option in BIOS
Hardware & Devices
HDD shows up, shows data, no folders or files visible
I just reinstalled Windows 7 64bit after a crash. I reconnected my second HDD to the machine where prior to the crash I stored all my photos and music. The problem is that there appears to be no folders or files visible in the drive, despite it showing over 300GB of used space. See the...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:40.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App