Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Permissions stuck on HDD from previous WinXP PC

17 Aug 2010   #1

Windows 7 Ultimate x64 (SP1)
Permissions stuck on HDD from previous WinXP PC

Hi Guys!

I'm having this very weird problem! I just bought a new PC and installed on it Windows 7 Ultimate x64.

I also unplugged my WD 1000GB Caviar Green Hard Drive from my old PC and connected it to the new one.

The problem now is that Windows 7 refuses to grant me permissions to change the folders/files from 'read-only' on my 1000GB drive from my old system.

At first when I tried to do that I got the typical message "You will need to provide administrator permissions to change these attributes". Then I had the option of clicking 'Continue', so I clicked it, and then it looked like it updated the permissions anyway. However once I clicked on 'OK' and the re-opened the folder properties, it was again set to 'read-only'.

I then opened the 'Security' tab, and saw that there was an 'unknown user' in the list there, which was probably the user from my old PC's WinXP installation. I then proceeded to delete that user, and made sure that my username had 'Full Control', and I also set the owner to my username. However, none of this has helped since I still keep getting the message "You will need to provide administrator permissions to change these attributes", and then it's the same thing again... it looks as if Windows 7 proceeds to changes the permissions, but after you click 'OK' and the re-open the properties it's still set to 'read-only'.

I tried changing the permissions and ownerships on a folder by folder basis, and also for the entire drive. I also tried between changing the ownership from my username to 'Administrator' (my username has full Admin privileges as well). Still, the problem persists!

At this point I'm completely at a loss as to what to do next... so I'm hoping this forum can give me some answers! Any help or advice will be greatly appreciated!


My System SpecsSystem Spec
17 Aug 2010   #2

Windows 7 Ultimate x64 (SP1)

My System SpecsSystem Spec
17 Aug 2010   #3

Windows 10 Pro x64 x3, Ubuntu

Hi John and welcome to Sevenforums

This is a long running issue with NTFS based windows but I think it may be made more difficult to solve with the UAC in place.This is one of those occasions tha I would advise switching off UAC. What you are doing is the correct procedure though I would always advise the take ownership first then add full control to your user then remove the unknown user.

Depending on the complexity of the folder structure you may have to repeat the procedure for any stubborn sub trees

I would personally add full control for administrators group and your actual user plus give everyone read and execute permissions once you have this set in the top level folder use the replace permissions in sub-folders and files option in the advanced dialogue to cascade down the tree.

once all is finished and working reset UAC and check normal operation
My System SpecsSystem Spec

17 Aug 2010   #4

Windows 7 Ultimate x64 (SP1)

Okay, I managed to resolve it! ^^

Thank you very much for the help Barman58, much appreciated! :)
My System SpecsSystem Spec

 Permissions stuck on HDD from previous WinXP PC

Thread Tools

Similar help and support threads
Thread Forum
Problem with previous versions: "No previous versions available"
I (stupidly and accidentally) deleted all files in my "Downloads" folder. As in, hard deleted them - not to the recycle bin. I right-clicked the folder and picked "Properties", "Previous versions". Lo and behold, there were several previous versions. I opened the one from today, browsed through...
Backup and Restore
Previous Versions not working-There are no previous versions available
Hi, Whenever I try to restore a file (right click > "Restore previous versions") that I know has recently changed, I see: "There are no previous versions available" on the file's "Previous Versions" tab. I've been running Windows 7 x64 Business for a long time now, and I have never seen it...
Performance & Maintenance
Restore Previous Versions always says "There are no previous versions"
I've set up a scheduled daily backup of particular data folders on my C drive. The backups are taking place as scheduled, and the latest versions of the files are appearing in the backup. But when I use Win. Explorer and right-click>Restore Previous Versions, no previous versions show up. Daily...
Backup and Restore
Stuck on Windows splash screen, safe mode stuck on classpnp.sys
After a power outage 3 weeks ago I was having issues with the system going down at around 5 minutes and then less and less time after that. I was told it was a display issue and to uninstall and reinstall my display drivers. I uninstalled my drivers and it was still the same. I felt like it was...
General Discussion
Outlook stuck outbox- Not conventional 'stuck' either
Hi Guys, We have a single user here that has problems with stuck outbox messages in outlook. Off of only one of his email accounts in his profile. Off of only his computer. There are definitely some patterns of characteristics from the emails though, which I would imagine have something to do...
Microsoft Office

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:32.
Twitter Facebook Google+