Optical USB mouse lags!!!


  1. Posts : 16
    Microsoft Windows 7 Ultimate - 6.1.7601 - x64
       #1

    Optical USB mouse lags!!!


    Hi everyone, I have a really weird problem. I have a simple USB optical mouse. The mouse sometimes lags! It stops moving, and it also doesn't have reaction for pressing buttons. It wasn't annoying really, until I started to play an FPS game. The lagging is sometimes short but still annoying, and I think it depends on CPU load which could be low, but sometimes it stucks at low CPU load too. Weird. I had a PS/2 optomechanical mouse before this, which was good, but I started to hate to clean it.
      My Computer


  2. Posts : 3,140
    Systems 1 and 2: Windows 7 Enterprise x64, Win 8 Developer
       #2

    - check batteries
    - is optical receiver visible (line of sight)?
    - did it always lag?
    - try changing video settings
      My Computer


  3. Posts : 16
    Microsoft Windows 7 Ultimate - 6.1.7601 - x64
    Thread Starter
       #3

    Oh sorry I didn't said, it's not wireless. And no it not always lags, just sometimes, for example, when I open an application, and my HDD is working, but it's weird, because in the case of the also not wireless (PS/2) mouse there was no problem like this.
      My Computer


  4. Posts : 2,964
    Windows 7 Professional SP1 64-bit
       #4

    Is this on a desktop or laptop? If desktop, do you have both of the mice you mention plugged in at the same time?
      My Computer


  5. Posts : 3,140
    Systems 1 and 2: Windows 7 Enterprise x64, Win 8 Developer
       #5

    Do you have a clean surface for the mouse to be on?
    Did you clean the optical part on the bottom?
      My Computer


  6. Posts : 16
    Microsoft Windows 7 Ultimate - 6.1.7601 - x64
    Thread Starter
       #6

    It's a desktop computer, and my mouse is on a clear surface. I had two mice plugged in, but I disconnected the PS/2 one, but it is still not perfect. Sometimes I press a mouse button, I release it, but it doesn't detect in time. Sometimes I drag the tabs in Google Chrome because of the for example. So it is sometimes stops, when I move, sometimes, it doesn't detect mouse button release correctly. It delays.
      My Computer


  7. Posts : 2,964
    Windows 7 Professional SP1 64-bit
       #7

    You might want to try using one of these:

      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 03:03.
Find Us